cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2469
Views
0
Helpful
11
Replies
Highlighted
Beginner

Configuring ORR in IOS XRv

Hi,


I am trying to configuring ORR in IOS XRv according the documentation in https://www.cisco.com/c/en/us/td/docs/routers/virtual-routers/configuration/guide/b-xrv9k-cg/b-xrv9k-cg_chapter_0110.html. I have a test network ensambled with IOS XRv 9000 Version 6.2.25, but i have problems when i try to replicate the configuration that is in the documentation optimal-route-reflection g1 192.0.2.2.

I have not the option to place the IP Address of the RR

RP/0/RP0/CPU0:ASR-UY1(config-bgp-nbr-af)#optimal-route-reflection group1 ?
  <cr>  

Despite of that i try to configure, but the configuration fail

RP/0/RP0/CPU0:ASR-1(config-bgp-nbr-af)#sho config
Fri Mar  2 19:31:10.023 UTC
Building configuration...
!! IOS XR Configuration version = 6.2.25
router bgp 65000
 neighbor 1.4.3.1
  address-family vpnv4 unicast
   optimal-route-reflection group1
  !
 !
!
end


RP/0/RP0/CPU0:ASR-1(config-bgp-nbr-af)#commit
Fri Mar  2 19:31:07.364 UTC

% Failed to commit one or more configuration items during a pseudo-atomic operation. All changes made have been reverted. Please issue 'show configuration failed [inheritance]' from this session to view the errors

RP/0/RP0/CPU0:ASR-1(config-bgp-nbr-af)#sho confi fail
Fri Mar  2 19:31:13.068 UTC
!! SEMANTIC ERRORS: This configuration was rejected by
!! the system due to semantic errors. The individual
!! errors with each failed configuration command can be
!! found below.


router bgp 65000
 neighbor 1.4.3.1
  address-family vpnv4 unicast
   optimal-route-reflection group1
!!% 'BGP' detected the 'warning' condition 'Invalid arguments'
  !
 !
!
end

If anyone can help me, i will be very grateful.

 

Regards

José

3 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted

No Problem..

 

we have a good document on this by Luc, however i am not sure how to make it externally accessible.

 

https://techzone.cisco.com/t5/XR-Platform-Independent-Topics/Border-Gateway-Protocol-BGP-Optimal-Route-Reflection/ta-p/901677

 

Need to check on this

View solution in original post

Highlighted
Highlighted

i made a mistake in my earlier post.

it seems vpnv4 is not supported for ORR

from an internal note we see the following

 

BGP ORR is supported for IPv4 Unicast and IPv6 Unicast
not supported for IPv4 Labelled unicast (VPNv4) 
not supported for IPv6 Labelled unicast (VPNv6)
not supported for  VPNv4 and VPNv6 support 

 

 

View solution in original post

11 REPLIES 11
Highlighted
Cisco Employee

Hi Jose,

 

this is a new feature to me, can we check if the optimal-route-reflection group is under the bgp address family? if possible can you provide your bgp config? i can try in our lab

 

router bgp 9730
 address-family ipv4 unicast
  optimal-route-reflection group1 1.1.1.1
 !
 neighbor 2.2.2.2
  remote-as 100
  address-family vpnv4 unicast
   optimal-route-reflection group1
  !
 !
!
end
!
Highlighted

Hi,

 

Thanks for your response, i try with a new clean config that i attach below and i have the same problem.

 

 

RP/0/RP0/CPU0:ASR-UY1#sho runn router bgp
Thu Mar 8 16:40:57.037 UTC
router bgp 65000
address-family vpnv4 unicast
!
address-family vpnv6 unicast
!
neighbor-group RR
remote-as 65000
update-source Loopback0
address-family vpnv4 unicast
!
address-family vpnv6 unicast
!
!
neighbor 10.4.3.1
use neighbor-group RR
!
neighbor 10.4.4.1
use neighbor-group RR
!
vrf Internet
rd 65000:65000
bgp bestpath as-path multipath-relax
address-family ipv4 unicast
redistribute connected
!
!
!

When i try to config below the address family without a neighbor or a neighbor-group i don't have this option.

 

 

 

 

RP/0/RP0/CPU0:ASR-UY1(config)#router bgp 65000
RP/0/RP0/CPU0:ASR-UY1(config-bgp)# address-family vpnv4 unicast
RP/0/RP0/CPU0:ASR-UY1(config-bgp-af)#opt?
                                     ^
% Invalid input detected at '^' marker.

And when i want to configure under the address-family but below a neighbor-group i do not have the option to add the RR IP, and when i try to commit without this option i have the problem that the commit fails with an error

!!% 'BGP' detected the 'warning' condition 'Invalid arguments'

.

 

 

 

RP/0/RP0/CPU0:ASR-UY1(config-bgp-vrf-af)# neighbor-group ANTEL_RR
RP/0/RP0/CPU0:ASR-UY1(config-bgp-nbrgrp)#  address-family vpnv4 unicast
RP/0/RP0/CPU0:ASR-UY1(config-bgp-nbrgrp-af)#optimal-route-reflection ?
  WORD  ORR group name - maximum 32 characters
RP/0/RP0/CPU0:ASR-UY1(config-bgp-nbrgrp-af)#optimal-route-reflection group1 ?
  <cr>  
RP/0/RP0/CPU0:ASR-UY1(config-bgp-nbrgrp-af)#optimal-route-reflection group1 
RP/0/RP0/CPU0:ASR-UY1(config-bgp-nbrgrp-af)#commit
Thu Mar  8 16:10:29.524 UTC

% Failed to commit one or more configuration items during a pseudo-atomic operation. All changes made have been reverted. Please issue 'show configuration failed [inheritance]' from this session to view the errors
RP/0/RP0/CPU0:ASR-UY1(config-bgp-nbrgrp-af)#sho confi fail
Thu Mar  8 16:10:33.028 UTC
!! SEMANTIC ERRORS: This configuration was rejected by 
!! the system due to semantic errors. The individual 
!! errors with each failed configuration command can be 
!! found below.

router bgp 65000
neighbor-group ANTEL_RR
address-family vpnv4 unicast
optimal-route-reflection group1
!!% 'BGP' detected the 'warning' condition 'Invalid arguments'
!
!
!
end

 

 

Thanks for your time

José

Highlighted

from reading configuration examples can we try this?

router bgp 6500
 address-family ipv4 unicast
  optimal-route-reflection group1 1.1.1.1
 neighbor-group ANTEL_RR
address-family vpnv4 unicast
optimal-route-reflection group1

 

Highlighted

Thanks, i could paste this configuration. To be honest is a little bit confuse for me, to configure the feature in address-family ipv4, to be enable to configure the address-family vpnv4.

 

I will try continue the deploy in my network and test this feature more deeply.

 

router bgp 65000
 address-family ipv4 unicast
  optimal-route-reflection group1 1.1.1.1
 !
 address-family vpnv4 unicast
 !
 address-family vpnv6 unicast
 !
 neighbor-group RR
  remote-as 65000
  update-source Loopback0
  address-family vpnv4 unicast
   optimal-route-reflection group1
  !
  address-family vpnv6 unicast
  !
 !
 neighbor 10.4.3.1
  use neighbor-group RR
 !
 neighbor 10.4.4.1
  use neighbor-group RR
 !

 

Thanks for your time

José

Highlighted

No Problem..

 

we have a good document on this by Luc, however i am not sure how to make it externally accessible.

 

https://techzone.cisco.com/t5/XR-Platform-Independent-Topics/Border-Gateway-Protocol-BGP-Optimal-Route-Reflection/ta-p/901677

 

Need to check on this

View solution in original post

Highlighted

Thanks a for your time again.

 

Regards

José

Highlighted
Highlighted

Thanks ...

Highlighted

Hi,

 

To be honest i recently have time to test in deep in my development enviroment, and i can make that the ORR works with VPNv4.

 

I follow the steps that the document https://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/212881-border-gateway-protocol-bgp-optimal-ro.html and i add the configuration necesary to test vpnv4.

 

The configuration in my vRR is

router bgp 65000
 address-family ipv4 unicast
  optimal-route-reflection ppp 1.4.1.1
 !
 address-family vpnv4 unicast
 !
 neighbor-group PE
  remote-as 65000
  update-source Loopback0
  address-family ipv4 unicast
   optimal-route-reflection ppp
   route-reflector-client
  !
  address-family vpnv4 unicast
   optimal-route-reflection ppp
   route-reflector-client
 !
 neighbor 1.4.1.1
  use neighbor-group PE
 !

router isis backbone_Int
 net 49.0001.0010.0400.3001.00
 distribute link-state
 address-family ipv4 unicast
  metric-style wide
  maximum-paths 32
 !
 interface Loopback0
  address-family ipv4 unicast
   metric 1
  !
 !
 interface GigabitEthernet0/0/0/0
  point-to-point
  address-family ipv4 unicast
   metric 15
  !
 !
 interface GigabitEthernet0/0/0/1
  point-to-point
  address-family ipv4 unicast
   metric 15
  !
 !
!


And when i try to see if in the neighbor is applied this feature i can not see this.

RP/0/RP0/CPU0:RR-01#sho bgp neighbor 1.4.1.1
Wed Aug  8 15:58:45.109 UTC

BGP neighbor is 1.4.1.1
 Remote AS 65000, local AS 65000, internal link
 Description: ASR-EU1
 Remote router ID 1.4.1.1
 Cluster ID 1.4.3.1
  BGP state = Established, up for 01:44:43
 ...
 
 For Address Family: IPv4 Unicast
  BGP neighbor version 0
  Update group: 0.3 Filter-group: 0.0  No Refresh request being processed
  Route-Reflector Client
  ORR root (configured): ppp; Index: 0
    Extended Nexthop Encoding: advertised
  Route refresh request: received 0, sent 0
  ...          
 For Address Family: VPNv4 Unicast
  BGP neighbor version 11
  Update group: 0.1 Filter-group: 0.1  No Refresh request being processed
  Route-Reflector Client
  Route refresh request: received 0, sent 1
  ...

I will be very gratefull if you can help me.


Regards.

José

Highlighted

i made a mistake in my earlier post.

it seems vpnv4 is not supported for ORR

from an internal note we see the following

 

BGP ORR is supported for IPv4 Unicast and IPv6 Unicast
not supported for IPv4 Labelled unicast (VPNv4) 
not supported for IPv6 Labelled unicast (VPNv6)
not supported for  VPNv4 and VPNv6 support 

 

 

View solution in original post

Highlighted

Thanks, you know if this feature is in the roadmap for VPNv4 and VPNv6?

 

Regards

José

Content for Community-Ad