cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

165
Views
0
Helpful
5
Replies

DHCP Server Configuration on ASR 9010 does not work

Hi,

I have problem setting up the dhcp on the asr 9010 equipment.
My settings are as follows:


--> ASR 9010
!
interface GigabitEthernet0/0/0/1
description ***Conect to sw***
vrf client_Multiservicos
!
interface GigabitEthernet0/0/0/1.41
description === Dados ===
vrf client_Multiservicos
ipv4 address 10.51.23.254 255.255.255.0
encapsulation dot1q 41
!
interface GigabitEthernet0/0/0/1.60
description === Management ===
vrf client_Multiservicos
ipv4 address 10.51.5.254 255.255.255.0
encapsulation dot1q 60
!
pool vrf client_Multiservicos ipv4 Dados
 address-range 10.51.23.1 10.51.23.250
!
dhcp ipv4
 profile Dados server
  pool Dados
  allow-move
  dns-server 10.1.1.1 10.1.1.2
  domain-name test.local
  subnet-mask 255.255.255.0
  default-router 10.51.23.254
!
interface GigabitEthernet0/0/0/1.41 server profile Dados

###########################

--> Switch 3650 

interface Ethernet0/0
description *** CONNECT ASR 9010 ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 41,60
switchport mode trunk
!
interface Vlan60
description *** Managment ***
ip address 10.51.5.253 255.255.255.0
!
ip default-gateway 10.51.5.254
!
interface Ethernet0/1
description ***CONNECT PC***
switchport access vlan 41
switchport mode access
duplex auto

 

 

Pc does not catch ip by dhcp. But if I configure dhcp on switch 3650 it works. In this case I need to have dhcp server on asr 9010.  

Attached the topology

Can you help me please?
Thanks

 

5 REPLIES 5
Collaborator

Re: DHCP Server Configuration on ASR 9010 does not work

Re: DHCP Server Configuration on ASR 9010 does not work

Hi Jaderson Pessoa,

I tested it that way too but it didn't work unfortunately...

Thanks

Cisco Employee

Re: DHCP Server Configuration on ASR 9010 does not work

You also need to assign the VRF to the DHCP profile.

Can you try that and then send the following outputs collected a few times:

show dhcp ipv4 server profile name <profile name>

show dhcp ipv4 server profile name <profile name> loc 0/0/cpu0

show dhcp ipv4 server statistic

show dhcp ipv4 server statistics loc 0/0/cpu0

show dhcp ipv4 server binding vrf <vrf name>

 

Thanks,

Sam

Re: DHCP Server Configuration on ASR 9010 does not work

Hi smilstea,

I put the vrf inside the ipv4 dhcp and still does not work.

 

Attached information requested.

 

Thanks, 

 

 
 
Cisco Employee

Re: DHCP Server Configuration on ASR 9010 does not work

I don't see any packets coming in and reaching the server, will need to debug and see if they are dropping due to a specific reason or if we see any packets at all.

 

debug dhcp ipv4 packet filter-id interface <interface>

debug dhcp ipv4 server errors

debug dhcp ipv4 server events

debug dhcp ipv4 server internals

 

Sam

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here