cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3155
Views
5
Helpful
16
Replies
Highlighted
Beginner

IOS XRv Error: AToM Dynamic with mismatched AC config

Hi,

I'm running IOS XRv in VMware Workstation. I have a simple topology of two PE routers connected to a P router, all running XRv.

I have configured Layer 3 VPN's and layer 2 Local E-Line VPN's (AC's on same PE) between the PEs with no problem. But when I try to configure a Layer 2 EoMPLS VPN over a pseudowire I get the following error:

Error: AToM Dynamic with mismatched AC config

 

Here's the full show output:

RP/0/0/CPU0:PE1#show l2vpn xconnect

Fri May 2 23:37:31.563 UTC

Legend: ST = State, UP = Up, DN = Down, AD = Admin Down, UR = Unresolved,

SB = Standby, SR = Standby Ready, (PP) = Partially Programmed

XConnect Segment 1 Segment 2

Group Name ST Description ST Description ST

------------------------ ----------------------------- -----------------------------

AC2AC_1 EoMPLS DN Gi0/0/0/1.2 DN 10.2.2.2 101 DN

----------------------------------------------------------------------------------------

RP/0/0/CPU0:PE1#show l2vpn xconnect detail

Fri May 2 23:37:39.382 UTC

Group AC2AC_1, XC EoMPLS, state is down; Interworking none

AC: GigabitEthernet0/0/0/1.2, state is down

Type VLAN; Num Ranges: 1

VLAN ranges: [11, 11]

MTU 1500; XC ID 0x4; interworking none

Error: AToM Dynamic with mismatched AC config

Statistics:

packets: received 0, sent 0

bytes: received 0, sent 0

drops: illegal VLAN 0, illegal length 0

PW: neighbor 10.2.2.2, PW ID 101, state is down ( all ready )

PW class not set, XC ID 0xff000001

Encapsulation MPLS, protocol LDP

Source address 10.1.1.1

PW type Ethernet, control word disabled, interworking none

PW backup disable delay 0 sec

Sequencing not set

PW Status TLV in use

MPLS Local Remote

------------ ------------------------------ -----------------------------

Label 16007 16008

Group ID 0x300 0x400

Interface GigabitEthernet0/0/0/1.2 GigabitEthernet0/0/0/2.2

MTU 1500 1500

Control word disabled disabled

PW type Ethernet Ethernet

VCCV CV type 0x2 0x2

(LSP ping verification) (LSP ping verification)

VCCV CC type 0x6 0x6

(router alert label) (router alert label)

(TTL expiry) (TTL expiry)

------------ ------------------------------ -----------------------------

Incoming Status (PW Status TLV):

Status code: 0x6 (AC Down) in Notification message

Outgoing Status (PW Status TLV):

Status code: 0x6 (AC Down) in Notification message

MIB cpwVcIndex: 4278190081

Create time: 02/05/2014 23:35:14 (00:02:24 ago)

Last time status changed: 02/05/2014 23:35:39 (00:01:59 ago)

Last time PW went down: 02/05/2014 23:35:39 (00:01:59 ago)

Statistics:

packets: received 0, sent 0

bytes: received 0, sent 0

 

Here's the configs:

# PE1 #

interface GigabitEthernet0/0/0/1

speed 100

duplex full

int g0/0/0/1.2 l2transport

encap dot1q 11

rewrite ingress tag pop 1

!

l2vpn

xconnect group AC2AC_1

p2p EoMPLS

int g0/0/0/1.2

neighbor ipv4 10.2.2.2 pw-id 101

 

# PE2 #

interface GigabitEthernet0/0/0/2

speed 100

duplex full

interface g0/0/0/2.2 l2transport

encapsulation dot1q 11

rewrite ingress tag pop 1

!

l2vpn

xconnect group AC2AC_1

p2p EoMPLS

interface GigabitEthernet0/0/0/2.2

neighbor ipv4 10.1.1.1 pw-id 101

 

############

Any help would be greatly appreciated

Everyone's tags (1)
16 REPLIES 16
Highlighted
Cisco Employee

Hi,Can you try EoMPLS under

Hi,

Can you try EoMPLS under main interface instead of sub-interface?.

 

-Nagendra

Highlighted
Beginner

Guys,Are you able to actually

Guys,

Are you able to actually transport packets between the ACs? In my config all counters stays zero..

RP/0/0/CPU0:R1#show l2vpn xconnect detail
Thu Jun 26 04:43:54.106 UTC

Group R4, XC R4, state is up; Interworking none
  AC: GigabitEthernet0/0/0/2, state is up
    Type Ethernet
    MTU 1500; XC ID 0x1; interworking none
    Statistics:
      packets: received 0, sent 0
      bytes: received 0, sent 0
  PW: neighbor 4.4.4.4, PW ID 10, state is up ( established )

***SNIP***

  Last time status changed: 26/06/2014 04:06:30 (00:37:23 ago)
    Statistics:
      packets: received 0, sent 0
      bytes: received 0, sent 0

The box is not able to send or receive anything in the AC

 

Highlighted
Beginner

I'm running IOS XRv in VMware

I'm running IOS XRv in VMware Workstation which doesn't support dot1q trunking so I'm not expecting the data plane to work. I think it should work in VMware ESXi.

 

Highlighted
Cisco Employee

XRv does not support l2vpn

XRv does not support l2vpn data forwarding yet. 

Regards,
/A

Highlighted
Beginner

You mean there are plans to

You mean there are plans to support it in the future?

I have another question is there a way to obtain the documentation PIE for XRv?

RP/0/0/CPU0:R2#man command ping
Mon Jun 30 06:09:11.580 UTC
Unable to retrieve man pages. Please check if doc pie is installed.

 

 

Highlighted
Cisco Employee

yes, there are plans to

yes, there are plans to support l2vpn.

Not sure about doc pie though. 

Highlighted
Beginner

Thanks for the response

Thanks for the response Nagendra.

Yeah I tried configuring it under the main interface, same error.

The error is only happening for point-to-point EoMPLS. VPLS works okay which surprised me. I had to configure 'rewrite ingress tag pop 1 symmetric' under the subinterface for VPLS to work, it reported an MTU mismatch error otherwise.

For EoMPLS, I've tried configuring it under the main interface, subinterface, popping/not popping the vlan tag, type 4/type 5, and manually setting various MTU sizes under the main interface configuration. I always get the same error.

Regards,

Neil

Highlighted
Beginner

Hi! I'm facing the same

Hi!

 

I'm facing the same problem on XRv. I've tried to configure it either with another XRv or with IOS-based router. Same result. I also tried interworking scenario between FrameRelay on IOS and Ethernet VLAN on XRv. In that case I'm getting a slitely different error: AToM Dynamic with not supported AC

 

My config is:

 

XRv:

hostname XR2
telnet vrf default ipv4 server max-servers 10
line template TELNET
 exec-timeout 0 0
!
line default
 exec-timeout 0 0
!
vty-pool default 0 99 line-template TELNET
interface Loopback0
 ipv4 address 20.20.20.20 255.255.255.0
!
interface MgmtEth0/0/CPU0/0
 ipv4 address 172.16.33.207 255.255.255.0
!
interface GigabitEthernet0/0/0/0
!
interface GigabitEthernet0/0/0/0.100 l2transport
 encapsulation dot1q 100 exact
!
interface GigabitEthernet0/0/0/0.102
 description R4 e1/1
 ipv4 address 12.4.20.20 255.255.255.0
 encapsulation dot1q 102
!
interface GigabitEthernet0/0/0/0.103
 description SW1 e1/3
 ipv4 address 10.0.0.20 255.255.255.0
 encapsulation dot1q 103
!
interface GigabitEthernet0/0/0/0.105
 description R8 e1/2
 encapsulation dot1q 105
!
interface GigabitEthernet0/0/0/0.110 l2transport
 encapsulation dot1q 110 exact
 rewrite ingress tag pop 1 symmetric
!
router static
 address-family ipv4 unicast
  0.0.0.0/0 172.16.33.254
 !
!
router ospf 1
 router-id 20.20.20.20
 mpls ldp sync
 mpls ldp auto-config
 area 0
  authentication-key encrypted 022527722E
  authentication message-digest
  message-digest-key 1 md5 encrypted 0478282F2A
  interface Loopback0
   passive enable
  !
  interface GigabitEthernet0/0/0/0.102
   network point-to-point
  !
 !
!
router bgp 1284
 address-family vpnv4 unicast
 !
 neighbor 5.5.5.5
  remote-as 1284
  update-source Loopback0
  address-family vpnv4 unicast
  !
 !
!
l2vpn
 router-id 20.20.20.20
 pw-class AToM
  encapsulation mpls
  !
 !
 pw-class Ether
  encapsulation mpls
   transport-mode vlan
  !
 !
 xconnect group AToM
  p2p AToM
   interface GigabitEthernet0/0/0/0.100
   neighbor ipv4 1.1.1.1 pw-id 100
    pw-class AToM
   !
   interworking ipv4
  !
 !
 xconnect group Test
  p2p AToM
   interface GigabitEthernet0/0/0/0.110
   neighbor ipv4 1.1.1.1 pw-id 111
    pw-class Ether
   !
  !
 !
!
mpls ldp
 neighbor
  password encrypted 0222217D2A332315616A5C
  1.1.1.1:0 password encrypted 08026F672C
  2.2.2.2:0 password encrypted 0027302F21
  3.3.3.3:0 password encrypted 0327782223
  4.4.4.4:0 password encrypted 072C02656B
  5.5.5.5:0 password encrypted 0327782223
  6.6.6.6:0 password encrypted 106D2A3020
  10.10.10.10:0 password encrypted 0327782223
  20.20.20.20:0 password encrypted 123A263E37
 !
 address-family ipv4
 !
!
end

 

IOS:

 

hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
ip cef    
no ipv6 cef
!
!
mpls ldp password required for 1
mpls ldp password option 1 for 1 CCIE
mpls ldp password option 2 for 99 DEFAULTMD5
frame-relay switching
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
pseudowire-class AToM
 encapsulation mpls
 interworking ip
!

!
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface Serial1/0
 mtu 1504
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay intf-type dce
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet2/0
 ip address 12.1.3.1 255.255.255.0
 ip ospf message-digest-key 1 md5 CCIE
 ip ospf network point-to-point
 duplex full
!         
interface Ethernet2/1
 no ip address
 duplex full
 no keepalive
!
interface Ethernet2/1.110
 encapsulation dot1Q 110
 xconnect 20.20.20.20 111 encapsulation mpls
!
interface Ethernet2/2
 no ip address
 shutdown
 duplex full
!
interface Ethernet2/3
 no ip address
 shutdown
 duplex full
!
router ospf 1
 router-id 1.1.1.1
 area 0 authentication message-digest
 passive-interface Loopback0
 network 1.1.1.1 0.0.0.0 area 0
 network 12.0.0.0 0.255.255.255 area 0
 mpls ldp sync
 mpls ldp autoconfig
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
access-list 1 permit 1.1.1.1
access-list 1 permit 2.2.2.2
access-list 1 permit 3.3.3.3
access-list 1 permit 4.4.4.4
access-list 1 permit 5.5.5.5
access-list 1 permit 6.6.6.6
access-list 1 permit 10.10.10.10
access-list 1 permit 20.20.20.20
access-list 2 permit 1.1.1.1
access-list 2 permit 2.2.2.2
access-list 2 permit 3.3.3.3
access-list 2 permit 4.4.4.4
access-list 2 permit 5.5.5.5
access-list 2 permit 6.6.6.6
access-list 99 permit any
connect AToM Serial1/0 100 l2transport
 xconnect 20.20.20.20 100 encapsulation mpls pw-class AToM
 !
!
!
!
!
control-plane
!
alias exec wmem write mem
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login

 

Outputs from the equipment:

 

XRv:

 

RP/0/0/CPU0:XR2#show l2vpn xconnect pw-id 111
Tue Jun  3 20:22:38.207 UTC
Legend: ST = State, UP = Up, DN = Down, AD = Admin Down, UR = Unresolved,
        SB = Standby, SR = Standby Ready, (PP) = Partially Programmed

XConnect                   Segment 1                       Segment 2                
Group      Name       ST   Description            ST       Description            ST    
------------------------   -----------------------------   -----------------------------
Test       AToM       DN   Gi0/0/0/0.110          DN       1.1.1.1         111    DN    
----------------------------------------------------------------------------------------
RP/0/0/CPU0:XR2#show l2vpn xconnect pw-id 111 detail 
Tue Jun  3 20:22:39.827 UTC

Group Test, XC AToM, state is down; Interworking none
  AC: GigabitEthernet0/0/0/0.110, state is down
    Type VLAN; Num Ranges: 1
    VLAN ranges: [110, 110]
    MTU 1500; XC ID 0x2; interworking none
    Error: AToM Dynamic with mismatched AC config
    Statistics:
      packets: received 0, sent 0
      bytes: received 0, sent 0
      drops: illegal VLAN 0, illegal length 0
  PW: neighbor 1.1.1.1, PW ID 111, state is down ( all ready )
    PW class Ether, XC ID 0xff000003
    Encapsulation MPLS, protocol LDP
    Source address 20.20.20.20
    PW type Ethernet VLAN, control word disabled, interworking none
    PW backup disable delay 0 sec
    Sequencing not set

    PW Status TLV in use
      MPLS         Local                          Remote                        
      ------------ ------------------------------ -----------------------------
      Label        16016                          33                            
      Group ID     0x200                          unknown                       
      Interface    GigabitEthernet0/0/0/0.110     unknown                       
      MTU          1500                           1500                          
      Control word disabled                       disabled                      
      PW type      Ethernet VLAN                  Ethernet VLAN                 
      VCCV CV type 0x2                            0x12                          
                   (LSP ping verification)        (LSP ping verification)       
      VCCV CC type 0x6                            0x6                           
                   (router alert label)           (router alert label)          
                   (TTL expiry)                   (TTL expiry)                  
      ------------ ------------------------------ -----------------------------
    Incoming Status (PW Status TLV):
      Status code: 0x0 (Up) in Notification message
    Outgoing Status (PW Status TLV):
      Status code: 0x6 (AC Down) in Notification message
    MIB cpwVcIndex: 4278190083
    Create time: 03/06/2014 20:07:05 (00:15:34 ago)
    Last time status changed: 03/06/2014 20:22:22 (00:00:17 ago)
    Last time PW went down: 03/06/2014 20:22:22 (00:00:17 ago)
    Statistics:
      packets: received 0, sent 0
      bytes: received 0, sent 0

 

IOS:

 

R1#show mpls l2transport vc 111 detail 
Local interface: Et2/1.110 up, line protocol up, Eth VLAN 110 up
  Destination address: 20.20.20.20, VC ID: 111, VC status: down
    Last error: Remote peer access circuit is down
    Output interface: Et2/0, imposed label stack {27 16016}
    Preferred path: not configured  
    Default path: active
    Next hop: 12.1.3.3
  Create time: 00:14:19, last status change time: 00:03:25
    Last label FSM state change time: 00:09:45
  Signaling protocol: LDP, peer 20.20.20.20:0 up
    Targeted Hello: 1.1.1.1(LDP Id) -> 20.20.20.20, LDP is UP
    Status TLV support (local/remote)   : enabled/supported
      LDP route watch                   : enabled
      Label/status state machine        : established, LruRrd
      Last local dataplane   status rcvd: No fault
      Last BFD dataplane     status rcvd: Not sent
      Last BFD peer monitor  status rcvd: No fault
      Last local AC  circuit status rcvd: No fault
      Last local AC  circuit status sent: DOWN AC(rx/tx faults)
      Last local PW i/f circ status rcvd: No fault
      Last local LDP TLV     status sent: No fault
      Last remote LDP TLV    status rcvd: DOWN AC(rx/tx faults)
      Last remote LDP ADJ    status rcvd: No fault
    MPLS VC labels: local 33, remote 16016 
    Group ID: local 0, remote 512
    MTU: local 1500, remote 1500
    Remote interface description: GigabitEthernet0_0_0_0.110
  Sequencing: receive disabled, send disabled
  Control Word: Off (configured: autosense)
  Dataplane:
    SSM segment/switch IDs: 16398/8204 (used), PWID: 2
  VC statistics:
    transit packet totals: receive 0, send 0
    transit byte totals:   receive 0, send 0
    transit packet drops:  receive 0, seq error 0, send 0

 

It looks like XRv is reporting its AC as down to the Pseudowire process, even though it is up:

 

RP/0/0/CPU0:XR2#show ip int br | incl GigabitEthernet0/0/0/0.110
Tue Jun  3 20:27:28.577 UTC
GigabitEthernet0/0/0/0.110     unassigned      Up                    Up    

Highlighted

 Hi sheeptest Can you share

 

Hi sheeptest

 

Can you share with us your configuration where you say that VPLS works.  I have topology en GNS3 con 2 router PE with IOS XR but I can not make it works

in AToM and VPLS. I also tried with transport-mode vlan  but it doesnot work

 

PE1

 

interface GigabitEthernet0/0/0/0.13 l2transport
 encapsulation dot1q 13
 rewrite ingress tag pop 1 symmetric

 

l2vpn
 pw-class VPLS_CLASS
  encapsulation mpls
   transport-mode ethernet
  !
 !
 bridge group VPLS
  bridge-domain 13
   interface GigabitEthernet0/0/0/0.13
   !
   vfi 13
    neighbor 20.20.20.20 pw-id 13
     pw-class VPLS_CLASS
    !
   !
 

PE2

interface GigabitEthernet0/0/0/1.13 l2transport
 encapsulation dot1q 13
 rewrite ingress tag pop 1 symmetric

 

l2vpn
 pw-class VPLS_CLASS
  encapsulation mpls
   transport-mode ethernet
  !
 !
 bridge group VPLS
  bridge-domain 13
   interface GigabitEthernet0/0/0/1.13
   !
   vfi 13
    neighbor 19.19.19.19 pw-id 13
     pw-class VPLS_CLASS
    !
   !

 

 

Highlighted
Beginner

Your VPLS config looks the

Your VPLS config looks the same as mine. You need to use /32 loopback addresses if not already. You don't need the pw-class config but it shouldn't break anything.


Note that it's just the control plane I have working, the L2VPN should come up.


I'm running IOS XRv in VMware Workstation which doesn't support dot1q trunking so I'm not expecting the data plane to work. I think it should work in VMware ESXi.

Highlighted
Beginner

I checked VPLS in the same

I checked VPLS in the same scenario. Now PWs were successfully established but still no forwarding occurs. Interface counters are increasing but AC counters are not increasing:

 

RP/0/0/CPU0:XR1#show interfaces gigabitEthernet 0/0/0/0.100
Thu Jul  3 10:35:12.935 UTC
GigabitEthernet0/0/0/0.100 is up, line protocol is up 
  Interface state transitions: 1
  Hardware is VLAN sub-interface(s), address is 0050.569e.b22c
  Layer 2 Transport Mode
  MTU 1518 bytes, BW 1000000 Kbit (Max: 1000000 Kbit)
     reliability Unknown, txload Unknown, rxload Unknown
  Encapsulation 802.1Q Virtual LAN,
    Outer Match: Dot1Q VLAN 100
    Ethertype Any, MAC Match src any, dest any
  loopback not set,
  Last input 00:00:52, output never
  Last clearing of "show interface" counters 00:01:58
     10 packets input, 85 bytes
     0 input drops, 0 queue drops, 0 input errors
     0 packets output, 0 bytes
     0 output drops, 0 queue drops, 0 output errors

 

RP/0/0/CPU0:XR1#show l2vpn bridge-domain bd-name VPLS detail 
Thu Jul  3 10:36:24.400 UTC
Legend: pp = Partially Programmed.
Bridge group: VPLS, bridge-domain: VPLS, id: 0, state: up, ShgId: 0, MSTi: 0
  Coupled state: disabled
  MAC learning: enabled
  MAC withdraw: enabled
    MAC withdraw for Access PW: enabled
    MAC withdraw sent on: bridge port up
    MAC withdraw relaying (access to access): disabled
  Flooding:
    Broadcast & Multicast: enabled
    Unknown unicast: enabled
  MAC aging time: 300 s, Type: inactivity
  MAC limit: 4000, Action: none, Notification: syslog
  MAC limit reached: no
  MAC port down flush: enabled
  MAC Secure: disabled, Logging: disabled
  Split Horizon Group: none
  Dynamic ARP Inspection: disabled, Logging: disabled
  IP Source Guard: disabled, Logging: disabled
  DHCPv4 snooping: disabled
  IGMP Snooping: enabled
  IGMP Snooping profile: none
  MLD Snooping profile: none
  Storm Control: disabled
  Bridge MTU: 1500
  MIB cvplsConfigIndex: 1
  Filter MAC addresses:
  P2MP PW: disabled
  Create time: 03/07/2014 07:09:49 (03:26:35 ago)
  No status change since creation
  ACs: 1 (1 up), VFIs: 1, PWs: 1 (1 up), PBBs: 0 (0 up)
  List of ACs:
    AC: GigabitEthernet0/0/0/0.100, state is up
      Type VLAN; Num Ranges: 1
      VLAN ranges: [100, 100]
      MTU 1500; XC ID 0x1; interworking none
      MAC learning: enabled
      Flooding:
        Broadcast & Multicast: enabled
        Unknown unicast: enabled
      MAC aging time: 300 s, Type: inactivity
      MAC limit: 4000, Action: none, Notification: syslog
      MAC limit reached: no
      MAC port down flush: enabled
      MAC Secure: disabled, Logging: disabled
      Split Horizon Group: none
      Dynamic ARP Inspection: disabled, Logging: disabled
      IP Source Guard: disabled, Logging: disabled
      DHCPv4 snooping: disabled
      IGMP Snooping: enabled
      IGMP Snooping profile: none
      MLD Snooping profile: none
      Storm Control: disabled
      Static MAC addresses:
      Statistics:
        packets: received 0, sent 0
        bytes: received 0, sent 0
      Storm control drop counters: 
        packets: broadcast 0, multicast 0, unknown unicast 0 
        bytes: broadcast 0, multicast 0, unknown unicast 0 
      Dynamic ARP inspection drop counters: 
        packets: 0, bytes: 0
      IP source guard drop counters: 
        packets: 0, bytes: 0
  List of Access PWs:
  List of VFIs:
    VFI VPLS (up)
      PW: neighbor 20.20.20.20, PW ID 100, state is up ( established )
        PW class VPLS, XC ID 0xff000001
        Encapsulation MPLS, protocol LDP
        Source address 19.19.19.19
        PW type Ethernet, control word disabled, interworking none
        Sequencing not set

        PW Status TLV in use
          MPLS         Local                          Remote                        
          ------------ ------------------------------ -------------------------
          Label        16001                          16001                         
          Group ID     0x0                            0x0                           
          Interface    VPLS                           VPLS                          
          MTU          1500                           1500                          
          Control word disabled                       disabled                      
          PW type      Ethernet                       Ethernet                      
          VCCV CV type 0x2                            0x2                           
                       (LSP ping verification)        (LSP ping verification)       
          VCCV CC type 0x6                            0x6                           
                       (router alert label)           (router alert label)          
                       (TTL expiry)                   (TTL expiry)                  
          ------------ ------------------------------ -------------------------
        Incoming Status (PW Status TLV):
          Status code: 0x0 (Up) in Notification message
        MIB cpwVcIndex: 4278190081
        Create time: 03/07/2014 07:09:49 (03:26:35 ago)
        Last time status changed: 03/07/2014 08:44:04 (01:52:19 ago)
        Last time PW went down: 03/07/2014 08:43:56 (01:52:28 ago)
        MAC withdraw messages: sent 0, received 0
        Static MAC addresses:
        Statistics:
          packets: received 0, sent 0
          bytes: received 0, sent 0
        Storm control drop counters: 
          packets: broadcast 0, multicast 0, unknown unicast 0 
          bytes: broadcast 0, multicast 0, unknown unicast 0 
      DHCPv4 snooping: disabled
      IGMP Snooping profile: none
      MLD Snooping profile: none
      VFI Statistics:
        drops: illegal VLAN 0, illegal length 0

 

My topology is:

 

R1(e1/0)---(gi0/0/0.100)XR1(gi0/0/0.103)----(gi0/0/0.103)XR2(gi0/0/0.101)---(e1/0)R2

 

My config is:

 

hostname XR1
!
interface Loopback0
 ipv4 address 19.19.19.19 255.255.255.255
 ipv6 address 2001::19:19:19:19/128
!
interface MgmtEth0/0/CPU0/0
 ipv4 address 172.16.33.206 255.255.255.0
!
interface GigabitEthernet0/0/0/0
 cdp
!
interface GigabitEthernet0/0/0/0.100 l2transport
 encapsulation dot1q 100
 rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet0/0/0/0.103
 ipv4 address 10.19.20.19 255.255.255.0
 ipv6 address 2001:10:19:20::19/64
 encapsulation dot1q 103
!
router static
 address-family ipv4 unicast
  0.0.0.0/0 172.16.33.254
 !
!
router ospf 1
 area 0
  interface Loopback0
   passive enable
  !
  interface GigabitEthernet0/0/0/0.103
   network point-to-point
  !
 !
!
l2vpn
 pw-class VPLS
  encapsulation mpls
   transport-mode ethernet
  !
 !
 bridge group VPLS
  bridge-domain VPLS
   interface GigabitEthernet0/0/0/0.100
   !
   vfi VPLS
    neighbor 20.20.20.20 pw-id 100
     pw-class VPLS
    !
   !
  !
 !
!
mpls oam
!
mpls ldp
 log
  neighbor
 !
 router-id 19.19.19.19
 interface GigabitEthernet0/0/0/0.103
 !
!
end

 

hostname XR2
!
interface Loopback0
 ipv4 address 20.20.20.20 255.255.255.255
 ipv6 address 2001::20:20:20:20/128
!
interface MgmtEth0/0/CPU0/0
 vrf Management
 ipv4 address 172.16.33.161 255.255.255.0
!
interface GigabitEthernet0/0/0/0
 cdp
!
interface GigabitEthernet0/0/0/0.100
 ipv4 address 192.168.100.14 255.255.255.0
 encapsulation dot1q 100
!
interface GigabitEthernet0/0/0/0.101 l2transport
 encapsulation dot1q 101
 rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet0/0/0/0.103
 ipv4 address 10.19.20.20 255.255.255.0
 ipv6 address 2001:10:19:20::20/64
 encapsulation dot1q 103
!
router static
 vrf Management
  address-family ipv4 unicast
   0.0.0.0/0 172.16.33.254
  !
 !
!
router ospf 1
 log adjacency changes
 area 0
  interface Loopback0
   passive enable
  !
  interface GigabitEthernet0/0/0/0.103
   network point-to-point
  !
 !
!
l2vpn
 pw-class VPLS
  encapsulation mpls
   transport-mode ethernet
  !
 !
 bridge group VPLS
  bridge-domain VPLS
   interface GigabitEthernet0/0/0/0.101
   !
   vfi VPLS
    neighbor 19.19.19.19 pw-id 100
     pw-class VPLS
    !
   !
  !
 !
!
mpls oam
!
mpls ldp
 log
  neighbor
 !
 router-id 20.20.20.20
 interface GigabitEthernet0/0/0/0.103
 !
!
end

 

Beginner

Hi,

Hi,

Know this is an old post but It's the first post I found when searching for info. May be it will help others.

Run into this problem and got it work. (control plane only because of limitations of XRv)

You have to configure the vlan under the subinterface like this:

interface GigabitEthernet0/0/0/1.100 l2transport
dot1q vlan 100

not with "encapsulation dot1q 100"

RP/0/0/CPU0:XR1#sh l2vpn xconne det
Mon Dec 7 21:43:04.741 UTC

Group XR1-R2, XC XR1-R2, state is up; Interworking none
AC: GigabitEthernet0/0/0/1.100, state is up
Type VLAN; Num Ranges: 1
VLAN ranges: [100, 100]
MTU 1500; XC ID 0x1; interworking none
Statistics:
packets: received 0, sent 0
bytes: received 0, sent 0
drops: illegal VLAN 0, illegal length 0
PW: neighbor 2.2.2.2, PW ID 219, state is up ( established )
PW class ETH-ETH, XC ID 0xff000001
Encapsulation MPLS, protocol LDP
Source address 19.19.19.19
PW type Ethernet VLAN, control word disabled, interworking none
PW backup disable delay 0 sec
Sequencing not set

PW Status TLV in use
MPLS Local Remote
------------ ------------------------------ -----------------------------
Label 24012 28
Group ID 0x300 unknown
Interface GigabitEthernet0/0/0/1.100 unknown
MTU 1500 1500
Control word disabled disabled
PW type Ethernet VLAN Ethernet VLAN
VCCV CV type 0x2 0x2
(LSP ping verification) (LSP ping verification)
VCCV CC type 0x6 0x6
(router alert label) (router alert label)
(TTL expiry) (TTL expiry)
------------ ------------------------------ -----------------------------
Incoming Status (PW Status TLV):
Status code: 0x0 (Up) in Notification message
Outgoing Status (PW Status TLV):
Status code: 0x0 (Up) in Notification message
MIB cpwVcIndex: 4278190081
Create time: 07/12/2015 17:18:52 (04:24:12 ago)
Last time status changed: 07/12/2015 21:38:40 (00:04:23 ago)
Last time PW went down: 07/12/2015 17:25:36 (04:17:28 ago)
Statistics:
packets: received 0, sent 0
bytes: received 0, sent 0

Regards,

Víctor.

Highlighted
Beginner

This was really helpful ,

This was really helpful , thank you

But Data plane is not working, any advice?

And if this is due to emulating issue, does this work for real life network?

Highlighted
Beginner

This is a strange "bug". I was just running into this is...

This is a strange "bug".  I was just running into this issue on 6.0.1 XRv, I also tested it in 6.2.3 XRv9k. 6.0.1 has "dot1q vlan" command, which brings up PW, but not 6.2.3. I could not get this working in 6.2.3. Port mode PW works fine, have not tried VPLS.

 

6.0.1:

 

RP/0/0/CPU0:XRv-R21#show run int gig 0/0/0/1.100
Tue Mar 13 21:40:18.008 UTC
interface GigabitEthernet0/0/0/1.100 l2transport
dot1q vlan 100
!

RP/0/0/CPU0:XRv-R21#
RP/0/0/CPU0:XRv-R21#show l2vpn xconnect
Tue Mar 13 21:40:26.587 UTC
Legend: ST = State, UP = Up, DN = Down, AD = Admin Down, UR = Unresolved,
SB = Standby, SR = Standby Ready, (PP) = Partially Programmed

XConnect Segment 1 Segment 2
Group Name ST Description ST Description ST
------------------------ ----------------------------- -----------------------------
PW PW101 UP Gi0/0/0/1.100 UP 2.2.2.2 101 UP
----------------------------------------------------------------------------------------

 

6.2.3:

 

RP/0/RP0/CPU0:XRv-R41# show vers
Wed Mar 14 04:42:16.265 UTC

Cisco IOS XR Software, Version 6.2.3
Copyright (c) 2013-2017 by Cisco Systems, Inc.

Build Information:
Built By : ahoang
Built On : Thu Dec 21 19:30:35 PST 2017
Build Host : iox-lnx-053
Workspace : /auto/srcarchive11/production/6.2.3/xrv9k/workspace
Version : 6.2.3
Location : /opt/cisco/XR/packages/

cisco IOS-XRv 9000 () processor
System uptime is 26 minutes

RP/0/RP0/CPU0:XRv-R41#
RP/0/RP0/CPU0:XRv-R41#
RP/0/RP0/CPU0:XRv-R41#
RP/0/RP0/CPU0:XRv-R41#config t
Wed Mar 14 04:43:54.916 UTC
int RP/0/RP0/CPU0:XRv-R41(config)#int gig 0/0/0/1.100 l2transport
RP/0/RP0/CPU0:XRv-R41(config-subif)#dot?
^
% Invalid input detected at '^' marker.
RP/0/RP0/CPU0:XRv-R41(config-subif)#encapsulation ?
default Packets unmatched by other service instances
dot1ad IEEE 802.1ad VLAN-tagged packets
dot1q IEEE 802.1Q VLAN-tagged packets
untagged Packets with no explicit VLAN tag
RP/0/RP0/CPU0:XRv-R41(config-subif)#encapsulation

CreatePlease to create content