12-13-2024 10:38 PM
Hi all,
My P2P l2vpn xconnect is not coming up. I trying to figure the problem out. What am I missing?
hostname XR1
interface Loopback0
ipv4 address 192.168.100.2 255.255.255.255
!
interface GigabitEthernet0/0/0/0
ipv4 address 10.0.200.6 255.255.255.252
!
interface GigabitEthernet0/0/0/1.10 l2transport
encapsulation dot1q 10
rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet0/0/0/2
shutdown
!
router ospf 1
router-id 192.168.100.2
mpls ldp auto-config
area 0
interface Loopback0
passive enable
!
interface GigabitEthernet0/0/0/0
network point-to-point
!
!
!
l2vpn
pw-class BASE
encapsulation mpls
protocol ldp
ipv4 source 192.168.100.2
!
!
xconnect group default
p2p CO19216801
interface GigabitEthernet0/0/0/1.10
neighbor ipv4 192.168.100.3 pw-id 10
pw-class BASE
!
!
!
!
mpls ldp
router-id 192.168.100.2
address-family ipv4
!
!
end
RP/0/0/CPU0:XR1#
--------------------------------------------------------------
XR2:
hostname XR2
interface Loopback0
ipv4 address 192.168.100.3 255.255.255.255
interface GigabitEthernet0/0/0/0
ipv4 address 10.0.200.10 255.255.255.252
!
interface GigabitEthernet0/0/0/1.10 l2transport
encapsulation dot1q 10
rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet0/0/0/2
shutdown
!
router ospf 1
router-id 192.168.100.3
mpls ldp auto-config
area 0
interface Loopback0
passive enable
!
interface GigabitEthernet0/0/0/0
network point-to-point
!
!
!
l2vpn
pw-class BASE
encapsulation mpls
protocol ldp
ipv4 source 192.168.100.3
!
!
xconnect group default
p2p CO19216801
interface GigabitEthernet0/0/0/1.10
neighbor ipv4 192.168.100.2 pw-id 10
pw-class BASE
!
!
!
!
mpls ldp
router-id 192.168.100.3
!
end
RP/0/0/CPU0:XR2#
-------------------------------------------------------------
P router in between two XR routers
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
ip address 10.0.200.5 255.255.255.252
ip ospf network point-to-point
duplex auto
speed auto
media-type rj45
mpls ip
!
interface GigabitEthernet0/2
ip address 10.0.200.9 255.255.255.252
ip ospf network point-to-point
duplex auto
speed auto
media-type rj45
mpls ip
!
router ospf 1
router-id 1.1.1.1
passive-interface Loopback0
network 10.0.200.5 0.0.0.0 area 0
network 10.0.200.9 0.0.0.0 area 0
------------------------------------
l2vpn status
RP/0/0/CPU0:XR1#sh l2vpn xconnect
Sat Dec 14 05:32:12.702 UTC
Legend: ST = State, UP = Up, DN = Down, AD = Admin Down, UR = Unresolved,
SB = Standby, SR = Standby Ready, (PP) = Partially Programmed
XConnect Segment 1 Segment 2
Group Name ST Description ST Description ST
------------------------ ----------------------------- -----------------------------
default CO19216801 DN Gi0/0/0/1.10 DN 192.168.100.3 10 DN
---------------------------------------------------------------------------------------
Solved! Go to Solution.
12-14-2024 08:29 PM
Hi @Badshah ,
That is correct. You could use XRv9k if you want to test it in your lab. XRv9k supports both control and data plane.
Regards,
12-14-2024 01:37 AM
I send you PM check it
MHM
12-14-2024 03:50 AM
I have replied you back. Please check.
12-14-2024 06:05 AM
Hi @Badshah ,
You need to enable LDP on the core facing interface on both XR1 and XR2
mpls ldp interface GigabitEthernet0/0/0/0
Regards,
12-14-2024 06:20 AM
He use auto-config under ospf so it by defualt will enable ldp under interface run ospf.
MHM
12-14-2024 10:02 AM
Hi @MHM Cisco World ,
Good catch.
@Badshah ,
Can you please provide a "sh mpls ldp neighbor brief" for both XR1 and XR2?
Regards,
12-14-2024 07:21 PM
Hi Harold,
Thank you for your response. PW is up after changing AC interface at PEs to
RP/0/0/CPU0:XR1#sh run int g0/0/0/2.10
Sun Dec 15 02:22:58.131 UTC
interface GigabitEthernet0/0/0/2.10 l2transport
dot1q vlan 10
!
RP/0/0/CPU0:XR1#sh l2vpn xconnect group default xc-name CO19216801
Sun Dec 15 02:21:09.148 UTC
Legend: ST = State, UP = Up, DN = Down, AD = Admin Down, UR = Unresolved,
SB = Standby, SR = Standby Ready, (PP) = Partially Programmed
XConnect Segment 1 Segment 2
Group Name ST Description ST Description ST
------------------------ ----------------------------- -----------------------------
default CO19216801 UP Gi0/0/0/1.10 UP 192.168.100.3 10 UP
-----------------------------------------------------------------------------------
I'm having another problem now. None of the CE can ping each other. Both CE's are tagging traffic (vlan 10). I removed the "rewrite ingress tag pop 1 symmetric" from both PE interfaces. But no expected outcome is being found.
12-14-2024 08:05 PM - edited 12-14-2024 08:27 PM
Hi @Badshah ,
This is normal behaviour with XRv. Only the control plane works properly. The data plane doesn't.
XRv9k supports both control and data plane.
Regards,
12-14-2024 08:18 PM
Hi Harold,
So, the real IOS-XR device would behave normally with my configuration. Am I correct?
Regards,
Badshah Sekendar
12-14-2024 08:29 PM
Hi @Badshah ,
That is correct. You could use XRv9k if you want to test it in your lab. XRv9k supports both control and data plane.
Regards,
12-14-2024 03:35 PM
PW is up now. However, none of the CE can ping each other. Both CE's are tagging traffic (vlan 10). I removed the "rewrite ingress tag pop 1 symmetric" from both PE interfaces. But no expected outcome is being found.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide