08-19-2016 10:14 AM
I've read a few other Cisco Support documents on enabling QoS shaping on Sub-Interfaces but I'm running into an issue that is perplexing me. Here is a summary of what we're trying to do:
We have a 10GE physical interface on an ASR-9010 connected to a 10GE switch. The 10GE router physical interface is broken down into sub-interfaces. Some of the sub-interfaces are logical 1GE circuits connected to the switch and some are connected at 10GE. For the 1GE connected-sites, we'd like to perform shaping to ensure that the speed-step from 10GE to 1GE doesn't impact performance. For all interfaces, I'd like to configure priority queuing for IP Prec 5 and 6 traffic. Unfortunately, when I apply the config I think will work, I'm getting an error:
!!% 'prm_ezhal' detected the 'warning' condition 'Not enough TM resources to satisfyrequest'
Here is my config:
class-map match-any VLAN_228
match vlan 228
end-class-map
!
class-map match-any VLAN_229
match vlan 229
end-class-map
!
class-map match-any VLAN_245
match vlan 245
end-class-map
!
policy-map prioritize_ASI
class class-default
shape average 10 gbps
service-policy prioritize_1ge
!
!
policy-map prioritize_1ge
class VLAN_228
shape average 1 gbps
service-policy prioritize_backbone
!
class VLAN_229
shape average 1 gbps
service-policy prioritize_backbone
!
class VLAN_245
shape average 1 gbps
service-policy prioritize_backbone
!
policy-map prioritize_backbone
class packets_with_ip_precedence_5
priority level 1
set cos 5
set dei 0
!
class packets_with_ip_precedence_6
priority level 1
set cos 6
set dei 0
!
class class-default
set cos 1
set dei 0
!
end-policy-map
!
interface Te0/7/0/20.228
service-policy output prioritize_ASI
!
interface Te0/7/0/20.229
service-policy output prioritize_ASI
!
interface Te0/7/0/20.245
service-policy output prioritize_ASI
At the end of the day, I have two questions. First, what TM resources am I over-running that is preventing these configs from being applied with only 3 x 1Gbps connections? Second, if we were to over-subscribe the 10GE physical interface such that we allowed 25 x 1Gb connections across the single 10GE link, would it be possible to apply a 1 Gbps shaper to all 25 sub-interfaces, even though it's only a 10Gbps physical link?
Thanks.
10-28-2019 04:36 AM
Good day,
Did you ever got an answer on your question because I have a similar quest on the same ASR platform?
Kind Regards
Lungelo
10-28-2019 02:28 PM
Instead of a parent shaper and then several child shapers what you want to do is have a parent shaper at 1G, what is in the original post would be good if you had multiple vlan's on the main interface and you allowed all those vlans with no specific sub-interface config. That's it for the config. No need for any matching or anything else and you can apply the same policy in egress on multiple sub-interfaces.
policy-map test
class class-default
shape average 1 gbps
!
!
Sam
10-28-2019 11:52 PM
Hi Sam,
Thanks for the response, so in my case I have 10Mbps sub-interface in a VRF. I have configured a QoS policy as the child policy and then I have a Shaper policy as the parent policy. What is strange to me is that when I apply the service policy on the sub-interface I get the following error message from the router:
10-28-2019 11:54 PM
Hi,
If I take the same QoS policy and apply to a physical interface it works but the problem only occurs when I apply it on the sub-interface.
10-29-2019 10:18 AM
Can you paste your entire policy-map configuration?
Sam
10-29-2019 11:09 AM
Hi Sam,
It looks like the error is caused by the limited resources on the TR (Transport) module. We are planning to move the customer link tonight to terminate on the secondary ASR9010 which has the SE (Service Edge) card. I think that will resolve the issue.
RP/0/RSP0/CPU0:CPEGCENT02#sh platform
Tue Oct 29 20:06:40.324 GMT
Node Type State Config State
-----------------------------------------------------------------------------
0/RSP0/CPU0 A9K-RSP440-TR(Active) IOS XR RUN PWR,NSHUT,MON
0/RSP1/CPU0 A9K-RSP440-TR(Standby) IOS XR RUN PWR,NSHUT,MON
0/0/CPU0 A9K-MOD80-TR IOS XR RUN PWR,NSHUT,MON
0/0/0 A9K-MPA-20X1GE OK PWR,NSHUT,MON
0/0/1 A9K-MPA-4X10GE OK PWR,NSHUT,MON
0/1/CPU0 A9K-SIP-700 IOS XR RUN PWR,NSHUT,MON
0/1/0 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/1/1 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/1/2 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/1/3 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/2/CPU0 A9K-SIP-700 IOS XR RUN PWR,NSHUT,MON
0/2/0 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/2/1 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/2/2 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/2/3 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/3/CPU0 A9K-SIP-700 IOS XR RUN PWR,NSHUT,MON
0/3/0 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/3/1 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/3/2 SPA-8XCHT1/E1 DISABLED NPWR,NSHUT,MON
0/3/3 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/4/CPU0 A9K-SIP-700 IOS XR RUN PWR,NSHUT,MON
0/4/0 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/4/1 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/4/2 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/4/3 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/5/CPU0 A9K-SIP-700 IOS XR RUN PWR,NSHUT,MON
0/5/0 SPA-8XCHT1/E1 BOOTING NPWR,NSHUT,MON
0/5/2 SPA-8XCHT1/E1 OK PWR,NSHUT,MON
0/7/CPU0 A9K-MOD160-TR IOS XR RUN PWR,NSHUT,MON
0/7/0 A9K-MPA-2X40GE OK PWR,NSHUT,MON
RP/0/RSP0/CPU0:CPEGCENT02#sh vrf dmv detail
Tue Oct 29 20:07:08.213 GMT
VRF dmv; RD 65000:10450112; VPN ID not set
VRF mode: Regular
Description not set
Interfaces:
GigabitEthernet0/0/0/16.1006
Address family IPV4 Unicast
Import VPN route-target communities:
RT:65000:1112
Export VPN route-target communities:
RT:65000:1112
No import route policy
Export route policy: cust-export
ipv4 access-list Critical_DMV_Data
permit tcp any host 10.123.89.114 eq 5001
permit tcp host 10.123.89.114 eq 5001 any
permit tcp any host 164.151.131.243 eq 2034
permit tcp host 164.151.131.243 eq 2034 any
permit tcp any host 164.151.131.244 eq 2031
permit tcp host 164.151.131.244 eq 2031 any
ipv4 access-list Transaction_DMV_Data
remark ## E-Mail ##
permit tcp any any eq 389
permit tcp any eq 389 any
permit tcp any any eq 443
permit tcp any eq 443 any
permit tcp any any eq smtp
permit tcp any eq smtp any
remark ## Printing ##
permit tcp any host 164.151.131.244 eq 8024
permit tcp host 164.151.131.244 eq 8024 any
ipv4 access-list Voice_DMV
permit ipv4 any 10.121.48.0 0.0.0.255
permit ipv4 10.121.48.0 0.0.0.255 any
class-map match-any Egress_DMV_Routing
match dscp cs6
end-class-map
class-map match-any Egress_DMV_Voice
match dscp ef
match access-group ipv4 Voice_DMV
end-class-map
class-map match-any Egress_DMV_CriticalData
match dscp af31
match access-group ipv4 Critical_DMV_Data
end-class-map
class-map match-any Egress_DMV_TransactionData
match dscp af21
match access-group ipv4 Transaction_DMV_Data
end-class-map
!
policy-map Egress_Wan_DMV
class Egress_DMV_Routing
bandwidth percent 3
!
class Egress_DMV_Voice
priority level 1
police rate percent 30
!
!
class Egress_DMV_CriticalData
bandwidth percent 20
random-detect default
!
class Egress_DMV_TransactionData
bandwidth percent 25
random-detect default
!
class class-default
bandwidth percent 22
random-detect default
!
policy-map Shape_Wan_DMV
class class-default
service-policy Egress_Wan_DMV
shape average 10000000 bps
bandwidth 10000000 bps
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide