Showing results for 
Search instead for 
Did you mean: 

something wrong with ios-xr


I don't know how to explain this, but first of all, i must tell something about me..

i'm working on cisco vendor, my job description maybe you can call helpdesk or operator..

i have strange situation or strange case..

something wrong with the ios xr, when i type/input/enter the command "ad sh inventory" on the routers, some modul not correctly show the detail about the moduls

example : previously, when i input the command like above, detail show correctly, like serial number, PID etc, but now when i type the command, some modul detail not show correctly.. is there something wrong with the ios xr ? is that cosmetic bug, it is possible ?

NAME: "module compact-flash 0/RSP0/CPU0", DESCR: " CompactFlash "

PID:  ?????  , VID: N/A, SN:  ??????

Detail show correctly,,

and i've find like this on 3 routers

2 on CRS1-4 (ios xr version 4.1.2)

1 on ASR9k (ios xr version 4.2.1)

thank in advance

Cisco Employee

Hey Rizaldi, When you mentioned it worked before and not working now. may be a minor bug. But i see there are few issues fixed around this. This should not be seen in the subsequent releases.



Hi Narvenka..

Thanks for your input.. i think it will be need minor upgrade too..

I have another question.. but little related with subject..

Why in some routers there is a PID for SPA does not detected ?

which means the SPA has already built-in with the PLIM, so the SPAs PIDs follow/participate with the PLIM PIDs.

And I think, the PIDs should be the SPAs identity itself "this is me". Why could not detected ? Why the PIDs should follow PLIM PIDs ?

And my logical says, so the SFP PIDs already built-in with the SPA should follow the SPAs PIDs, don't you think ?


PLIM 0/PL1/* : Cisco CRS-1 Series 2x10GE WAN/LAN Flexible Interface Module

  MAIN:  board type 60011c

         800-32691-01 rev B0

         dev N/A


  PCA:   73-12575-01 rev B0

  PID:   2-10GE-WL-FLEX

  VID:   V01


  ECI:   171293

  Interface port config:  0 Ports

  Optical reach type:  Unknown

  Connector type:  MT-P


RP/0/RP0/CPU0:Routers#sh inventory location 0/1/0   

Tue Oct 29 14:03:01.894 WIB

NAME: "0/1/0", DESCR: "Cisco 1-Port 10GE LAN/WAN-PHY Shared Port Adapter"

PID:                   , VID: N/A, SN:

RP/0/RP0/CPU0:Routers#sh inventory location 0/1/2

Tue Oct 29 14:03:51.514 WIB

NAME: "0/1/2", DESCR: "Cisco 1-Port 10GE LAN/WAN-PHY Shared Port Adapter"

PID:                   , VID: N/A, SN:


Thank in advance

Hi, i know the reason why cisco made the PID of some SPA not detect, i've ask to my friend and my 2nd layer engineers, the reason is because to differentiate between the SPA non-module and SPA module.


have you tried using: admin show inventory location <> 

heads up: use the LC as the location and don't address the MPA directly. as an example, use 0/1/CPU0 instead of 0/1/1

To display the product inventory listing of all Cisco products installed in the networking device, use the show inventory command in user EXEC or privileged EXEC mode.

show inventory [raw] [entity]
(raw)(Optional) Retrieves information about all of the Cisco products--referred to as entities--installed in the Cisco networking device, even if the entities do not have a product ID (PID) value, a unique device identifier (UDI), or other physical identification.
entity(Optional) Name of a Cisco entity (for example, chassis, backplane, module, or slot). A quoted string may be used to display very specific UDI information; for example “sfslot 1” will display the UDI information for slot 1 of an entity named sfslot.