Showing results for 
Search instead for 
Did you mean: 

Jabber for Android: Cannot connect to Phone Services

Gordon Ross
Level 9
Level 9

I'm trying to setup a Jabber for Android client IM&P is working fine, but phone services aren't. I just get the error message:


"Cannot connect to Phone Services server. Check your network settings."


Other Jabber clients (Windows, Mac, iPhone & iPad) can all connect fine from the same WiFi network and get phone services. Any suggestions as to what to look for? Are there any diagnostic logs I can view in the Android Jabber client?





Please rate all helpful posts.
25 Replies 25

Level 1
Level 1



I have the same problem with an HTC one android 4.4.2

No problem on a Samsung S3 android 4.2




HTC One: Not Supported. Doesn't work.

Samsung Galaxy Note 3: Support, Doesn't work.

Samsung Galaxy S5: Supported, Works.


I can see Android is going to be a right royal PITA. It's almost going to be easier to say Android ISN'T supported...



Please rate all helpful posts.


Did you find a solution? I have the same issue with CUCM/IMP 10.5 and jabber 10.5 (windows and android)

Windows works perfectly, but jabber android has the "Cannot connect to Unified Communication Manager server"

If I check the log files all seems OK, I can see jabber android finds the device, the DN, names all, but doesn't register.





Sorry, I can't get the HTC One to work. There's no point in asking TAC as they'll say it's not a supported phone.





Please rate all helpful posts.

I am using Samsung Galaxy 3 and this is supported I believe, and previous version of jabber android worked fine.


Jabber is still not OK,

Cisco must put much more effort in  it :(

OK. In the Protocol Specific Information section of the Jabber device, check that you've configured the SIP Digest User to that of the owner.



Please rate all helpful posts.

I tried that now, but still my phone services are not available




Adding the domain name as user define BOT device can resolve the issue relative to Samsung phone, any other non-support Android phone should use mixed mode security in order to resolve the issue.




I should tell that the cisco supports only a 6-7 modells of android devices that can handle a calls - other will fail to register. The main feature about htc is that they blocked some sip functionality in their software - so no luck to use them untill you change something in your phone (with root rights).

Hi All,


I'm running UC applications on version 10.5, and Jabber for Android on 11.0 release on a Samsung S4.

On the Corporate WiFI, all services work well, but when I login via Expressway on a different wifi, the IM&P and Unity services are good, but no phone services. 


I've already set the domain on the BOT device, add digest authentication, excluded the device and add it again, but the problem still remains.


Please, any thoughts?

Go to the bottom of the device page and add your root domain address

That worked for me. Thanks

Please remember to rate useful posts clicking on the stars below.
LinkedIn Profile:

Did you manage to get this working on a HTC One?

I think I heard that the HTC One might be supported in a later Jabber version, but I'm not sure when that will be.



Please rate all helpful posts.