cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
412
Views
0
Helpful
7
Replies
Highlighted
Beginner

Basic Finesse Gadget

Hi Guys,

 

i'm new to Finesse and gadgets.

 

i'm trying to get the following result:

1. a new tab in the finesse desktop layout

2. a gadget that displays the URLS.

 

so far i've managed to get the additional tab displayed, and i followed the steps described here (https://developer.cisco.com/learning/lab/finesse-hello-world-gadget/step/1).

 

how ever when i click on the link there is no URL or txt displayed.

 

could some one help me with what im doing wrong?

 

i've only uploaded the following XML to the 3rdparty gadget folder

<?xml version="1.0" encoding="UTF-8" ?>
<Module>
<ModulePrefs title="Test Gadget">
<Require feature="pubsub-2" />
<Require feature="setprefs" />
<Require feature="loadingindicator">
<Param name="manual-dismiss">false</Param>
<Param name="loading-timeout">10</Param>
</Require>
</ModulePrefs>
<UserPref name="scheme" display_name="scheme" default_value=""/>
<UserPref name="host" display_name="host" default_value=""/>
<UserPref name="hostPort" display_name="hostPort" default_value=""/>
<Content type="html">
<![CDATA[
<!DOCTYPE html>

<!-- jQuery -->
<script type="text/javascript" src="/desktop/assets/js/jquery.min.js"></script>

<!-- Finesse Library -->
<script type="text/javascript" src="/desktop/assets/js/finesse.js"></script>

<body>
<div id="link"><a href="http://www.google.com" target="_blank">http://www.google.com</a></div>
</body>
]]>
</Content>
</Module>

 

thanks,

Kevin

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Basic Finesse Gadget

Hi,

 

If you are using https, you need to use the port so that is correct.

 

Hmmm. I'm trying to think of what could be wrong.

 

1. Is the gadget hosted on the Finesse server or a separate web server?

2. Using the developer tools, what HTML do you see when you look at the gadget? Do you see the HTML for the link?

 

Thanx,

Denise

7 REPLIES 7
Cisco Employee

Re: Basic Finesse Gadget

Hi,

 

Are you using the lab environment that from the learning lab? If not, what version of Finesse are you using. I just tested the code you pasted below and I was able to click the link which opened up a new tab with Google loaded using Finesse 12.0 with CCE on Firefox and Chrome.

 

Thanx,

Denise

Beginner

Re: Basic Finesse Gadget

Hi Denise,

 

My current version is 10.6 SU3, i tried it on the 11.6 sandbox as well an it worked fine.

do you think it has something to do with my actual finesse server?

btw im using CCX.

 

Thanks,

Kevin

 

Cisco Employee

Re: Basic Finesse Gadget

Hi,

 

Unfortunately I don't have a 10.6 system anymore, so I can't try it for myself. It might have something to do with 10.6 in general vs your actual server itself.

 

10.6 was the first version where the finesse.js was hosted on the finesse server. On your browser, can you go to http://<finesse fqdn>/desktop/assets/js/finesse.js and make sure it loads the JS file? I want to make sure that thats working.

 

Another thing to check is if there are any errors in the developer tools console. Is the link showing up but nothing happens when you click it?

 

Thanx,

Denise

Beginner

Re: Basic Finesse Gadget

Hi Denise,

 

the page only loads if i use https://FQDN:8445/desktop/assets/js/finesse.js, it doesn't load if i dont use the port number.

the reason im trying to get this working on 10.6 is we are planning to upgrade to v11 or higher.

 

the developer tools do not show any errors, the gadget loads and i get the gadget header name, but no link. I've attached a screen-shot.WorkSites.PNG

 

 

 

Thanks,
Kevin

Cisco Employee

Re: Basic Finesse Gadget

Hi,

 

If you are using https, you need to use the port so that is correct.

 

Hmmm. I'm trying to think of what could be wrong.

 

1. Is the gadget hosted on the Finesse server or a separate web server?

2. Using the developer tools, what HTML do you see when you look at the gadget? Do you see the HTML for the link?

 

Thanx,

Denise

Beginner

Re: Basic Finesse Gadget

Hi Denise,

 

thank you so much for you help, you pointed me in the right direction.

 

it was hosted on the finesse server, but when going through the developer tools it seem to be looking for another file, so I restored the default layout and started from the beginning.

 

Thanks again,

Kevin

Cisco Employee

Re: Basic Finesse Gadget

Hi,

 

I'm glad I was able to help. Good luck with your gadget!

 

Thanx,

Denise

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards