Showing results for 
Search instead for 
Did you mean: 

CUIC 11.5 in UCCE 11.5 - Bag of Issues


Greetings folks! wanted to check in with other fellow CCE Engineers on their experience with CUIC 11.5 in a UCCE Deployment. We just got done standing up UCCE 11.5 with CUIC - Build For those already aware, CUIC 11.5 now has a brand new GUI. I have several TAC cases opened and hence the title for this discussion. Here are the list of issues I have seen thus far. 

1) The only Tab the remains and works using the new GUI is the Reports Tab. All other Tab's (DashBoards, Repot Definitions, Users, Configure Tabs), jump back to the old legacy GUI when chosen. Have a TAC case open and have tried this on IE 11, Firefox 49.0.1, Chrome 53.0.x etc and get the same issue. I doubt this is by design, has anyone figured out a setting in the browser that may alleviate this issue? 

The Reports Tab is the only Tab that sticks and stays in the new GUI

Clicking on Report Definitions, Configure, Dashboards or Users Tab takes you back into the Old GUI page via a new Window or Tab in the broswer 

As an example, when I click on reports, I stay on the new GUI as shown here 

But I click on say "Reports Definition" Tab, I end up with a New Broswer Window that throws me into the old GUI (which btw there are a lot of things you cannot do in the Old GUI, trust me, I thought I'd just settle with the old GUI, you cant even "Save As" on a report on the Old GUI, "You Have to" use the new GUI to work with "Reports". Here is where you get thrown when you click on the Reports Definition Tab (or Dashboards, Users or Configure Tabs) 

2) The Next issue is with Thresholds, I must there are some great enhancements on Thresholds included Nested Thresholds that you can create (which is awesome). But what I found is that some of the Thresholds for certain Data Types dont work. for example Thresholds on a Service Level Today column which is a Decimal Format represented at xxxxxxx.xx % by way of a Forumla within the Report defintiion in say the Call Type Report (its the F0003 or F0004 Custom Field if you look in the Reports Definition for a Call Type Report). If you set a Threshold say ServiceLevelToday Less that 80.00 it wont work. In fact nothing works, I have tried (.8, 0.8, 0.80, .80, 80, 80.00, 80.0 and every combination possible). TAC has told me this is a defect, so I am on a waiting pattern now on this one. 

3) Cant Create Gauge view in the new GUI, there is no option to create a Gauge View in the new GUI from the Reports Tab, take a look 

To get around this, You could say click on Reports Defintiion Tab to take you to the old GUI (which in itself is an issue as detailed above), the you have the option to create a Gauge View from the Old GUI as shown here 

and even so, when you actually go back to the report and try to select the new view, you are faced with a grayed out radio button that wont let you select the gauge view when you set parameters and views for your report ! 

All in all, its been an challenging trying to get things rolling on CUIC 11.5 

Any thoughts, Suggestions and feedback is appreciated. If you have gotten around some of these issues, please let me know and I will do the same once I find answers from TAC on these issues. 

12 Replies 12


#1 is the working by design.  The only UI that was refreshed was the Reports tab.  All others are still the old interface, at least that's what's been communicated in the TOI's and other place.


thanks for the confirmation. I just heard something similar from TAC! I wish Cisco didn't release it until it was all cleaned up. Whats interesting is things created on the Legacy GUI seem to be functional in some screens on the new GUI and not in some parts. for example, a Gauge view created from Legacy area can be selected once the report is run (or) running and you can switch to Gauge view from there, but if you are in the Edit view of the Report under the new GUI, you cannot choose that as a default view. its a mess. 

Still working through other issues with separate TAC cases. As mentioned previously, will post if I get some answers, for now the threshold issue has been officially confimed as a Defect and is with the BU. 

Any update on this?

The product manager posted in a thread on the developers/Reporting forum that they are trying to have all aspects of the GUI in the new form for 11.6 but I do not know how the progress has been on that.

Many customers get super annoyed by having to fiddle with Compatibility View when using IE as they switch between the old and new.


Quick update on this. So there is an update patch that was released that addresses (among several things) issues with Thresholds. I can confirm that after patching the CUIC server the thresholds are working well. 

Note - Keep in mind my update is specific to UCCE / CUIC 11.5 (not UCCX) 

Not applicable

The only UI that was refreshed was the Reports tab.

That's got to be a joke right? Who releases a new user interface for one tab and makes the old interface nonfunctional? What a pita

Here is what I found (this is just a rumor, based on my conversation with some Guys from Cisco) apparently the reason that Cisco only re-did / updated just the reports tab is to prepare the reports Tab to conform to a standard that can be (in the future) embedded into Finesse . In simple terms, we could expect to see the entire reports tab embedded into Finesse. Like I mentioned, I don't know whether this is just a rumor or if this is intact the answer to the mystery, but that's what I heard about why Cisco changed up just the reports tab..., I guess time will tell if this is true. 

Not applicable

Is there any way to switch to the new gui from the old one? I have users getting stuck in the old gui and having to do a complete browser clear to get the new gui again.



I have UCCX10.6 (Mixed Mode) in production and test system UCCX 11.5 - Currently testing with IE11.

I have similar issue.

I found Cisco Bug CSCvc11492 which recognizes the problem but doesn't provide coherent solution.

I opened ticket with TAC and their suggestion was to use Firefox or Chrome or roll back security packs on IE11. In other words they said, this wasn't issue with UCCX 11.5 but rather with Internet browsers.

I pushed back and asked TAC to escalate the ticket and after a while I got information that issue will be solved with UCCX 11.6 with GA in April 2017.


I had to escalate to get correct information!

I hope this helps you in any way.



Not applicable

Hi Guys,

I am also facing the issue with reports in UCCX 11.5(1)..

When i am trying  reports --> Unified CCX Historical --> Inbound--> In inobound when i select the agent details or any thing not getting any response from the system

All is working fine except reports in CUIC.

Could some one please help me resolve the issue . 

Thanks in advance

Not applicable

Install the below cop file fro the below bug

Run the Fix for CSCvb27878 - For 8.x/9.x/10.x/11.0.x/11.5.x  .



Hi. I have the same problem in  UCCX version :(


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers