Showing results for 
Search instead for 
Did you mean: 

Issue with CUIC based 3rd party gadget in Finesse

Level 1
Level 1

We upgraded to 12.5 UCCE earlier this year. On previous versions, I have not had any issue creating CUIC based gadgets and adding them to Finesse prior to 12.5.  I have created a new gadget, to the same design as previous gadgets and I haven't been able to get it to function.  Report built in CUIC, like other gadgets. Same permissions and etc, HTML based view. 


Gadget File:

<?xml version="1.0" encoding="UTF-8"?>
title="Daily SL" height="300">
<Content type="url" href="https://FQDN:8444/cuicui/permalink/?viewId=9FF64F261000017D0003C0600A94F07A&amp;linkType=htmlType&amp;viewType=Grid&amp;refreshRate=1800" />


Finesse Layout Entry:
<gadget >https://FQDN/3rdpartygadget/files/PACDailySL.xml</gadget>

Uploaded to the same dir as the functional gadgets. Restarted TomCat.


I can access the URL from a new browser tab (no cached CUIC logins), it loads correctly:


When using Chrome or Firefox, I get the following errors: 

Chrome: Sad Face "FQDN refused to connect"

FireFox: Requests to open in new window, uses this URL: 




I have rebuilt the report numerous times, and even tried using other reports but no luck.  Any help or guidance would be greatly appreciated! 


I did notice a difference in the URL on a previously made gadget but I changed the new gadget URL to match and it did not function. 


Old Gadget: 





CUIC 12.5


Finesse 12.5 ES07

12 Replies 12

Hi, so the new gadget doesn't work, but you have other gadgets, also built in the 12.5 system, that do work?

Or the only gadgets that work are the ones you built previously?

Hi Bill,

That is correct, this is the first gadget I've had to make and upload since we upgraded to 12.5 earlier this year.  All the previous gadgets are working without issue, to the best of my knowledge. 

This may be a dumb question, but could you use the permalink for the report/gauge without doing it via a gadget but instead just call the permalink from the layout in Finesse?

Level 1
Level 1

Were you able to resolve this?  I have the exact same issues with Chrome and Firefox.  The permalink opens just fine by itself, but when you embed the <gadget>insert-the-permalink-here</gadget> within the Finesse Desktop XML, the "refused to connect" error comes up.  One note I'll make is that this is on UCCX 12.5, not UCCE.  When I do this back on 11.6, no issues.  I've tried using the persistent logging and looking at the Finesse locallog details, but nothing in there is helpful at all.  I thought perhaps it was something certificate related, but I have everything (servers and agents) trusting the root CA that signed the Tomcat certs.

Hi kdamisch,  


Unfortunately, I have not found a resolution for this.  It's been pushed to the backburner for now, but if/when I am to resolve it, I'll update this thread. 

Just guessing here could it be a CORS related issue? Have either of you opened a TAC case?



Level 1
Level 1

I've added both servers on both ports 8444 and 8445 in the utils finesse frame_access_allowed_list and allowed all origins with utils finesse cors enable_all and rebooted both servers.  Looking at the F12 developer tools console in Chrome, I see this:


Refused to display 'https://uccxpub.domain.local:8444/' in a frame because it set 'X-Frame-Options' to 'sameorigin'


Should Finesse (port 8445) be able to show a CUIC report (port 8444) within the Finesse Desktop?  Am I missing some CLI command to allow CUIC dashboards/reports to be shown in Finesse?

Hi @kdamisch ,


Have you fixed this issue? is so how?

I am facing the same issue in UCCE. Looks like the origin server does not authorize us to show the content inside an iframe.


I see the same errors, and have tried the same CLI additions.  I have a TAC case open but they haven't made any progress.  The 11.5 gadgets are working without issue.  Totally baffled by this. 

Level 1
Level 1

So,  my 12.5 gadget is working without issue, and I even added a new one today.  There have been no system or environment changes, patches, or upgrades.  It just works now, on Firefox, Chrome, and Edge. I have no idea why.  

So it wasn't working with all browsers and then all of a sudden it is working with all browsers, and no changes? That is very strange. Is it possible that the underlying infrastructure wasn't patched but even rebooted/services cycled?

The only reboot was our Finesse A server, but even then we tested the gadget on our A and B server and it didn't work.