cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
431
Views
0
Helpful
11
Replies
Highlighted
Beginner

PCCE 12.0 2k to 4k migration

Hello,

 

I have a customer who is upgrading from 11.5 PCCE 2k to 12 and wants to go to a 4k deployment once they are upgraded.  My question is if this is supported to change the deployment type without breaking the existing configuration from the 2k deployment, thus breaking reporting and associations.  I have not been able to find a document that talks about this and wanted to check here before opening a TAC case. 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

PCCE 4k (and 12k) is only supported for new, greenfield deployments in PCCE 12.0. Consequently, this isn't supported. The 4k deployment will need to be set up afresh.

View solution in original post

11 REPLIES 11
Highlighted
Rising star

Yes, that change is completely supported and you won't break anything that you can't fix. My experience is that the Outbound Campaigns had to be re-created, but that was before all the Engineering Specials came out. I think that's all kosher now. You typically find stuff that breaks when you go down in deployment, not up.
Highlighted

So, its just a matter of rerunning the set deployment after we get to version 12 and then using the inventory tools to add the extra components?  Sounds straight forward enough.  I was just wondering if there was a white paper or tech reference doc to the migration.  

Highlighted

I havent found a whitepaper or TechNotes specifically for this, but this TechNote was helpful when it comes to importing the certificates: https://www.cisco.com/c/en/us/support/docs/contact-center/packaged-contact-center-enterprise-1201/214845-manage-pcce-components-certificate-for-s.html

 

So as long as you pass the validator, you will be good from a deployment perspective.

Highlighted
Beginner

I opened a TAC case on this since there was no supporting documentation.  The TAC response (and BU response) is that this is not a supported migration.  

 

"Migration from PCCE 2k to 4k or 12k is not supported, you can migrate from PCCE 2k to UCCE 4k or 12k but not from PCCE 2k to PCCE 4k or 12k"  

Highlighted

What a strange response... I literally just did this for a customer going from PCCE 11.5... we migrated to PCCE 12.0 2K and in the middle of Plan & Design, we had to go to 4K due to a big influx of agents, which forced us to break apart CUIC. And this passed A2Q

Highlighted

In your method did you just add the new components with the inventory tool once they were online? In a conversation with the TAC engineer, I believe the response is actually that it isn't a tested migration. Which makes it one of those "It will probably work, but it's at your own risk" type of scenarios.


Highlighted


In your method did you just add the new components with the inventory tool once they were online?

Yep, that's exactly what I did. I did a tech refresh (new gear). I made sure to have all my VMs up and running before running the validator tool. I got tripped up on the CUIC piece first, but I was good once I realized that I had to split those components up (CUIC, LD, IdS).

One thing I had to re-do was CUIC. I couldn't just backup and restore a combo server to a 4K that requires the components to be broken up. So lucky for me, the reports were from Stock and not custom SQL queries.

Correction on my original post... It wasnt 11.5, it was 11.6, although I doubt it matters.

Highlighted

That doesn't sound right at all. Can you have TAC confirm that the BU said this? or see if your AM can get you in contact with one of the product owner. It's escaping me who is in charge of PCCE, but the AM should know.

 

david

Highlighted

I spoke with the Cisco TAC engineer who spoke specifically about his conversation with the BU and he confirmed in an email. Though, the BU contact is never mentioned by name. I think it would be short-sighted not to support or not to have tested a PCCE 2k expansion to a PCCE 4k. We are escalating this and another issue through our management to Cisco.



Thanks everyone


Highlighted
Cisco Employee

PCCE 4k (and 12k) is only supported for new, greenfield deployments in PCCE 12.0. Consequently, this isn't supported. The 4k deployment will need to be set up afresh.

View solution in original post

Highlighted

Thanks.  Our management escalation confirmed the same.  Disappointing but we'll have to go down a different avenue.