07-27-2024 01:29 AM
Hello Community,
Does the VRF names and the L3 vni that we create in bgp-evpn should be same on both the VTEP's?
Also, if I am using route-map to advertise the network via bgp should the tag value be also same?
I am trying to pin from 100.100.100.1 to 101.101.101.1. Below is the config.
VTEP1 :-
interface Vlan100
vrf member vxlan-lab
interface Vlan111
vrf member vxlan-lab
vrf context vxlan-lab
vni 11111
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
router bgp 65001
vrf vxlan-lab
address-family ipv4 unicast
redistribute direct route-map RM1
interface Vlan100
no shutdown
vrf member vxlan-lab
ip address 100.100.100.254/24 tag 123
fabric forwarding mode anycast-gateway
interface Vlan111
no shutdown
vrf member vxlan-lab
ip forward
VTEP2:-
interface Vlan101
vrf member vxlan-lab1
interface Vlan111
vrf member vxlan-lab1
vrf context vxlan-lab1
vni 1111
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
router bgp 65001
vrf vxlan-lab1
address-family ipv4 unicast
redistribute direct route-map RM1
interface Vlan101
no shutdown
vrf member vxlan-lab1
ip address 101.101.101.254/24 tag 1234
fabric forwarding mode anycast-gateway
interface Vlan111
no shutdown
vrf member vxlan-lab1
ip forward
Please note I am using n9K virtual images.
Solved! Go to Solution.
07-29-2024 02:17 AM
Hello,
>Does the VRF names and the L3 vni that we create in bgp-evpn should be same on both the VTEP's?
Names - no, as locally significant, VNI - yes, as the numbers which will be put in VXLAN header of the routed packet.
But usually names and VNI are the same across all VTEPs in fabric for convenience.
>Also, if I am using route-map to advertise the network via bgp should the tag value be also same?
Tag value should be the same in ip address statement and in route-map on one VTEP. Tags can be different across the VTEPs, but again, usually they are the same across the VTEPs in fabric.
Also, as you use network to announce subnet to bgp, there is no much sense to double it with tag/redistribution, you can choose one of the way (usually - redistribution).
07-29-2024 04:55 AM
No need to have same vrf name
What important here is route target must be mirror or same.
MHM
07-29-2024 06:19 AM
From documentation:
interface vlan1001
no shutdown
vrf member vxlan-900001
ip address 4.1.1.1/24 tag 54321
ipv6 address 4:1:0:1::1/64 tag 54321
fabric forwarding mode anycast-gateway
route-map HOST-SVI permit 10
match tag 54321
router bgp 65535
<>
vrf vxlan-900001
address-family ipv4 unicast
redistribute direct route-map HOST-SVI
address-family ipv6 unicast
redistribute direct route-map HOST-SVI
Tags in ip address for SVI and in route-map are the same
07-29-2024 02:17 AM
Hello,
>Does the VRF names and the L3 vni that we create in bgp-evpn should be same on both the VTEP's?
Names - no, as locally significant, VNI - yes, as the numbers which will be put in VXLAN header of the routed packet.
But usually names and VNI are the same across all VTEPs in fabric for convenience.
>Also, if I am using route-map to advertise the network via bgp should the tag value be also same?
Tag value should be the same in ip address statement and in route-map on one VTEP. Tags can be different across the VTEPs, but again, usually they are the same across the VTEPs in fabric.
Also, as you use network to announce subnet to bgp, there is no much sense to double it with tag/redistribution, you can choose one of the way (usually - redistribution).
07-29-2024 06:01 AM
@Pavel Tarakanov,
When you say " tag value same in the ip address and statement and in route-map " can you share some example so I understand the statement correctly.
07-29-2024 06:19 AM
From documentation:
interface vlan1001
no shutdown
vrf member vxlan-900001
ip address 4.1.1.1/24 tag 54321
ipv6 address 4:1:0:1::1/64 tag 54321
fabric forwarding mode anycast-gateway
route-map HOST-SVI permit 10
match tag 54321
router bgp 65535
<>
vrf vxlan-900001
address-family ipv4 unicast
redistribute direct route-map HOST-SVI
address-family ipv6 unicast
redistribute direct route-map HOST-SVI
Tags in ip address for SVI and in route-map are the same
07-29-2024 07:11 AM
@Pavel Tarakanov, Thanks for the explanation
07-29-2024 04:55 AM
No need to have same vrf name
What important here is route target must be mirror or same.
MHM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide