10-04-2024 12:38 AM
Hi,
I'm having problems to redirect incoming call from sip trunk to CUE AA,
- I have a Cisco 3945 and a NME-CUE , VID: V04
- the sip trunk provider only gives the last four digits.
- sip trunk number 8800 redirects to extension 100. Works fine.
- sip trunk number 5624 redirects to extension 100. Works fine.
- sip trunk number 8006 redirects to extension 600, which is the AA. Does not work.
- When I dial 600 from any extension AA work fine.
Here is a briefing of the configuration, if you need any more info please let me know. Thank you in advance.
Solved! Go to Solution.
10-08-2024 04:49 AM - edited 10-08-2024 04:52 AM
Have you changed the codec to the one I mentioned in the dial-peer? i must be G.711alaw
Remove g729 from the voice class code and add G.711alaw.
10-08-2024 10:29 PM
thank you, I will try it tomorrow
10-09-2024 08:41 PM
10-09-2024 10:03 PM
Is your transcoder registered with your CME?
From what I can tell you use 172.16.1.1 for CME, that’s the address you need to use for the SCCP server configuration, not the IP of one of your routers other interfaces. Remove the SCCP server configuration you have put in and add a new using the CME IP and set the version to the maximum it has, usually version 7.
10-09-2024 10:20 PM - edited 10-09-2024 10:21 PM
I don’t see that you have configured the required settings for the transcoder to work. The CCM group is not configured, and the IP address mentioned for the SCCP CCM is your second interface used by the ISP trunk. Any changes you make need to take effect by issuing the “no SCCP” command and then re-enabling SCCP. Also changes on telephoney-service need recreate cnf files.
You need to make the following changes to the configurations:
telephony-service
sdspfarm units 10
sdspfarm transcode sessions 30
sdspfarm tag 1 MTP881dfcdf4502
sccp ccm group 1
associate ccm 1 priority 1
associate profile 1 register MTP881dfcdf4502
sccp local GigabitEthernet0/1
sccp ccm 172.16.1.1 priority 1 version 7.0
You can verify the status of the transcoder using the command "show sccp".
10-09-2024 11:12 PM
thank you I will try it tomorrow
10-10-2024 10:13 PM
It worked now, thank very much for everything I understood how the transcoder works, this is the final code working, besides the "no sccp" is also need "shutdown" and turn on "no shutdown" the "dspfarm profile 1 transcode".
!
version 15.7
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
voice call carrier capacity active
!
voice service voip
ip address trusted list
ipv4 10.187.128.3 255.255.255.255
ipv4 10.187.128.19 255.255.255.255
ipv4 10.187.128.0 255.255.255.0
mode border-element license capacity 30
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
supplementary-service media-renegotiate
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
bind control source-interface GigabitEthernet0/2
bind media source-interface GigabitEthernet0/2
header-passing
privacy-policy passthru
!
!
voice class uri PSTN sip
host ipv4:10.187.128.3
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
!
!
voice translation-rule 1
rule 1 /^9\(.*\)/ /\1/
!
voice translation-rule 2
rule 1 /.../ /XXXXXXX800/
!
voice translation-rule 11
rule 1 /8800$/ /600/
rule 2 /8806$/ /600/
rule 3 /5624$/ /600/
!
!
voice translation-profile PSTN_INCOMING
translate called 11
!
voice translation-profile SIP
translate calling 2
translate called 1
!
interface GigabitEthernet0/0
ip address 192.168.1.19 255.255.252.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 172.16.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
ip address 10.65.65.19 255.255.224.0
duplex auto
speed auto
!
interface Integrated-Service-Engine4/0
ip unnumbered GigabitEthernet0/1
ip virtual-reassembly in
service-module ip address 172.16.1.2 255.255.255.0
!Application: CUE Running on NME
service-module ip default-gateway 172.16.1.1
no keepalive
!
ip default-gateway 192.168.1.254
ip forward-protocol nd
!
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip route 10.187.128.0 255.255.255.0 10.65.64.1
ip route 172.16.1.2 255.255.255.255 Integrated-Service-Engine4/0
!
!
nls resp-timeout 1
cpd cr-id 1
!
control-plane
!
mgcp profile default
!
sccp local GigabitEthernet0/1
sccp ccm 172.16.1.1 identifier 1 priority 1 version 7.0
sccp
!
sccp ccm group 1
bind interface GigabitEthernet0/1
associate ccm 1 priority 1
**** MAC Address of GigabitEthernet0/2*********
**** GigabitEthernet0/2 is SIP TRUNK Interface*******
***** MTP + 881d.fcdf.4502 *****************
associate profile 1 register MTP881dfcdf4502
!
!
!
dspfarm profile 1 transcode
description Hardware Transcoder
codec g711alaw
codec g711ulaw
codec pass-through
maximum sessions 30
associate application SCCP
!
dial-peer voice 9000 voip
description ** INBOUND CALLS from telecoms **
translation-profile incoming PSTN_INCOMING
session protocol sipv2
incoming called-number .%
incoming uri via PSTN
voice-class codec 1
voice-class sip early-offer forced
dtmf-relay rtp-nte
no vad
!
dial-peer voice 600 voip
description ** AA Dial Peer **
destination-pattern 60.
session protocol sipv2
session target ipv4:172.16.1.2
no voice-class sip early-offer forced
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
!
sip-ua
no remote-party-id
retry invite 2
retry options 1
timers connect 100
mwi-server ipv4:172.16.1.2 expires 3600 port 5060 transport udp unsolicited
sip-server ipv4:10.187.128.3
!
!
!
gatekeeper
shutdown
!
!
telephony-service
sdspfarm units 10
sdspfarm transcode sessions 30
sdspfarm tag 1 MTP881dfcdf4502
conference transfer-pattern
max-ephones 128
max-dn 128
ip source-address 172.16.1.1 port 2000
auto assign 1 to 10 type 7965
cnf-file location flash:
cnf-file perphone
user-locale ES load CME-locale-es_ES-Spanish-12.0.12.0.tar
network-locale ES
load 7937 apps37sccp.1-4-4-0
load 7945 SCCP45.9-2-1S
load 7965 SCCP45.9-2-1S
time-zone 9
time-format 24
date-format dd-mm-yy
voicemail 4500
mwi relay
max-conferences 8 gain -6
dn-webedit
time-webedit
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide