cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1018
Views
20
Helpful
4
Replies

CUBE or H323 Gateway Using FXO Ports

Ahmad2233
Beginner
Beginner

Dear Good day,

    I have a CUCM 11.5 new installation to replace my CME, and I want to use my CME router as a voice gateway, we have a legacy FXO ports coming from our PSTN (we will change to SIP Trunk in the next year). Please I want to know which type of gateway should I use, and what is the initial configuration to make the FXO ports work for us?

 

This is the current configurations on our CME router:

 

 

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!
!
!
trunk group FXO-PORTS
!
!
voice-card 0
!
!
!
voice service voip
lpcor incoming mobile-call
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
redirect ip2ip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
registrar server expires max 600 min 60
transport switch udp tcp
!
!
!
voice class dualtone-detect-params 1
freq-max-power 0
freq-min-power 13
freq-power-twist 4
cadence-variation 8
!
voice class custom-cptone disconnect
dualtone disconnect
frequency 422
cadence 247 254
!
voice class custom-cptone STC
dualtone disconnect
frequency 425
cadence 50 50
!
!
voice register global
mode cme
source-address 10.10.10.10 port 5060
max-dn 100
max-pool 50
authenticate register
authenticate realm all
timezone 31
date-format D/M/Y
mwi stutter
mwi reg-e164
voicemail 5000
url authentication http://192.168.2.1/CCMCIP/authenticate.asp
tftp-path flash:
create profile sync 0430031936355252
ntp-server 172.25.227.126 mode multicast
!
!
!
voice lpcor enable
voice lpcor call-block cause serv-not-implemented
voice lpcor custom
group 1 mob-call
group 2 fac
group 10 mobile-call
!
voice lpcor ip-trunk subnet incoming
index 1 mobile-call 10.10.10.0 255.255.255.0
!
voice lpcor ip-phone subnet incoming
index 1 mobile-call dhcp-pool cme-voice
!
!
voice translation-rule 100
rule 1 /^9/ //
!
!
voice translation-profile CALL-OUT-DGTSTRP
translate called 100
!
!
!
!
application
package param passwd
!
package auth
param max-retries 0
param passwd-prompt flash:enter_pin.au
param term-digit #
param abort-digit *
param passwd 12345
param user-prompt flash:enter_account.au
param max-digits 4
!
service clid_authen_collect
group-name 1
!
!
license udi pid CISCO2921/K9 sn FGL2009115M
hw-module ism 0
!
hw-module pvdm 0/0
!
!
!
!
!
interface Loopback0
ip address 192.168.2.1 255.255.255.0
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description * Ajar LAN *
ip address 10.10.10.10 255.255.255.0
duplex auto
speed auto
!
interface ISM0/0
ip unnumbered Loopback0
service-module ip address 192.168.2.2 255.255.255.0
!Application: CUE Running on ISM
service-module ip default-gateway 192.168.2.1
!
interface GigabitEthernet0/1
description
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface ISM0/1
no ip address
!
interface Vlan1
no ip address
!
ip forward-protocol nd
!
!
!
voice-port 0/0/0
trunk-group FXO-PORTS 1
supervisory custom-cptone disconnect
supervisory dualtone-detect-params 1
no battery-reversal
cptone BE
connection plar opx 5001
impedance complex2
description **Telephone Line Number 1 **
caller-id enable
caller-id alerting line-reversal
caller-id alerting dsp-pre-allocate
!
voice-port 0/0/1
trunk-group FXO-PORTS
supervisory custom-cptone disconnect
supervisory dualtone-detect-params 1
no battery-reversal
cptone BE
connection plar opx 5001
impedance complex2
description **Telephone Line Number 2 **
caller-id enable
caller-id alerting line-reversal
caller-id alerting dsp-pre-allocate
!
voice-port 0/0/2
trunk-group FXO-PORTS 1
supervisory custom-cptone disconnect
supervisory dualtone-detect-params 1
no battery-reversal
cptone BE
connection plar opx 5001
impedance complex2
description **Telephone Line Number 3 **
caller-id enable
caller-id alerting line-reversal
caller-id alerting dsp-pre-allocate
!
voice-port 0/0/3
trunk-group FXO-PORTS 1
supervisory custom-cptone STC
supervisory dualtone-detect-params 1
no battery-reversal
cptone BE
connection plar opx 5001
impedance complex2
description **Telephone Line Number 4 **
caller-id enable
caller-id alerting line-reversal
caller-id alerting dsp-pre-allocate
!
voice-port 0/1/0
trunk-group FXO-PORTS 1
supervisory custom-cptone disconnect
supervisory dualtone-detect-params 1
no battery-reversal
cptone BE
connection plar opx 5001
shutdown
impedance complex2
description **Telephone Line Number 5**
caller-id enable
caller-id alerting line-reversal
caller-id alerting dsp-pre-allocate
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer cor custom
name internal
name local
name national
name mobile
name international
name mobile-pass
!
!
dial-peer cor list INTERNAL-CALLS
member internal
!
dial-peer cor list LOCAL-CALLS
member internal
member local
!
dial-peer cor list NTNL-CALLS
member internal
member local
member national
!
dial-peer cor list MOBILE-CALLS
member internal
member local
member national
member mobile
!
dial-peer cor list INTNL-CALLS
member internal
member local
member national
member mobile
member international
!
dial-peer cor list MOBILE-PASS
member internal
member local
member national
member mobile-pass
!
dial-peer cor list ITsupport
member internal
member local
member national
member mobile
!
!
dial-peer voice 5000 voip
description ** cue VM number **
destination-pattern 5000
b2bua
session protocol sipv2
session target ipv4:192.168.2.2
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 5001 voip
description ** cue AA number **
destination-pattern 5001
b2bua
session protocol sipv2
session target ipv4:192.168.2.2
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 100 pots
trunkgroup FXO-PORTS
corlist outgoing LOCAL-CALLS
description STC Calls
destination-pattern 99[^2].
forward-digits 3
!
dial-peer voice 101 pots
corlist outgoing LOCAL-CALLS
description TollFree Calls
destination-pattern 7800.......
port 0/0/1
forward-digits 10
!
dial-peer voice 102 pots
trunkgroup FXO-PORTS
corlist outgoing LOCAL-CALLS
description TollFree Calls
destination-pattern 992.......
forward-digits 9
!
dial-peer voice 103 pots
trunkgroup FXO-PORTS
corlist outgoing LOCAL-CALLS
description Local Calls
destination-pattern 9[248]......
forward-digits 7
!
dial-peer voice 104 pots
trunkgroup FXO-PORTS
corlist outgoing NTNL-CALLS
description National Calls
destination-pattern 901........
forward-digits 10
!
dial-peer voice 105 pots
corlist outgoing MOBILE-CALLS
description Mobile Calls
destination-pattern 78905........
clid restrict
port 0/0/1
forward-digits 10
!
dial-peer voice 106 pots
corlist outgoing INTNL-CALLS
description International Calls
translation-profile outgoing CALL-OUT-DGTSTRP
destination-pattern 3638.T
port 0/0/1
!
dial-peer voice 115 pots
trunkgroup FXO-PORTS
corlist outgoing MOBILE-PASS
description Mobile Calls
shutdown
destination-pattern 805........
forward-digits 10
!
dial-peer voice 108 pots
corlist outgoing MOBILE-CALLS
description Mobile Calls
destination-pattern 025805........
port 0/0/0
forward-digits 10
!
dial-peer voice 107 pots
corlist outgoing ITsupport
description ITSupport
destination-pattern 05610705........
clid restrict
port 0/0/0
forward-digits 10
!
!
sip-ua
!
!
!
gatekeeper
shutdown
!
!
telephony-service
authentication credential cisco cisco123
max-ephones 50
max-dn 100
ip source-address 10.10.10.10 port 2000
auto assign 1 to 50
no service directed-pickup
timeouts interdigit 5
timeouts busy 5
timeouts ringing 20
system message AL-JOMAIH
url services http://192.168.2.2/voiceview/common/login.do
url authentication http://192.168.2.1/CCMCIP/authenticate.asp
time-zone 31
date-format dd-mm-yy
voicemail 5000
max-conferences 8 gain -6
call-park system application
moh enable-g711 "flash:/music-on-hold.au"
web admin system name cisco password cisco123
dn-webedit
time-webedit
transfer-system full-consult
transfer-pattern .T
create cnf-files version-stamp 7960 Nov 20 2019 07:18:41
!
!
!
!
!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

 

 

Thanks a lot guys

2 Accepted Solutions

Accepted Solutions

Chris Deren
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

You can certainly do this, you will first need to decide which voip protocol you want to use so that CUCM can communicate with your GW, your options are in order of my preference (SIP, H323, MGCP). If you decide to use H323 then you just need to add the H323 GW to CUCM, apply proper CSS to allow inbound calling, and build Route Group, Route List, Route Patterns for outbound calls.  If you decide to use SIP, you would add SIP trunk in CUCM that points to this router and again build RG, RL, RPs.  In both cases you will need to also add dial-peer(s) on the GW to communicate with CUCM.  If you do MGCP then you add the GW as the correct model under MGCP GW config and apply MGCP config to the GW.  

There are many guides and examples on how to configure each protocol, but if you have specific question on any of them, let us know.

View solution in original post

Hi,

As @Chris Deren mentioned, you have three different options to configure your Voice Gateway. I would recommend to go with SIP Protocol as you will be eventually migrating to SIP Trunk. This will provide protocol consistency between CUCM to Voice Gateway and Voice Gateway to SIP Trunk (in future) and SIP Protocol is easier to troubleshoot than other protocols. 

Below is the initial configuration that you need on your Voice Gateway. On CUCM side, you need Partition, CSS, Router Group, Route List, Route Pattern, and SIP Trunk etc..

!
trunk group PSTN-FXO
 description # Dedicated For PSTN Calls #
 hunt-scheme longest-idle
!
voice call send-alert
voice rtp send-recv
!
voice service voip
 ip address trusted list
  ipv4 10.xxx.xxx.xxx
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 supplementary-service media-renegotiate
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  bind control source-interface GigabitEthernet0/0/0
  bind media source-interface GigabitEthernet0/0/0
  header-passing
  error-passthru
  options-ping 60
  no update-callerid
  early-offer forced
  midcall-signaling passthru
  privacy-policy passthru
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
voice class server-group 1000
 ipv4 10.xxx.xxx.3
 ipv4 10.xxx.xxx.4 preference 1
 description # CUCM Server Group #
!
voice-card 0/4
 dsp services dspfarm
 no watchdog
!
interface GigabitEthernet0/0/0
 ip address 10.xxx.xxx.9 255.255.255.0
 negotiation auto
!
ip tftp source-interface GigabitEthernet0/0/0
ip route 0.0.0.0 0.0.0.0 10.xxx.xxx.1
!
!
voice-port 1/0/0
 trunk-group PSTN-FXO
 connection plar opx 10000
 description # POTS Line Number #
 caller-id enable
!
voice-port 1/0/1
 trunk-group PSTN-FXO
 connection plar opx 10000
 description # POTS Line Number #
 caller-id enable
!
voice-port 1/0/2
 trunk-group PSTN-FXO
 connection plar opx 10000
 description # POTS Line Number #
 caller-id enable
!
voice-port 1/0/3
 trunk-group PSTN-FXO
 connection plar opx 10000
 description # POTS Line Number #
 caller-id enable
!
dial-peer voice 1001 voip
 description # Calls To CUCM CLUSTER #
 destination-pattern 10000$
 session protocol sipv2
 session server-group 1000
 incoming called-number .
 voice-class codec 1  
 voice-class sip early-offer forced
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 9000 pots
 description # For PSTN Incoming Calls #
 incoming called-number .
 direct-inward-dial
!
dial-peer voice 9001 pots
 trunkgroup PSTN-FXO
 description # For 911 Emergency Calls #
 destination-pattern 911
 progress_ind alert enable 8
 progress_ind progress enable 8
 no digit-strip
!
dial-peer voice 9002 pots
 trunkgroup PSTN-FXO
 description # For 911 Emergency Calls #
 destination-pattern 9911
 progress_ind alert enable 8
 progress_ind progress enable 8
 forward-digits 3
!
dial-peer voice 9003 pots
 trunkgroup PSTN-FXO
 description # For Local 10-Digit PSTN Calls #
 destination-pattern 9[2-9]..[2-9]......
 progress_ind alert enable 8
 progress_ind progress enable 8
!
dial-peer voice 9004 pots
 trunkgroup PSTN-FXO
 description # For Long Distance PSTN Calls #
 destination-pattern 91[2-9]..[2-9]......
 progress_ind alert enable 8
 progress_ind progress enable 8
 prefix 1
!

 

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.

View solution in original post

4 Replies 4

Chris Deren
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

You can certainly do this, you will first need to decide which voip protocol you want to use so that CUCM can communicate with your GW, your options are in order of my preference (SIP, H323, MGCP). If you decide to use H323 then you just need to add the H323 GW to CUCM, apply proper CSS to allow inbound calling, and build Route Group, Route List, Route Patterns for outbound calls.  If you decide to use SIP, you would add SIP trunk in CUCM that points to this router and again build RG, RL, RPs.  In both cases you will need to also add dial-peer(s) on the GW to communicate with CUCM.  If you do MGCP then you add the GW as the correct model under MGCP GW config and apply MGCP config to the GW.  

There are many guides and examples on how to configure each protocol, but if you have specific question on any of them, let us know.

Hi,

As @Chris Deren mentioned, you have three different options to configure your Voice Gateway. I would recommend to go with SIP Protocol as you will be eventually migrating to SIP Trunk. This will provide protocol consistency between CUCM to Voice Gateway and Voice Gateway to SIP Trunk (in future) and SIP Protocol is easier to troubleshoot than other protocols. 

Below is the initial configuration that you need on your Voice Gateway. On CUCM side, you need Partition, CSS, Router Group, Route List, Route Pattern, and SIP Trunk etc..

!
trunk group PSTN-FXO
 description # Dedicated For PSTN Calls #
 hunt-scheme longest-idle
!
voice call send-alert
voice rtp send-recv
!
voice service voip
 ip address trusted list
  ipv4 10.xxx.xxx.xxx
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 supplementary-service media-renegotiate
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  bind control source-interface GigabitEthernet0/0/0
  bind media source-interface GigabitEthernet0/0/0
  header-passing
  error-passthru
  options-ping 60
  no update-callerid
  early-offer forced
  midcall-signaling passthru
  privacy-policy passthru
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
voice class server-group 1000
 ipv4 10.xxx.xxx.3
 ipv4 10.xxx.xxx.4 preference 1
 description # CUCM Server Group #
!
voice-card 0/4
 dsp services dspfarm
 no watchdog
!
interface GigabitEthernet0/0/0
 ip address 10.xxx.xxx.9 255.255.255.0
 negotiation auto
!
ip tftp source-interface GigabitEthernet0/0/0
ip route 0.0.0.0 0.0.0.0 10.xxx.xxx.1
!
!
voice-port 1/0/0
 trunk-group PSTN-FXO
 connection plar opx 10000
 description # POTS Line Number #
 caller-id enable
!
voice-port 1/0/1
 trunk-group PSTN-FXO
 connection plar opx 10000
 description # POTS Line Number #
 caller-id enable
!
voice-port 1/0/2
 trunk-group PSTN-FXO
 connection plar opx 10000
 description # POTS Line Number #
 caller-id enable
!
voice-port 1/0/3
 trunk-group PSTN-FXO
 connection plar opx 10000
 description # POTS Line Number #
 caller-id enable
!
dial-peer voice 1001 voip
 description # Calls To CUCM CLUSTER #
 destination-pattern 10000$
 session protocol sipv2
 session server-group 1000
 incoming called-number .
 voice-class codec 1  
 voice-class sip early-offer forced
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 9000 pots
 description # For PSTN Incoming Calls #
 incoming called-number .
 direct-inward-dial
!
dial-peer voice 9001 pots
 trunkgroup PSTN-FXO
 description # For 911 Emergency Calls #
 destination-pattern 911
 progress_ind alert enable 8
 progress_ind progress enable 8
 no digit-strip
!
dial-peer voice 9002 pots
 trunkgroup PSTN-FXO
 description # For 911 Emergency Calls #
 destination-pattern 9911
 progress_ind alert enable 8
 progress_ind progress enable 8
 forward-digits 3
!
dial-peer voice 9003 pots
 trunkgroup PSTN-FXO
 description # For Local 10-Digit PSTN Calls #
 destination-pattern 9[2-9]..[2-9]......
 progress_ind alert enable 8
 progress_ind progress enable 8
!
dial-peer voice 9004 pots
 trunkgroup PSTN-FXO
 description # For Long Distance PSTN Calls #
 destination-pattern 91[2-9]..[2-9]......
 progress_ind alert enable 8
 progress_ind progress enable 8
 prefix 1
!

 

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.

Thanks a lot, this is very helpful, and I'm going with SIP as you mentioned.

that was helpful, thanks a ton.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: