cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
278
Views
0
Helpful
2
Replies
Highlighted
Beginner

Inbound Calls Receiving Busy Signal

Hello,

 

We have a UC560 environment that is not receiving any inbound calls. All attempts result in a busy signal. Outgoing calls are working fine.

 

When I run 'terminal monitor > debug isdn q931' I get the following.

 

004883: ISDN Se0/3/0:23 Q931: RX <- SETUP pd = 8 callref = 0x038C
Bearer Capability i = 0x9090A2
Standard = CCITT
Transfer Capability = 3.1kHz Audio
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xA98385
Exclusive, Channel 5
Facility i = 0x9F8B0100A10F02010106072A8648CE1500040A0100
Protocol Profile = Networking Extensions
0xA10F02010106072A8648CE1500040A0100
Component = Invoke component
Invoke Id = 1
Operation = InformationFollowing (calling_name)
Name information in subsequent FACILITY message
Progress Ind i = 0x8283 - Origination address is non-ISDN
Calling Party Number i = 0x2183, '<redacted 1>'
Plan:ISDN, Type:National
Called Party Number i = 0xA1, '<redacted 2>'
Plan:ISDN, Type:National
004884: ISDN Se0/3/0:23 Q931: Received SETUP callref = 0x838C callID = 0x002F switch = primary-ni interface = User
004885: ISDN Se0/3/0:23 Q931: TX -> CALL_PROC pd = 8 callref = 0x838C
Channel ID i = 0xA98385
Exclusive, Channel 5
004886: ISDN Se0/3/0:23 Q931: RX <- FACILITY pd = 8 callref = 0x038C
Facility i = 0x9F8B0100A117020101020100800F455049544F4D454E4554574F524B53
Protocol Profile = Networking Extensions
0xA117020101020100800F455049544F4D454E4554574F524B53
Component = Invoke component
Invoke Id = 1
Operation = CallingName
Name Presentation Allowed Extended
Name = <redacted 3>
004887: ISDN Se0/3/0:23 Q931: TX -> ALERTING pd = 8 callref = 0x838C
004888: ISDN Se0/3/0:23 Q931: TX -> DISCONNECT pd = 8 callref = 0x838C
Cause i = 0x80A9 - Temporary failure
004889: ISDN Se0/3/0:23 Q931: RX <- RELEASE pd = 8 callref = 0x038C
004890: ISDN Se0/3/0:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x838C

 

 

The Voice Debug log shows the following.

 

 

>>>>CCAPI handed cid 2683 with tag 3001 to app "_ManagedAppProcess_Default"
006189: Dec 1 17:06:03.656: //-1/20E25B89801F/RXRULE/regxrule_stack_push_RegXruleNumInfo_internal: stack=0x8C2596BC; count=1
006190: Dec 1 17:06:03.656: //-1/20E25B89801F/RXRULE/regxrule_profile_translate_internal: number=<redacted 4>

type=national plan=isdn numbertype=calling
006191: Dec 1 17:06:03.660: //-1/20E25B89801F/RXRULE/regxrule_get_RegXrule: Translation ruleset with tag=3265 doesn't exist
006192: Dec 1 17:06:03.660: //-1/20E25B89801F/RXRULE/regxrule_profile_match_internal: Error: ruleset for calling number not found
006193: Dec 1 17:06:03.660: //-1/20E25B89801F/RXRULE/regxrule_profile_translate_internal: No match: number=<redacted 5> type=national plan=isdn
006194: Dec 1 17:06:03.660: //-1/20E25B89801F/RXRULE/regxrule_profile_translate_internal: number= type=UNKNOWN plan=UNKNOWN numbertype=redirect-called
006195: Dec 1 17:06:03.660: //-1/20E25B89801F/RXRULE/regxrule_get_RegXrule: Invalid translation ruleset tag=0
006196: Dec 1 17:06:03.660: //-1/20E25B89801F/RXRULE/regxrule_profile_match_internal: Error: ruleset for redirect-called number not found
006197: Dec 1 17:06:03.660: //-1/20E25B89801F/RXRULE/regxrule_profile_translate_internal: No match: number= type=UNKNOWN plan=UNKNOWN
006198: Dec 1 17:06:03.660: //-1/20E25B89801F/RXRULE/regxrule_profile_translate_internal: number=<redacted 6>

type=national plan=isdn numbertype=called
006199: Dec 1 17:06:03.660: //-1/20E25B89801F/RXRULE/regxrule_profile_match_internal: Matched with rule 1 in ruleset 6
006200: Dec 1 17:06:03.660: //-1/20E25B89801F/RXRULE/regxrule_profile_match_internal: Matched with rule 1 in ruleset 6
006201: Dec 1 17:06:03.660: //-1/20E25B89801F/RXRULE/sed_subst: Successful substitution; pattern=<redacted 7>

matchPattern=<redacted 8> replacePattern=401 replaced pattern=401

 

To the best of my knowledge no configuration changes have been made. Any assistance would be appreciated.

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

I don't really understand it, but it turns out that Unity was hung up. Rebooting that in the CCA fixed everything. Still not sure why rebooting the entire UC560 box 3 times didn't have the same result.

View solution in original post

2 REPLIES 2
Highlighted
VIP Rising star

Hello,

 

You may need to check the translation rules that you use for your incoming calls. Contacting your Provider will also be useful for checking its logs.

 

G

Please Rate Posts (by clicking on Star) and/or Mark Solutions as Accepted, when applies
Highlighted

I don't really understand it, but it turns out that Unity was hung up. Rebooting that in the CCA fixed everything. Still not sure why rebooting the entire UC560 box 3 times didn't have the same result.

View solution in original post

Content for Community-Ad