cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
19704
Views
24
Helpful
20
Replies

MGCP gateway is not registering

alalli
Explorer
Explorer

Good Day All,

I have configured a VG224 GW with CM4.2 and it does not seem to be registering.

The configurationis pretty stock/standard.

I double checked the host name with call manager and they match.

I have provided a copy of the router config minus passwords, aaa, line ports, etc and a copy of debug mgcp events.

If anyone has any ideas, they are much appreciated.

Regards,

Amanda

20 Replies 20

This was the solution for my registration issue .   Thank you ! 

This worked ! Thank you !

Hi Blanderos

 

Yes... But what worked for you?

I am running CUCM 12.5

 

ISR4331 IOS 16.6.4

 

ISR IP@ coes up in CUCM... but trunk appears unregistered!!!

 

ISR4331 declared with full name hostname.domain

 

I have MFT-T1/E1-E1 HW

 

Pls help and tell me what was the solution for you

 

JULIEN

Hi

Please follow below URL.

https://community.cisco.com/t5/collaboration-voice-and-video/mgcp-gateway-integration-with-cucm-and-pstn-service-provider/ta-p/3116588
*** Please rate helpful post. Please mark as answer if it solves your problem/query.
regards, Ritesh Desai

Hi,

 

Sorry... But obviously all this been done

 

Double checked and everything

 

Looks like its a famous issue with Cisco:

 

CUCM sees my GW/Trunk unregistered ...but @ VoIP_GW(ISR4331) level, it looks fine =>

 

HUB2-VOIP-RTR#sh ccm-manager
MGCP Domain Name: HUB2-VOIP-RTR.domainname
Priority Status Host
============================================================
Primary Registered 33.1X.X.X
First Backup None
Second Backup None

+

HUB2-VOIP-RTR#sh mgcp
MGCP Admin State ACTIVE, Oper State ACTIVE - Cause Code NONE
MGCP call-agent: 33..X.X.X. 2427 Initial protocol service is MGCP 0.1

 

So everything looks OK @ this VoIP_GW level

 

But still, no E1 service! When I tried to call out, NOK

 

What I've been doing =>

- Reset GW & E1 Trunk @ CUCM level

- RIS rebooted @ Publisher + Sub/CallManager-role level (even Tomcat if i remember all I've done!)

- Reboot ISR4331

- Reboot mgcp(no mgcp / mgcp)@ ISR4331

- Break then rebuild mgcp setup @both level(CUCM + ISR4331)

 

So this looks very strange to me

 

Even if it's registered on ISR4331, the unregistered state @ CUCM level makes like unable to call out thru this E1, unable to seize that E1 trunk

 

THX for advice

 

JULIEN

Hi,


On CUCM, MGCP trunk if its xyz.abc.com then on your VG hostname must be xyz and VG must be part of domain. If its not then make VG part of domain by adding below command.

On your Router have you configured ip domain name ?

Have a look at PRI, have you configured your PRI group timeslots with service mgcp?

Is your PRI up & it shows Multiple Frame Established?


*** Please rate helpful post. Please mark as answer if it solves your problem/query.
regards, Ritesh Desai
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: