cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2271
Views
5
Helpful
15
Replies

"No valid upgrade options were found" message while installing cucm 10.5su10

Hi, 

I am unable to update the call manager version 10.5.2.10000-5 to 10.5 SU10. Every time I try to load the file from SFTP, I am getting the error No valid options found. 

I tried with different SFTP software (FreeFTPd. Solarwind),  OS method, and CLI method but no luck, Anyone got any guidance to troubleshoot or how to progress further. 

File: UCSInstall_UCOS_10.5.2.22900-12.sgn.iso

Checked the file name and MD5 checksum and all looks good. I don't find any errors in the logs as such. I may have to try reboot next I beleive. 

 

Install Logs: 

01/31/2021 11:09:21 file_list.sh|/opt/cisco/install/bin/filter file=/var/log/install/downloaded_versions|<LVL::Debug>
01/31/2021 11:09:21 filter|Parse argument file=/var/log/install/downloaded_versions|<LVL::Debug>
01/31/2021 11:09:21 filter|No patch type specified. Optional.|<LVL::Debug>
01/31/2021 11:09:21 filter|No upgrade mode specifed. Optional.|<LVL::Debug>
01/31/2021 11:09:24 filter|Processing filter candidate names|<LVL::Debug>
01/31/2021 11:09:24 filter|Process "UCSInstall_UCOS_10.5.2.22900-12.sgn.iso"|<LVL::Debug>
01/31/2021 11:09:24 filter| Match against cop pattern (plm..*.cop)|<LVL::Debug>
01/31/2021 11:09:24 filter| Match against cop pattern (plm..*.cop.sgn)|<LVL::Debug>
01/31/2021 11:09:24 filter| Match against patch pattern (UCSInstall_UCOS_[0-9]+\.[0-9]+\.[0-9]+\.[0-9]+-[0-9]+.iso)|<LVL::Debug>
01/31/2021 11:09:24 filter| Match against patch pattern (UCSInstall_UCOS_UNRST_[0-9]+\.[0-9]+\.[0-9]+\.[0-9]+-[0-9]+.iso)|<LVL::Debug>
01/31/2021 11:09:24 filter| Match against patch pattern (UCSInstall_UCOS_[0-9]+\.[0-9]+\.[0-9]+\.[0-9]+-[0-9]+.sgn.iso)|<LVL::Debug>
01/31/2021 11:09:24 filter|INorOUT=IN UCSInstall_UCOS_10.5.2.22900-12.sgn.iso: Filter passed.|<LVL::Debug>
01/31/2021 11:09:24 file_list.sh|List file (post-filtered):|<LVL::Debug>
01/31/2021 11:09:24 file_list.sh|(CAPTURE) <?xml version="1.0" encoding="UTF-8"?>|<LVL::Debug>
01/31/2021 11:09:24 file_list.sh|(CAPTURE) <InstallList>|<LVL::Debug>
01/31/2021 11:09:24 file_list.sh|(CAPTURE) <InstallItem type="patch" secure-file="UCSInstall_UCOS_10.5.2.22900-12.sgn.iso" version="10.5.2.22900-12" file="UCSInstall_UCOS_10.5.2.22900-12.sgn.iso" reboot="no" signed="yes" unrestricted="no"/>|<LVL::Debug>
01/31/2021 11:09:24 file_list.sh|(CAPTURE) </InstallList>|<LVL::Debug>
01/31/2021 11:09:24 file_list.sh|success|<LVL::Info>
01/31/2021 11:09:24 file_list.sh|file_list.sh complete (rc=0)|<LVL::Info>
01/31/2021 11:09:24 file_list.sh|is_upgrade_lock_available: Upgrade lock is not available.|<LVL::Debug>

options: q=quit, n=next, p=prev, b=begin, e=end (lines 21 - 40 of 52) :
01/31/2021 11:09:24 file_list.sh|is_upgrade_in_progress: Already locked by this process (pid: 14928).|<LVL::Debug>
01/31/2021 11:09:24 file_list.sh|release_upgrade_lock: Releasing lock (pid: 14928)|<LVL::Debug>
01/31/2021 11:10:20 sd_cancelInstall.sh|Admin initiated a cancel
01/31/2021 11:10:20 sd_cancelInstall.sh|Process cancel utilities in /common/cancel_upgrade
01/31/2021 11:10:20 sd_cancelInstall.sh|Found no mount point to clean up.
01/31/2021 11:10:20 sd_cancelInstall.sh|Cleaning up /common/download directory
01/31/2021 11:10:20 sd_cancelInstall.sh|Installation CANCELLED
01/31/2021 11:10:20 sd_cancelInstall.sh|Canceling active side processes
01/31/2021 11:10:20 sd_cancelInstall.sh|Canceling active side processes done
01/31/2021 11:10:20 sd_cancelInstall.sh|Canceling inactive side processes
01/31/2021 11:10:20 sd_cancelInstall.sh|This is not a COP, so will do IDS shared memory clean up if needed on inactive partition
01/31/2021 11:10:20 sd_cancelInstall.sh|Canceling inactive side processes done

end of the file reached

Regards, 

Shalid 

15 Replies 15

Tyson Joachims
Rising star
Rising star

Is this in a virtual environment? If so, I'd transfer the upgrade file to the file store of the hypervisor and then mount the image to the guest OS's CD drive. Then run the upgrade from there. Can you see if that works?

Thanks for the response. 

That is my next plan if I couldn't resolve the remote file system method. unfortunately, we do not have access to vcentre, I will be asking for the same. 

 

Regards, 

I tried mounting to the datastore and attached it to the VM but no luck. 

in every case, whether it remote file system or CD/DVD, I am getting the same error. I tried different iso files and even I tried with the lower SU version. but no luck. 

Any guidance will be appreciated. 

Regards, 

 

 

I am not sure it this applies to your version 

ciscocm.version3-keys.cop.sgn  Go through the release guide.

 

 

 

 

 

 



Response Signature


checked it earlier but it looks like doesn't applicable here. moreover, I can see k3 files with I the existing call manager.  I tried with different versions of SU and another cop file, the call manager is not accepting any of these files. I may have to contact Cisco TAC further. 

Regards,

 

sd_cancelInstall.sh|Admin initiated a cancel >>> Why it says Admin initiated ?

 

 

 

 



Response Signature


Roger Kallberg
VIP Expert VIP Expert
VIP Expert

What type of installation of CM is it, restricted or unrestricted? Make sure that the upgrade file is for the same type.



Response Signature


As @Roger Kallberg mentioned check the versions too.

Upgrade from unrestricted to restricted  not possible.

 

 

 

 

 



Response Signature


@Nithin Eluvathingal Maybe you meant to ask the OP that, not to me as I asked the same?



Response Signature


Thank you all for your responses. 

 

  • The logs showing admin cancel since I cancelled the installation when I see the error "No valid upgrade options were found"
  • it is a restricted version (System version: 10.5.2.10000-5)  in the call manager and I am trying the same restricted version of iso files
  • Tried different hosts, different SFTP clients but no luck. In the logs, I can see the call manager reading the files in the SFTP directory. for some reason, it is not accepting the file name. I changed the file names but no luck.  

Regards,

 


@Shalid Kurunnan Chalil wrote:
  • I changed the file names but no luck.  

Not an answer to you're real issue, but you can not change the name of the file as it has a checksum and the CM will verify that the checksum is correct to validate the file. If you change the name the checksum will not match.



Response Signature


Hi,

 

Thanks, It was my desperate attempt to try out the all the ways. 

regards 

I would recommend to  Contact TAC .

 

 



Response Signature


Maybe a silly question but could you just confirm it is the Publisher you're trying to upgrade.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers