06-01-2016 09:31 PM - edited 03-17-2019 07:06 AM
We have CUBE with a SIP Trunk to CUCM. CUCM is version 11. When an inbound call come into the gateway I can see in the trace SIP invite messages sent to CUCM but I am not getting anything back. We took logs from CUCM but cannot see any SIP INVITE. I noticed in the logs all the packets are being dropped. Configuration is attached.
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname DC01-SR01
!
boot-start-marker
boot system flash bootflash:isr4300-universalk9.03.16.01a.S.155-3.S1a-ext.SPA.bin
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
enable secret 5 $1$XAVl$hYsjHbjgfdNcghGu2YT1m0
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
!
ip vrf DMZ
rd 65010:10
!
!
!
!
!
!
!
!
!
!
!
ip host sip.vocus.net.au 10.X.X.X
ip host _sip._udp.sip.vocus.net.au srv 10 10 5060 sip.vocus.net.au
ip name-server 202.X.X.X 202.X.X.X
ip domain name prod.vict.com.au
!
!
!
!
!
!
!
!
!
!
subscriber templating
!
multilink bundle-name authenticated
!
flow exporter Solarwinds
destination 172.X.X.X
source GigabitEthernet0/1/0
transport udp 2055
!
!
flow monitor Solarwinds
exporter Solarwinds
record netflow-original
!
!
!
!
!
!
!
!
!
voice vrf DMZ
!
voice service voip
ip address trusted list
ipv4 10.X.X.X
ipv4 10.X.X.X
ipv4 10.X.X.X
address-hiding
mode border-element license capacity 40
media disable-detailed-stats
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
no supplementary-service sip handle-replaces
fax protocol t38 version 0 ls-redundancy 1 hs-redundancy 1 fallback none
modem passthrough nse codec g711alaw
sip
registrar server
asserted-id pai
localhost dns:sip.vocus.net.au
options-ping 90
early-offer forced
history-info
midcall-signaling passthru
call-route p-called-party-id
!
voice class codec 1
codec preference 2 g711alaw
codec preference 3 g711ulaw
!
voice class sip-profiles 1
request INVITE sip-header P-Asserted-Identity modify "\.au\>" ".au;otg= VOC-72889-1-OTG >"
request INVITE sip-header To modify "@.*" "@sip.vocus.net.au>"
!
!
!
voice class dpg 201
dial-peer 201
!
voice class dpg 101
dial-peer 101 preference 1
dial-peer 102 preference 2
!
!
!
!
voice translation-rule 10
rule 1 /^03854797/ /97/
rule 2 /^385479700/ /97/
!
voice translation-rule 20
rule 1 // /00/
!
!
voice translation-profile VICT-INCOMING
translate calling 20
translate called 10
!
!
!
!
voice-card 0/4
no watchdog
!
license udi pid ISR4331/K9 sn FDO1942152L
!
spanning-tree extend system-id
!
username admin password 0 VICTNx0s
!
redundancy
mode none
!
!
!
!
!
vlan internal allocation policy ascending
!
!
class-map match-any SIP
match ip precedence 3
match ip dscp af31
match protocol sip
class-map match-any RTP
match ip precedence 5
match ip dscp ef
match protocol rtp
!
policy-map VoIP
class SIP
bandwidth percent 5
class RTP
priority percent 70
policy-map Outbound
class class-default
shape average 10000000
service-policy VoIP
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description DC01-SR01 BGP Router ID
ip address 10.1.X.X 255.255.255.255
!
interface Port-channel13
description Port-channel to DC01-CS01 & DC01-02 Po13
no ip address
no negotiation auto
!
interface Port-channel13.797
description DMZ-WANTRANSIT-01 - DC01-CS01 & DC01-02
encapsulation dot1Q 797
ip vrf forwarding DMZ
ip address 10.1.X.X 255.255.255.240
!
interface GigabitEthernet0/0/0
description DC01-CS01 Eth1/7
no ip address
media-type rj45
negotiation auto
channel-group 13 mode active
!
interface GigabitEthernet0/0/1
description DC01-CS02 Eth1/7
no ip address
negotiation auto
channel-group 13 mode active
!
interface GigabitEthernet0/0/2
description Temp CPNC Link
ip vrf forwarding DMZ
ip address 169.X.X.X 255.255.255.252
negotiation auto
!
interface GigabitEthernet0/1/0
description Link to Londsale Street
ip vrf forwarding DMZ
ip address 10.X.X.X 255.255.255.252
ip flow monitor Solarwinds input
ip flow monitor Solarwinds output
negotiation auto
!
interface GigabitEthernet0/1/1
description Vocus SIP Trunk
ip vrf forwarding DMZ
ip address 10.X.X.X 255.255.255.248
negotiation auto
service-policy output Outbound
!
interface Service-Engine0/4/0
!
interface GigabitEthernet0
description Out-of-Band Management Interface: DC01-AS01
vrf forwarding Mgmt-intf
ip address 10.1.X.X 255.255.255.0
negotiation auto
!
interface Vlan1
no ip address
shutdown
!
router bgp 65010
bgp router-id 10.1.95.133
bgp log-neighbor-changes
network 10.1.X.X mask 255.255.255.0
network 10.1.X.X mask 255.255.255.0
network 172.X.X.X mask 255.255.255.0
!
address-family ipv4 vrf DMZ
redistribute static
neighbor 169.X.1.X remote-as 27435
neighbor 169.X.1.X description CPNC
neighbor 169.X.1.X password 7 0528243A05456A080D043743595F506B
neighbor 169.X.1.X activate
neighbor 169.X.1.X route-map RM-CPNC-in in
neighbor 169.X.1.X route-map RM-CPNC-OUT out
exit-address-family
!
ip forward-protocol nd
no ip ftp passive
ip ftp source-interface GigabitEthernet0
no ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 10.1.84.1
ip route vrf DMZ 0.0.0.0 0.0.0.0 10.1.95.65
ip route vrf DMZ 0.0.0.0 0.0.0.0 10.1.95.6 tag 200 name VICT-DEFAULT-ROUTE
ip route vrf DMZ 10.1.0.0 X.255.0.0 10.1.95.65 name VICT-PROD_via_DC01-FW01
ip route vrf DMZ 10.X.X.0 255.255.255.0 10.1.95.65 name 1-stop_via_DC01-FW01
ip route vrf DMZ 10.X.X.0 255.255.255.0 10.1.95.65 name 1-stop_via_DC01-FW01
ip route vrf DMZ 10.X.0.3 255.255.255.255 10.249.4.9 name SIP-via-VOCUS
ip route vrf DMZ 172.X.X.0 255.255.255.0 10.1.95.253 tag 100 name LONSDALE
ip route vrf DMZ 202.X.X.X 255.255.255.255 10.249.4.9 name SIP-via-VOCUS
ip route vrf DMZ 202.X.X.X 255.255.255.255 10.249.4.9 name SIP-via-VOCUS
!
!
ip access-list extended VTY_ACCESS
permit tcp 10.1.X.0 0.0.15.255 any eq 22 log
!
!
ip prefix-list PL-DEFAULT-ROUTE seq 10 permit 0.0.0.0/0
!
ip prefix-list PL-VICT-CAAS seq 10 permit 10.184.119.0/24
ip prefix-list PL-VICT-CAAS seq 15 permit 10.184.45.0/24
ip prefix-list PL-VICT-CAAS seq 20 permit 10.184.208.0/24
ip prefix-list PL-VICT-CAAS seq 25 permit 10.184.96.0/24
!
ip prefix-list PL-VICT-IT_Cabin seq 10 permit 10.1.88.0/24
!
ip prefix-list PL-VICT-LONSDALE seq 10 permit 172.16.74.0/24
!
ip prefix-list PL-VICT-PROD seq 10 permit 10.1.0.0/16
!
ip prefix-list PL-VICT-SUMMARY seq 10 permit 49.255.238.128/27
logging source-interface GigabitEthernet0 vrf Mgmt-intf
logging host 10.1.X.X
!
route-map RM-CPNC-in permit 10
match ip address prefix-list PL-VICT-CAAS
!
route-map RM-CPNC-IN deny 20
match ip address prefix-list PL-VICT-LONSDALE
!
route-map RM-CPNC-OUT permit 10
match ip address PL-VICT-LONSDALE
!
route-map RM-CPNC-OUT deny 20
!
snmp-server trap-source GigabitEthernet0
snmp-server location NextDC
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps license
snmp-server enable traps memory bufferpeak
snmp-server enable traps config-copy
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps event-manager
snmp-server enable traps hsrp
snmp-server enable traps syslog
snmp-server enable traps flash insertion removal
snmp-server enable traps bgp
snmp-server enable traps ipsla
snmp-server enable traps alarms informational
snmp-server enable traps transceiver all
snmp-server enable traps voice
snmp-server enable traps ccme
snmp-server enable traps srst
snmp-server host 10.1.X.X version 2c VIctSS#%3645RW
snmp-server host 172.X.X.X version 2c VIctSS#%3645RW
!
!
!
!
control-plane
!
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 100 voip
description *** Inbound LAN dial-peer from CUCM
session protocol sipv2
session target sip-server
destination dpg 201
incoming called-number *T
voice-class codec 1
dtmf-relay rtp-nte
!
dial-peer voice 101 voip
description *** Outbound LAN dial-peer to CUCM
destination-pattern 97..
session protocol sipv2
session target ipv4:10.1.76.21
session transport tcp
voice-class codec 1
voice-class sip options-ping 65
voice-class sip bind control source-interface Port-channel13.797
voice-class sip bind media source-interface Port-channel13.797
dtmf-relay rtp-nte
!
dial-peer voice 200 voip
description *Inbound WAN dial-peer from AMCOM SIP
translation-profile incoming VICT-INCOMING
max-conn 40
session protocol sipv2
session target sip-server
destination dpg 101
incoming called-number .
dtmf-relay rtp-nte
codec g711alaw
!
dial-peer voice 201 voip
description *Outbound WAN dial-peer to VOCUS SIP
max-conn 40
destination-pattern *T
session protocol sipv2
session target sip-server
voice-class sip profiles 1
voice-class sip bind control source-interface GigabitEthernet0/1/1
voice-class sip bind media source-interface GigabitEthernet0/1/1
dtmf-relay rtp-nte
codec g711alaw
!
dial-peer voice 102 voip
description *** Outbound LAN dial-peer to CUCM
destination-pattern 97..
session protocol sipv2
session target ipv4:10.1.X.X
session transport tcp
voice-class codec 1
voice-class sip options-ping 65
voice-class sip bind control source-interface Port-channel13.797
voice-class sip bind media source-interface Port-channel13.797
dtmf-relay rtp-nte
!
!
gateway
timer receive-rtp 1200
!
sip-ua
credentials number VOC-72889-1-Pilot username VOC-72889-1-Trunk password 7 047221302D334917514E5210465E5F53 realm sip.vocus.net.au
authentication username VOC-72889-1-Trunk password 7 132C3D24291E017373737F3461774050 realm sip.vocus.net.au
no remote-party-id
retry invite 2
retry response 3
retry prack 6
retry register 3
timers expires 300000
registrar dns:sip.vocus.net.au expires 3600
sip-server ipv4:10.X.0.X
!
banner motd ^C
**************************************************************************
**************************************************************************
WARNING
Access to this system is for authorised users and for authorised purposes only.
Unauthorised access or use is a serious breach of security policies.
For staff this may involve disciplinary action up to and including
dismissal, it may also be a criminal or civil offence.
If you or your intended use are not authorised do not proceed to log on
DC01-SR01#
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
All inbound calls the SIP INVITE are not being sent to Call Manager. Look like it is being dropped
Log Buffer (4096 bytes):
d from console by admin on vty0 (10.1.112.238)
SIP: Trying to parse unsupported attribute at media level
Jun 2 01:05:22.294: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=665, local_addr=10.1.95.76, remote_addr=10.1.76.21, remote_port=5060 - All retries are exhausted, deleting pending messages
Jun 2 01:05:25.805: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=666, local_addr=10.1.95.76, remote_addr=10.1.76.22, remote_port=5060 - All retries are exhausted, deleting pending messages
SIP: Trying to parse unsupported attribute at media level
Jun 2 01:05:28.333: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=665, local_addr=10.1.95.76, remote_addr=10.1.76.21, remote_port=5060 - All retries are exhausted, deleting pending messages
Jun 2 01:05:31.837: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=666, local_addr=10.1.95.76, remote_addr=10.1.76.22, remote_port=5060 - All retries are exhausted, deleting pending messages
SIP: Trying to parse unsupported attribute at media level
Jun 2 01:05:34.569: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=665, local_addr=10.1.95.76, remote_addr=10.1.76.21, remote_port=5060 - All retries are exhausted, deleting pending messages
Jun 2 01:05:38.066: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=666, local_addr=10.1.95.76, remote_addr=10.1.76.22, remote_port=5060 - All retries are exhausted, deleting pending messages
SIP: Trying to parse unsupported attribute at media level
Jun 2 01:05:40.742: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=665, local_addr=10.1.95.76, remote_addr=10.1.76.21, remote_port=5060 - All retries are exhausted, deleting pending messages
Jun 2 01:05:44.249: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=666, local_addr=10.1.95.76, remote_addr=10.1.76.22, remote_port=5060 - All retries are exhausted, deleting pending messages
SIP: Trying to parse unsupported attribute at media level
Jun 2 01:05:46.772: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=665, local_addr=10.1.95.76, remote_addr=10.1.76.21, remote_port=5060 - All retries are exhausted, deleting pending messages
Jun 2 01:29:06.944: %SYS-5-CONFIG_I: Configured from console by admin on vty0 (10.1.112.238)
Jun 2 01:44:18.402: %SYS-5-CONFIG_I: Configured from console by admin on vty0 (10.1.112.238)
Jun 2 02:13:35.732: %SEC-6-IPACCESSLOGP: list VTY_ACCESS permitted tcp 10.1.112.238(57519) -> 0.0.0.0(22), 1 packet
Jun 2 02:18:45.812: %SEC-6-IPACCESSLOGP: list VTY_ACCESS permitted tcp 10.1.112.238(57519) -> 0.0.0.0(22), 1 packet
SIP: Trying to parse unsupported attribute at media level
Jun 2 02:28:39.674: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=667, local_addr=10.1.95.76, remote_addr=10.1.76.21, remote_port=5060 - All retries are exhausted, deleting pending messages
Jun 2 02:28:43.175: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=668, local_addr=10.1.95.76, remote_addr=10.1.76.22, remote_port=5060 - All retries are exhausted, deleting pending messages
SIP: Trying to parse unsupported attribute at media level
Jun 2 02:28:45.862: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=667, local_addr=10.1.95.76, remote_addr=10.1.76.21, remote_port=5060 - All retries are exhausted, deleting pending messages
Jun 2 02:28:49.357: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=668, local_addr=10.1.95.76, remote_addr=10.1.76.22, remote_port=5060 - All retries are exhausted, deleting pending messages
SIP: Trying to parse unsupported attribute at media level
Jun 2 02:28:52.043: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=667, local_addr=10.1.95.76, remote_addr=10.1.76.21, remote_port=5060 - All retries are exhausted, deleting pending messages
Jun 2 02:28:55.549: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=668, local_addr=10.1.95.76, remote_addr=10.1.76.22, remote_port=5060 - All retries are exhausted, deleting pending messages
SIP: Trying to parse unsupported attribute at media level
Jun 2 02:28:58.053: %SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=667, local_addr=10.1.95.76, remote_addr=10.1.76.21, remote_port=5060 - All retries are exhausted, deleting pending messages
DC01-SR01#
Any Suggestions please!
06-02-2016 06:32 AM
Please provide full "debug ccsip messages" showing both call legs as well as "debug voice dialpeer".
Also, make sure CUCM SIP trunk configuration uses SIP security profile with TCP enabled as that appears to be what you are using.
06-06-2016 12:14 AM
06-02-2016 10:33 AM
Hello,
normally "unsupported attribute at media level" comes when GW having issue in parsing any attribute value from the SDP. example.
m=audio 49594 RTP/AVP 0 101
a=rtpmap:0 PCMU/8000
a=sendrecv
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=ptime:20
a=xyzasbcada ===================> unsupported attribute value in the feild which GW not able to parse it and hence generating error.
SIP: Trying to parse unsupported attribute at media level
for below error, what is this ip address? 10.1.95.76. Can you please check is there any dial-peer pointing this ip address and having some issue? if there is tcp timed out or reachabiliity issue you would see this error.
%SIP-3-INTERNAL: TCP_SOCKET_SEND_BLOCKED: connid=667, local_addr=10.1.95.76
as suggested by Chris please collect the relevant debugs to find out what exactly is happening.
Br,
Nadeem
01-22-2018 06:35 AM
03-27-2021 06:33 PM
Have you solved this problem?
I have the same issue...
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide