cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
307
Views
0
Helpful
6
Replies

VLAN Flapping on ports with cisco phones

elcookie16
Level 1
Level 1

I have a cisco 9300 with cisco 7841 phones running passthrough to workstations. The phone macs and flapping between data vlan(1250) and voice vlan(1260). I have tried clearing the mac table. I don't see any STP topology changes and I even tried shutting one member of the port-channel down to ensure no loops. I have compared configs to every other switch I have and can't find anything different about this one. Every port with a phone is flapping on this switch. It flaps roughly every 15 seconds.

interface GigabitEthernet2/0/31
description USERS
switchport access vlan 1250
switchport mode access
switchport nonegotiate
switchport block unicast
switchport voice vlan 1260
storm-control broadcast level 75.00
storm-control action trap
spanning-tree portfast
spanning-tree bpduguard enable
spanning-tree guard root
service-policy output BAN-QOS
end

elcookie16_1-1718914636745.png

Every entry here is about 5 seconds apart. Any ideas?

1 Accepted Solution

Accepted Solutions

As I know it bug of SW 

The phone is appear in both voice and data vlan' 

The recommend solution from cisco TAC is config port secuirty with max two mac in port.

So in one port try add port-secuirty and max mac two and violation is log only not shutdown

Try above in one port and check 

Thanks 

Goodluck 

MHM

View solution in original post

6 Replies 6

Can you check cdp 

Did you see  both phone and workstation 

MHM

2 entries in cdp both ports. 

SEP00DF1D890F04 Gig 2/0/31 159 H P M IP Phone Port 2
SEP00DF1D890F04 Gig 2/0/31 156 H P M IP Phone Port 1

elcookie16_0-1718916534833.png

 

As I know it bug of SW 

The phone is appear in both voice and data vlan' 

The recommend solution from cisco TAC is config port secuirty with max two mac in port.

So in one port try add port-secuirty and max mac two and violation is log only not shutdown

Try above in one port and check 

Thanks 

Goodluck 

MHM

balaji.bandi
Hall of Fame
Hall of Fame

what IOS Code running ?

test different scenario :

1. default teh interface Gi2/0/31 put some simple config voice and Data vlan  like below :

nterface GigabitEthernet2/0/31
description USERS
switchport access vlan 1250
switchport mode access
switchport voice vlan 1260
spanning-tree portfast
service-policy output BAN-QOS

2. Have you tried Phone alone and PC connecting to other port is this still flaps ?

3. how is your DHCP configuration ? (can you compare with other switch working ?)

4. Also do you have Power enough ? show post and show power inline ?

5 . show cdp neigh

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Version 17.09.04a

I put the following config on 2/0/31 and it still flaps.

Interface GigabitEthernet2/0/31
description USERS
switchport access vlan 1250
switchport mode access
switchport voice vlan 1260
spanning-tree portfast

Phone flaps on the port by itself without the PC. I need to run these on passthrough so I am not wasting ports. 
DHCP is the same for all other phone vlans. 
I have 1336 watts remaining on power. 

CDP Neighbor entries for devices is question. Note every port with a cisco phone is flapping.
SEP00DF1D890F04 Gig 2/0/31 159 H P M IP Phone Port 2
SEP00DF1D890F04 Gig 2/0/31 156 H P M IP Phone Port 1

Try 17.9.5 or above some improvements you may see.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help