cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
176
Views
0
Helpful
8
Replies
Highlighted
Beginner

VOIP Setup

I'm new to this organization and their cisco switch setup is giving me a headache.

we have Voip setup with vlans and all, but the ports carrying voip have been set as trunk ports. I want to make them normal access ports that can carry voice traffic. But whenever i do so, the phones refuse to register.

This is the current setup of a voip port:

interface GigabitEthernet1/0/10
switchport trunk native vlan 21
switchport trunk allowed vlan 20,21
switchport mode trunk
switchport voice vlan 20
spanning-tree portfast

 

This is what I did:

no switchport trunk native vlan 21
no switchport trunk allowed vlan 20,21
switchport mode access

switch access vlan 21
switchport voice vlan 20

 

But it shows phone unregistered.

VLAN 21 = data vlan

VLAN 20 = voice

the native vlan on the real trunk link is vlan 1

why does it work when the interface is a trunk but doesnt work when i change it to my configuration?

 

Switch is a cisco 2960 and IP phone is a CP 7821

8 REPLIES 8
Highlighted
Hall of Fame Community Legend

There are a few VoIP brands that need be on Trunk ports.  

Highlighted
VIP Advocate

if you enable LLDP on switch and with  voice and data vlan configuration  all most all phones will work. some may need trunk.

 

can you specify the phone model which you are using and switch details. 

=>>>If this answered your question, please click "ACCEPT AS SOLUTION"<<<=
=>>>If you find this response useful, please mark it as "HELPFUL"<<<=
Highlighted

It's a cisco cp7821 model IP phone

Highlighted

Hope you are using Cisco witch.

try below.

Default interface GigabitEthernet1/0/10

 

interface GigabitEthernet1/0/10
switchport mode access

switch access vlan 21
switchport voice vlan 20

if this is not a Cisco switch, turn on LLDP.

=>>>If this answered your question, please click "ACCEPT AS SOLUTION"<<<=
=>>>If you find this response useful, please mark it as "HELPFUL"<<<=
Highlighted

Already did that. The device is stuck at not registered

Highlighted

Whats ur call control platform.

Whats the operational vlan and ip address on phone. also share the status message from phone.

 

is this for just one phone or all ? hae you tried resetting the phone ?

 

 

 

 

=>>>If this answered your question, please click "ACCEPT AS SOLUTION"<<<=
=>>>If you find this response useful, please mark it as "HELPFUL"<<<=
Highlighted
Hall of Fame Community Legend


@amatorjnr wrote:

Already did that. The device is stuck at not registered


Is the phone getting a valid IP address or not?

Highlighted
VIP Engager

Not all platforms support voice VLAN functionality without specifying the port mode is trunk. For some it's just an advertisement and needs configuration, and for others it configures it to accept that tagged traffic.

If what you've changed it to doesn't produce anything useful then configure it back the way it was.

Content for Community-Ad