cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3334
Views
41
Helpful
20
Replies

VWIC3-1MFT-T1/E1 showing Unregistered in CUCM 10.5

9tysixuae
Level 1
Level 1

Hello,

 I am trying to register E1 and 8 FXO with CUCM 10.5 using mgcp. FXOs are showing registered in CUCM but not E1, it shows Unregistered. I have attached the Gateway configuration and screenshot CUCM. I am using Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.4(1)T3, REL
EASE SOFTWARE. Please let me if there is any mistakes in my configuration.

 

AD_Voice_GW#show ccm-manager
MGCP Domain Name: AD_Voice_GW
Priority        Status                   Host
============================================================
Primary         Registered               10.20.13.9
First Backup    Backup Ready             10.20.13.8
Second Backup   None

Current active Call Manager:    10.20.13.9
Backhaul/Redundant link port:   2428
Failover Interval:              30 seconds
Keepalive Interval:             15 seconds
Last keepalive sent:            14:39:48 GMT Apr 10 2015 (elapsed time: 00:00:12
)
Last MGCP traffic time:         14:39:48 GMT Apr 10 2015 (elapsed time: 00:00:12
)
Last failover time:             None
Last switchback time:           None
Switchback mode:                Graceful
MGCP Fallback mode:             Not Selected
Last MGCP Fallback start time:  None
Last MGCP Fallback end time:    None
MGCP Download Tones:            Disabled
TFTP retry count to shut Ports: 2

Backhaul Link info:
    Link Protocol:      TCP
    Remote Port Number: 2428
    Remote IP Address:  10.20.13.9
    Current Link State: OPEN
    Statistics:
        Packets recvd:   1
        Recv failures:   0
        Packets xmitted: 2
        Xmit failures:   0
    PRI Ports being backhauled:
        Slot 0, VIC 0, port 0
Configuration Auto-Download Information
=======================================
Current version-id: 1428657466-23cb555c-fb36-457e-81fa-58438df308d4
Last config-downloaded:00:00:00
Current state: Waiting for commands
Configuration Download statistics:
        Download Attempted             : 1
          Download Successful          : 1
          Download Failed              : 0
          TFTP Download Failed         : 0
        Configuration Attempted        : 1
          Configuration Successful     : 1
          Configuration Failed(Parsing): 0
          Configuration Failed(config) : 0
Last config download command: New Registration
FAX mode: disable
Configuration Error History:
AD_Voice_GW#

==============================================================================

D_Voice_GW#show isdn status
Global ISDN Switchtype = primary-net5

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not appl
y

ISDN Serial0/0/0:15 interface
        dsl 0, interface ISDN Switchtype = primary-net5
        L2 Protocol = Q.921 0x0000  L3 Protocol(s) = CCM MANAGER 0x0003
    Layer 1 Status:
        SHUTDOWN
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x00000000
    Number of L2 Discards = 0, L2 Session ID = 0
    Total Allocated ISDN CCBs = 0
AD_Voice_GW#

=====================================================================================

AD_Voice_GW#show mgcp endpoint

Interface E1 0/0/0

             ENDPOINT-NAME    V-PORT     SIG-TYPE   ADMIN
  S0/SU0/ds1-0/1@AD_Voice_G  0/0/0:15        none   up
  S0/SU0/ds1-0/2@AD_Voice_G  0/0/0:15        none   up
  S0/SU0/ds1-0/3@AD_Voice_G  0/0/0:15        none   up
  S0/SU0/ds1-0/4@AD_Voice_G  0/0/0:15        none   up
  S0/SU0/ds1-0/5@AD_Voice_G  0/0/0:15        none   up
  S0/SU0/ds1-0/6@AD_Voice_G  0/0/0:15        none   up
  S0/SU0/ds1-0/7@AD_Voice_G  0/0/0:15        none   up
  S0/SU0/ds1-0/8@AD_Voice_G  0/0/0:15        none   up
  S0/SU0/ds1-0/9@AD_Voice_G  0/0/0:15        none   up
  S0/SU0/ds1-0/10@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/11@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/12@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/13@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/14@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/15@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/17@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/18@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/19@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/20@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/21@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/22@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/23@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/24@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/25@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/26@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/27@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/28@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/29@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/30@AD_Voice_  0/0/0:15        none   up
  S0/SU0/ds1-0/31@AD_Voice_  0/0/0:15        none   up

aaln/S0/SU1/0@AD_Voice_GW
aaln/S0/SU1/1@AD_Voice_GW
aaln/S0/SU1/2@AD_Voice_GW
aaln/S0/SU1/3@AD_Voice_GW
aaln/S0/SU2/0@AD_Voice_GW
aaln/S0/SU2/1@AD_Voice_GW
aaln/S0/SU2/2@AD_Voice_GW
aaln/S0/SU2/3@AD_Voice_GW

AD_Voice_GW#

 

 

1 Accepted Solution

Accepted Solutions

Since ISDN Layer 1 was showing as Deactivated/Shutdown,so , framing crc4 could be main cause.

 

regds,

aman

View solution in original post

20 Replies 20

Hi.

Your E1 Level 2 is not up (not multiple frame established) that's why is not registered on CUCM.

Check your port configuration on CUCM and verify the connectivity to your TSP.

 

 

Please let me know

 

Regards

 

Carlo

 

 

Please rate all helpful posts "The more you help the more you learn"

Layer 1 connectivity is not working. It is acting like the E1 is not plugged in to 0/0/0 or the E1 is down from the carrier or the cable is bad. 

 

  Layer 1 Status:
        SHUTDOWN

 

 

kkoeper12 is correct, layer 1 is shutdown (bad), and Layer 2 is in TEI_ASSIGNED (bad). In this state it is normal for the E1 endpoint to not register with CUCM.

    Layer 1 Status:
        SHUTDOWN
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED


Please engage your provider to look into this.


Additionally, you could run a loopback test to see if there is an MGCP issue (although since you have your FXO ports registered this is most likely not the case). If you put your PRI into loopback mode (for testing purposes), it should register with CUCM and will validate E1 MGCP registration.

controller e1 0/0/0
loopback local line

http://www.cisco.com/c/en/us/support/docs/voice/device-signaling/116492-trouble-t1e1-00.html#anc4

 

Another great command for checking E1 status is "show controllers e1".

Sorry for the delay. E1 is connected to port and I tested the connection with another 3com voice E1 gateway, it working fine. So i think I am missing something in my cisco configuration. Please go through my configuration let me know if there is something missing. Or do I need to do some shutdown, no shutdown command.

Thank you for your support.

Hi,

 

If physical layer E1 is coming up with 3 COM VG, then try swapping the E1 pairs at either modem or router E1 port end.

 

https://supportforums.cisco.com/document/34981/various-pin-outs-used-pots-connections

you can try changing the CRC-4 framing on E1 controller.

 

regds,

aman

Thank you. I swapped from modem side, but no use. Still showing shutdown. When checked with service provider they infomed for framing use CRC is disabled.

Hi.

Can you please post a screenshot of port configuration on cucm?

Also try to reload the vg and  post the output of a show mgcp endpoint

 

 

Thanks

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"

thank you, the issue solved, I dont know how. I just give shutdown and no shutdown on the controller interface as per my service provider request. Its working fine now. thank you all for your kind support. Any comments??

 

#show isdn status
Global ISDN Switchtype = primary-qsig

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not apply

ISDN Serial0/0/0:15 interface
        dsl 0, interface ISDN Switchtype = primary-net5
        L2 Protocol = Q.921 0x0000  L3 Protocol(s) = CCM MANAGER 0x0003
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0xFFFF7FFF
    Number of L2 Discards = 0, L2 Session ID = 4
    Total Allocated ISDN CCBs = 0

 

the only change which I could find is that you have configured global isdn switch type as primary-qsig while in your first discussion , it shows primary-net5.

 

even though it does not matter since switch type is configured as primary-net5 on interface .

 

Any other change u did ?

 

regds,

aman