10-21-2014 01:23 PM
I have a requirement to pass a Xconnect over an RSVP-TE signalled tunnel, but I do not have the option to add a preferred-route so the Xconnect always passes over LDP signalled LSPs.
All examples I have seen suggest to use preferred-route under xconnect configuration but this is not available on either a 7200 router or ME3600.
Could anyone advise on how I get the xconnect to pass over the RSVP-TE tunnel?
Thanks
Paolo
10-21-2014 11:11 PM
Hi,
If preferred path option is not there then probably you need to do routing to prefer TE tunnel for xconnect destination. It can be done via static route or auto-route announce. If this causes all traffic between two PE taking one TE tunnel, you can have different loopback for the xconnect so that only traffic for that L2vpn can be routed via that tunnel.
--Pls dont forget to rate helpful posts--
Regards,
Akash
10-22-2014 02:22 AM
Thanks for this.
I have tried setting up another tunnel interface between different loopbacks which comes up fine, however when I try to xconnect between the new loopbacks i get an MPLS Config error saying the loopback address is not a valid LDP id, use the original loopback instead.
Any thoughts?
Paolo
10-22-2014 08:29 AM
Hi Paolo,
For TE to come up , TE destination should be TE router-id on tail-end but for xconnect there is no such requirement. Please share the error message and check if LSP to new loopback is through or not. you can use command "ping mpls ipv4 <destination loopback> <source loopback>"
-Akash
10-23-2014 01:59 PM
Hi Akash,
Thanks for your help.
The RSVP-TE tunnel is up ok and I have a route for the second loopback through the tunnel using a static route. But when I configure the Xconnect to use the second loopback I get the following error:
MPLS config error: 10.191.254.4 is not a valid LDP id, use 10.191.255.4 instead.
I am using 7200 routers on GNS3 but plan to implement this on ME3600 in our live network.
I do not have the ping mpls command available.
Thanks
Paolo
Relevant config below:
Side 1:
interface Loopback0
ip address 10.191.255.3 255.255.255.255
!
interface Loopback1
ip address 10.191.254.3 255.255.255.255
!
interface Tunnel69
ip unnumbered Loopback0
tunnel destination 10.191.255.4
tunnel mode mpls traffic-eng
tunnel bandwidth transmit 10000
tunnel bandwidth receive 10000
tunnel mpls traffic-eng path-option 1 dynamic
no routing dynamic
!
interface FastEthernet0/0
ip address 10.191.0.2 255.255.255.254
ip ospf cost 200
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 50000 50000
!
interface FastEthernet1/0.11
encapsulation dot1Q 11
no cdp enable
xconnect 10.191.254.4 70 encapsulation mpls
!
Side 2:
interface Loopback0
ip address 10.191.255.4 255.255.255.255
!
interface Loopback1
ip address 10.191.254.4 255.255.255.255
!
interface Tunnel69
ip unnumbered Loopback0
tunnel destination 10.191.255.3
tunnel mode mpls traffic-eng
tunnel bandwidth transmit 10000
tunnel bandwidth receive 10000
tunnel mpls traffic-eng path-option 1 dynamic
no routing dynamic
!
interface FastEthernet0/0
ip address 10.191.0.3 255.255.255.254
ip ospf cost 200
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 50000 50000
!
interface FastEthernet1/0.11
encapsulation dot1Q 11
no cdp enable
xconnect 10.191.254.3 70 encapsulation mpls
10-30-2014 02:26 AM
Hello Paolo,
Use the ATOM Tunnel selection feature
http://www.cisco.com/c/en/us/td/docs/ios/12_2sr/12_2sra/feature/guide/srtunsel.html#wp1055371
at both sides configure the following PW
pseudowire-class paolo
encapsulation mpls
preferred-path interface Tunnel69
Then on Side 1:
interface FastEthernet1/0.11
encapsulation dot1Q 11
no cdp enable
xconnect 10.191.254.4 70 pw-class paolo
Side 2 :
interface FastEthernet1/0.11
encapsulation dot1Q 11
no cdp enable
xconnect 10.191.254.3 70 pw-class paolo
Thanks
11-07-2014 06:21 AM
Hi,
Thanks for your answer, but unfortunately I do not have the preferred-path option available - this is the problem.
Thanks
Paolo
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide