cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
37738
Views
55
Helpful
22
Replies
Highlighted
Beginner

ASDM ASA 5510 Error

There were several postings online. This may not be the best or only fix but this is what worked for me.

So here is the work-around that I used to resolve the issue.

1. Go to the ASA IP address in IE.

2. Select Continue to website. (This is where it asks if you want to install the ASDM Launcher)

3. In the Address Bar click on "Certificate Error" then "View Certificates."

4. Go to Details tab and select "Copy to File" and export the cert to my desktop using the default DER format.

5. Open Java Control Panel and go to "Security" tab and "Manage Certificates."

6. Selected "Secure Site" in drop down box and clicked "Import."

7. Select "All Files" in drop down box, and selected the Cert that I exported from IE.

Some of my customers told me that the “copy-to” button was grayed out, this is because the IP is not in the trusted zone.

Here is the fix for that if needed

  1. From the Tools menu, select Internet Options.
  2. In the Security tab, click Trusted Sites.
  3. Click the Sites button.
  4. Where it says "Add this website to the zone," enter the website address provided in the email you received.
  5. Click Add.
  6. Click Close.
  7. Click OK.
  8. Set the Security Level for the Trusted Sites zone to Medium.
  9. Click OK.
  10. Close and re-launch web browser, the button will be selectable

Then use the webstart ASDM if all of the above fails. :-/

View solution in original post

Beginner

Thanks a lot John and

Thanks a lot John and Mitchell. Faced the same issue. Now it's clear.

Highlighted

ASDM ASA 5510 Error

Unfortunately, Java Webstart did not work with me, at least not before I added the ASA URL to the exception list of Java Control Panel.

Go to Java Control Panel, Security tab, then click Edit Site List, and add the URL of your ASA (https://ASAIPAddress)

Highlighted
Beginner

How to get ASDM to work with

How to get ASDM to work with Java 1.7

Highlighted
Beginner

I got the same issue and the

I got the same issue and the solution is import SSL certificate of the ASA to Certificate Snap-in:

- Open https:\\asaipaddress
- Export certificate to ABC.cer (up to browsers)
- Start\Run => mmc
- File => Add\Remove Snapin
- Select Certificate \ Computer Account \ Local Computer
- Import ABC.cer to:
    - Personal
   - Trusted root certification authorities
   - Intermediate certification authorities
- Done

Highlighted

Voquoclevi, Thanks! I was

Voquoclevi,

 

Thanks! I was able to follow you up to the point of importing the certificate to Personal Trusted and Intermediate. WHere do I get the cert to install? I don't recall the step to actually save a .cer file.

 

Thanks!

Highlighted
Beginner

Metuckness2014, That's first

Metuckness2014

That's first step: Open web browser, browse to ASA address. And the way to export .CER file is based on each particular browser.

Highlighted

I'm sure there are more

I'm sure there are more elegant solutions I could hack with, but....

Your solution to go through IE and add the security certificate worked, and just saved me literally hours of effort. 

Thank you.

Paul

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards