cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1228
Views
0
Helpful
31
Replies

Apply SNMP to Cisco Meeting Server (CMS)

Ahmed Tarek
Beginner
Beginner

Hello Experts,

i need to apply SNMP v3 to CMS ( Version 3.6 )

1 Accepted Solution

Accepted Solutions

Ahmed Tarek
Beginner
Beginner

Dear All,

after check with real expert the correct commands are :

cms>snmp disable

cms>snmp user add test ******** SHA AES

cms>snmp enable

pls note the following

user is test (with no password) ( test it is name for user )

******** is password for SHA and AES ( same password for both, not different for each other ) SAME !

then you set same setting in snmp server side

View solution in original post

31 Replies 31

thanks a lot for your support,

i will proceed and tell you the results

HI NITHIN,

i used below commands

- SNMP enabled

then

- snmp user add <name> <> (SHA)***** (AES) ****

but it is not work, kindly advise

*** is mean password for SHA and AES

And what is the error? Wrong username / password, cannot connect, ...?
What are you typing exactly? I think the way you posted it, is wrong ...
Type it again and then make a screenshot of it.

Thanks for reply

i get SNMP commands guide from CMS, pls tell me exactly command to follow 

If you have the guide and also the screenshot from @Nithin Eluvathingal, why don't you follow the instructions?

snmp user add <username> <password> <MD5 or SHA> <DES or AES>
The red parameter are optional, this depends on the settings in your SNMP server.

E.g.
snmp user add myusername mypassword SHA AES

thanks a lot for your support,

i already type above command, but it dose not work

i add also password after SHA and AES too, as there is password for username

what do you think ?

As already written, you need to also check the settings on the SNMP server ...
Are you using SHA and AES on the SNMP server?
Do you see any error message on the SNMP server or in CMS?

It doesn't help, if you don't answer all my questions.

Check the message in CMS if you enter the command "syslog follow", after you enter the command "snmp enable".

If you can't read the messages, then post the output of CMS here.
But without any logs or screenshot or whatever, nobody will be able to help you, because we cannot read your mind or see what you see!!

thanks again for support, as i mentioned above i type what i get when proceed to add SNMP command, i type ( get SNMP commands guide from CMS )

like below

Usage:
snmp enable
snmp disable
snmp community add <name> [<ip address>/<prefix>]
snmp community del <name>
snmp user add <username> <password> (MD5|SHA) (DES|AES)
snmp user del <username>
snmp trap enable <agent> <community>
snmp trap disable
snmp trap test

above is what i get , above is guide !!! this is what i said above!!! SNMP GUIDE !!  is this difficult for you to understand ?

result nothing, so i asked again to get correct command as i `m just beginner.

if you can help i will be appreciated, if not pls stop and let any one else to support.

do you understand me now ?

Why don't you just do what I'm writing? Why don't you answer all the questions, that you are asked?!
How should somebody be able to help you, if you don't provide all the information that you are asked for?

What are the settings in the SNMP server? They need to match with what you are configuring in CMS.
Are you using SHA and AES on the SNMP server?
Do you see any error messages on the SNMP server?
Dou you see any error messages in CMS? Check the messages output in CMS if you enter the command "syslog follow" in the CLI after you enter the command "snmp enable".
Why can't you post a screenshot of what you are typing in the CLI and the corresponding output?

i think we waste more time for this as i said i only get SNMP commands guide again after i input my command, anyway pls find below data :-

What are the settings in the SNMP server? They need to match with what you are configuring in CMS.

see attached no 1 ( SNMP server run successfully with CUCM with same setting )

---------------------

Are you using SHA and AES on the SNMP server?

using sha ( i typed my command above ) so you can know what i used!

---------------------

Do you see any error messages on the SNMP server?

No

---------------------

Do you see any error messages in CMS? Check the messages output in CMS if you enter the command "syslog follow" in the CLI after you enter the command "snmp enable".

No error messages in CMS at all , only below

Usage:
snmp enable
snmp disable
snmp community add <name> [<ip address>/<prefix>]
snmp community del <name>
snmp user add <username> <password> (MD5|SHA) (DES|AES)
snmp user del <username>
snmp trap enable <agent> <community>
snmp trap disable
snmp trap test

first command i typed is snmp enabled

---------------------

Why can't you post a screenshot of what you are typing in the CLI and the corresponding output?

i typed above my command i input, anyway see attached image no 2

 

b.winter
VIP Advocate VIP Advocate
VIP Advocate

You are typing the command in a wrong format, that is why you get the output of the command list:
Usage:
snmp enable
snmp disable
snmp community add <name> [<ip address>/<prefix>]
snmp community del <name>
snmp user add <username> <password> (MD5|SHA) (DES|AES)
snmp user del <username>
snmp trap enable <agent> <community>
snmp trap disable
snmp trap test

This is a basic rule for you to know, if you type any command wrong, you will get the command list again.
CMS won't give you a error message if you type the command incorrectly.

As already written in the example, the format is:
snmp user add myusername mypassword SHA AES

What you are typing is:
snmp user add <...> <> (sha1) (...) (AES128) (...)

There is a basic misunderstanding on your side, how to enter commands in CMS CLI.

Parameters between <..> are mandatory paramters and should be substitutad with the correct value:
e.g.: <name> --> myusername

Parameters between (...) are optional parameters and you should select one of them:
e.g.: (MD5|SHA) --> you type MD5 or SHA

So in your case you now type the following:
snmp user add msroot password SHA AES
And please replace the red password with your own password.

thanks again, but as i am saying before i`m beginner

sorry could you pls type exact command to proceed ?

thanks to note the following: -

username in SNMP server has no password

SHA1 has password and we type in CMS command

AES has password and we type it in CMS command

i typed below command

snmp user add <username> <> SHA1 password AES password

what i miss?

What you miss? You miss to read carefully!
What's so hard to just type in what I have written? You typed the command incorrectly again!
If you don't read and follow, what other people write, then this has nothing to do with being a beginner...

What I have written:
snmp user add msroot password SHA AES

What you have written:
snmp user add <username> <> SHA1 password AES password

Don't you see the difference?!

In your SNMP server:
SNMPv3 Username: msroot
SNMPv3 Authentication --> Method: SHA1
SNMPv3 Authentication --> Password: thisismypassword
SNMPv3 Privacy / Method --> Method: AES128
SNMPv3 Authentication --> Password: thisismypassword

In CMS you type exactly the following:
snmp user add msroot thisismypassword SHA AES

Isn't that hard right?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers