Showing results for 
Search instead for 
Did you mean: 

MGCP CM Primary won't register


Hi all,

I have a new 2851 running 12.3911)T10

1 MFT T1 in the MBRD slot 3

CM 4.1.2 with a publisher and sub



I will past the config in here, but here is the issue, the Sub as the Primary will not register even though the Pub is fine. (see "sh ccm" output) I have verified:

--network connectivity

--DNS name and gateway name in CM and router both include ""

--stipped and re-applied "mgcp" global command

--ran DB Helper to make sure database was replicating

I am all out of ideas on this.


sh ccm:

VR01-1930#sh ccm

MGCP Domain Name:

Priority Status Host


Primary Down

First Backup Registered

Second Backup None

Current active Call Manager:

Backhaul/Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 14:27:55 DST Jun 23 2006 (elapsed time: 00:00:10)

Last MGCP traffic time: 14:27:55 DST Jun 23 2006 (elapsed time: 00:00:10)

Last failover time: 13:40:55 DST Jun 23 2006 from (

Last switchback time: 12:19:15 DST Jun 23 2006 from (

Switchback mode: Graceful

MGCP Fallback mode: Not Selected

Last MGCP Fallback start time: None

Last MGCP Fallback end time: None

MGCP Download Tones: Disabled

--More-- Backhaul Link info:

Link Protocol: TCP

Remote Port Number: 2428

Remote IP Address:

Current Link State: OPEN


Packets recvd: 0

Recv failures: 0

Packets xmitted: 0

Xmit failures: 0

PRI Ports being backhauled:

Slot 0, port 0

Configuration Error History:

FAX mode: disable


SH run vitals:

sh run

Building configuration...

Current configuration : 2487 bytes


version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption


hostname VR01-1930


ip domain name

no ftp-server write-enable

isdn switch-type primary-ni


voice-card 0

no dspfarm



ccm-manager redundant-host

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server




controller T1 0/3/0

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

description 1930 Como PRI




interface GigabitEthernet0/0

description Connection to VOICE NET on 1930-Como Switch

ip address

duplex full

speed 100


interface Serial0/3/0:23

no ip address

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable


ip classless

ip route



voice-port 0/3/0:23



mgcp call-agent 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface GigabitEthernet0/0

mgcp bind media source-interface GigabitEthernet0/0

mgcp profile default






14 Replies 14



As mentioned that network connectivity is fine.What abt the phones do the they get registered to PUB.Can you make calls between phones which are connected to seperate CCM.

Can you verfiy the version of softwares running on both the servers.

Try restarting the Callmanager service in Publisher. Also make sure the Database layer service is running.

Any errors related to MGCP or devices on the error log.




In the config you posted, the dial-peer command is missing. Do you have that in the router ?

dial-peer voice 1 pots

service mgcpapp

port 0/3/0:23

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus


You are missing 2nd backup host name

try with below configuration :

ccm-manager redundant-host

Let me know if this helps.




Thats not required. His pub is .16 and sub is .15. His mgcp call-agent has .15 specified. He has a ccm-manager redundant-host with .16 specified too.

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

Is the dial-peer needed for registration? I had not finished the config b/c the gateway had notr registered.

Also, the phones are all working fine off both CM's as the enviornment is pre-existing.

I did see in DBHelper that the Pub DNS is listed as while the Sub is listed simply as CCM2


When I look at the box itself they both have the defined in the fully qualified domain extension (both are in a simple workgroup named WORKGROUP) so I'm not sure why DBHelper is reporting it differently. I do get green smilies though, not Mr. YUK's SO I don't know if this is really a problem, but considering how MGCP reacts with not ergistering on domain name mismatches AND the Sub is the one listed with out the, it might have something to do with it.

I am simply adding a new gateway so I can get rid of the existing H323 T1 gateway. So all phones and calls work fine right now. This gateway is not in the equation yet.

I asked the client to restart his Sub at the end of the day friday to see if that would fix the issue. I thought it might be a service on one of the servers, but wasn't sure which service would affect MGCP registration. The Pub must be ok since it registers but the Sub does not (see "sh ccm" output)

great feedback so far guys, I hope this extra info sparks some ideas. I'll be opening a TAC case on Monday, but I'd like to get it resolved before having to do that. It's such a basic set-up that it is frustrating the heck out of me to see the Sub listed as "Down" in the Gateway.


YOu are right, you dont need the dial peer for the gateway to register with Callmanager. That is confirmed.

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

One thing I have noticed, is that when configuring mgcp manually (no ccm-manager config) I have needed to add the dial-peer to get it to register initially, but removing it after that caused no issues.

Its very strange. Anyway, I was just curious to see if anyone else has experienced this.

Again, I stress that IT IS NOT NEEDED as shanky said, but initially adding it has caused my pri's to register to callmanager immediately (and then can be removed after that as MGCP controls the d channel and this is why its not needed for call routing).

adignan - berbee


I tried the same config on an FXO gateway and it registers too without the dial peer..

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus


I am not sure if you have checked this, but If you have a ip domain name specified, when you add your gateway to CCM you have to specify the domain name.

For ex.

Hope this helps

thank you eloy, I have checked this and tried it both ways in CM and on the gateway.

Added info - I also stripped the gateway config clean and set it all back in to see if having it defined in CM first made any difference. It did not.


In CCM, is the gateway in a device pool with a CCM group that includes both the pub and sub?



On the GW, can you enable:

deb mgcp packet

deb ccm events

Then do

conf t

no mgcp - wait a couple of secs for the debugs to stop, then


then give a few seconds fo the registration to complete, then do "unde all", and sh ccm ( jsut to confirm it's registered fine)

I'll take a look at the traces to see what they show.



Wild goose chase......The client had applied MS patches to the subscriber which was causing the services to flake out. We uninstalled the patches and everything came up fine.

Thanks for all your help.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers