05-30-2022 08:01 AM
Configure OSPF Area 0 on all routers. and make the end to end connectivity.
R5 to R2 is our Lease line link
**********************************
Set the traffic like this
**********************************************
when you do the traceroute from R1 to R2 Loopback Address 147.147.11.98 ,
it should be travel through R1 to R4 to R5 to R2 and
when you do traceroute from R5 to R2 router
It travels through R5 to R4 to R1 to R3 to R2
MY CONFIGURATIONS
R1:
--------------------------
conf t
int s1/1
ip add 131.131.34.82 255.255.255.240
no sh
ex
int s1/0
ip add 131.131.34.163 255.255.255.240
no sh
ex
router ospf 131
network 131.131.34.80 0.0.0.15 area 0
network 131.131.34.160 0.0.0.15 area 0
ex
R2:
--------------------------
conf t
int s1/0
ip add 131.131.34.139 255.255.255.240
no sh
ex
int s1/1
ip add 131.131.34.124 255.255.255.240
no sh
ex
int loopback 2
ip add 147.147.11.98 255.255.255.252
ex
router ospf 131
network 131.131.34.128 0.0.0.15 area 0
network 131.131.34.112 0.0.0.15 area 0
network 147.147.11.96 0.0.0.3 area 0
ex
R3:
--------------------------
conf t
int s1/1
ip add 131.131.34.126 255.255.255.240
no sh
ex
int s1/2
ip add 131.131.34.83 255.255.255.240
no sh
ex
router ospf 131
network 131.131.34.80 0.0.0.15 area 0
network 131.131.34.112 0.0.0.15 area 0
ex
R4:
--------------------------
conf t
int s1/0
ip add 131.131.34.168 255.255.255.240
no sh
ex
int s1/1
ip add 131.131.34.151 255.255.255.240
no sh
ex
router ospf 131
network 131.131.34.160 0.0.0.15 area 0
network 131.131.34.144 0.0.0.15 area 0
ex
R5:
--------------------------
conf t
int s1/1
ip add 131.131.34.153 255.255.255.240
no sh
ex
int s1/0
ip add 131.131.34.138 255.255.255.240
no sh
ex
router ospf 131
network 131.131.34.144 0.0.0.15 area 0
network 131.131.34.128 0.0.0.15 area 0
ex
how to give costing from R1 to R2
and R5 to R2 to travel like below
1-traceroute from R1 to R2 Loopback Address 147.147.11.98 ,
it should be travel through R1 to R4 to R5 to R2.
2-when you do traceroute from R5 to R2 router
It should travels through R5 to R4 to R1 to R3 to R2
05-30-2022 08:04 AM - edited 05-30-2022 08:05 AM
yes you can do with Traffic engineering by manipulating the COST
show ip route (show you what is the cost in the path,)
05-30-2022 08:46 AM
i am not supposed to do MPLS in my level, so if it is costing then i can only solve either 1st one or 2nd one.
if i increase the cost of R1 interface that is connected to R3 that means 1st solved. and 2nd not solved.
if i increase the cost of R5 interface that is connected to R2 that means 2nd solved but 1st not choose the route that i supposed to give.
i can solve with costing only one task out of two tasks.
1-traceroute from R1 to R2 Loopback Address 147.147.11.98 ,
it should be travel through R1 to R4 to R5 to R2.
2-when you do traceroute from R5 to R2 router
05-30-2022 08:10 AM
this is so advance OSPF case and as @balaji.bandi mention this solve by only TE,
https://www.youtube.com/watch?v=QcOP8vteyvA
05-30-2022 08:46 AM
i am not supposed to do MPLS in my level, so if it is costing then i can only solve either 1st one or 2nd one.
if i increase the cost of R1 interface that is connected to R3 that means 1st solved. and 2nd not solved.
if i increase the cost of R5 interface that is connected to R2 that means 2nd solved but 1st not choose the route that i supposed to give.
i can solve with costing only one task out of two tasks.
1-traceroute from R1 to R2 Loopback Address 147.147.11.98 ,
it should be travel through R1 to R4 to R5 to R2.
2-when you do traceroute from R5 to R2 router
It should travels through R5 to R4 to R1 to R3 to R2
05-30-2022 08:10 AM
Hi
You can not select a route manually and packettracer does not support source interface for ping or trace route.
But, according to your requirements:
1-traceroute from R1 to R2 Loopback Address 147.147.11.98 ,
it should be travel through R1 to R4 to R5 to R2.
2-when you do traceroute from R5 to R2 router
It should travels through R5 to R4 to R1 to R3 to R2
"It should travels" which means, if you did everything right , it should go to the right path.
05-30-2022 09:03 AM
i am using gns3 virtual machine.
i gave all commands in the question and if i do that it choose less distance
in 1st task it choose from R1 to R3 to R2
in 2nd task it choose from R5 to R2 l
if i use costing in interfaces i can satisfy only one task.
suppose lets assume
if i gave cost 1 in all interfaces of all routers
after that lets give cost 100 for the R5 interface that is connected to R2.
then if we trace route 2nd TASK will be solved.
for 2nd TASK lets give cost 110 for the R1 interface that is connected to R3.
now second one will be solved but 1st TASK wont work
the reason is cost.
R5 to R2- cost =100(chooses
R5 -R4 -R1-R3-R2 cost =113
it choose less cost so we cant satisfy 2st TASK
but can satisfy 1st task because
R1-R3-R2 cost = 110+1=111
R1-R4-R5-R2 cost = 1+1+100=102 (chooses)
if we decrease the R5 interface that is connected to R2 then the Task-2 wont work
05-30-2022 08:36 AM - edited 05-30-2022 08:37 AM
Hello
IF all interface costs and lsa types are equal.
RTR5<>RTR2 = DIRECT
RTR5<>RTR4 = DIRECT
RTR5<>RTR3 = via RTR2
RTR1<>RTR3 = DIRECT
RTR1<>RTR4 = DIRECT
RTR1<>RTR2 = via RTR3
RTR4<>R2/R3 = ECMP oldest lsa age
So to manually manipulate the above apply ospf interface costs would be applicable (highest values less preferred)
05-30-2022 09:06 AM
i gave all commands in the question and if i do that it choose less distance
in 1st task it choose from R1 to R3 to R2
in 2nd task it choose from R5 to R2 l
if i use costing in interfaces i can satisfy only one task.
suppose lets assume
if i gave cost 1 in all interfaces of all routers
after that lets give cost 100 for the R5 interface that is connected to R2.
then if we trace route 2nd TASK will be solved.
for 2nd TASK lets give cost 110 for the R1 interface that is connected to R3.
now second one will be solved but 1st TASK wont work
the reason is cost.
R5 to R2- cost =100(chooses
R5 -R4 -R1-R3-R2 cost =113
it choose less cost so we cant satisfy 2st TASK
but can satisfy 1st task because
R1-R3-R2 cost = 110+1=111
R1-R4-R5-R2 cost = 1+1+100=102 (chooses)
if we decrease the R5 interface that is connected to R2 then the Task-2 wont work
how to satisfy both
05-30-2022 10:00 AM - edited 05-30-2022 10:07 AM
Hello
@sivared0001 wrote:
in 1st task it choose from R1 to R3 to R2 ,
in 2nd task it choose from R5 to R2 l
I must have missed these tasks? however as i stated previous all thing being equal these should be met given the topology from your OP
RTR5<>RTR2 = DIRECT < task 2
RTR5<>RTR4 = DIRECT
RTR5<>RTR3 = via RTR2
RTR1<>RTR3 = DIRECT
RTR1<>RTR4 = DIRECT
RTR1<>RTR2 = via RTR3 < task 1
RTR4<>R2/R3 = ECMP oldest lsa age
05-30-2022 10:09 AM
TASK1-traceroute from R1 to R2 Loopback2 Address 147.147.11.98 ,
it should be travel through R1 to R4 to R5 to R2.
TASK2-when you do traceroute from R5 to R2 router address that connected to R3 (not R2 loopback 2 address)
It should travels through R5 to R4 to R1 to R3 to R2
05-30-2022 11:54 AM - edited 05-30-2022 11:57 AM
Hello
You could accomplish this possibly through Policy Based Touting with ospf costing being equal on all interfaces, however doing PBR could also create asymmetric routing for either task you apply PBR unless its applied not only on R1/R5 but also R2.
example: TASK1
RTR1<>RTR2 = via RTR3
RTR1
access-list 100 permit ip host 1.1.1.1 host 2.2.2.2
route-map PBR_TASK1
Match ip address 100
set ip next-hop 131.131.34.83
int lo0
ip policy route-map PBR_TASK1
RTR 2
access-list 100 permit ip host 2.2.2.2 host 1.1.1.1
route-map PBR_TASK1
Match ip address 100
set ip next-hop 131.131.34.126
int lo0
ip policy route-map PBR_TASK1
example: TASK2
R5 to R4 to R1 to R3 to R2
RTR5
access-list 100 permit ip host 5.5.5.5 host 2.2.2.2
route-map PBR_TASK2
Match ip address 100
set ip next-hop 131.131.34.151
int lo0
ip policy route-map PBR_TASK2
RTR 2
access-list 101 permit ip host 2.2.2.2 host 5.5.5.5
route-map PBR_TASK2
Match ip address 101
set ip next-hop 131.131.34.138
int lo0
ip policy route-map PBR_TASK2
05-31-2022 12:38 AM - edited 05-31-2022 12:39 AM
R1:
access-list 100 permit host 131.131.34.82 host 147.147.11.98
access-list 100 permit host 131.131.34.163 host 147.147.11.98
route-map PBR permit 10
match IP address 100
set IP next-hop 131.131.34.168
IP local policy route-map PBR
R2:
access-list 100 permit host 147.147.11.98 host 131.131.34.163
access-list 100 permit host 147.147.11.98 host 131.131.34.82
route-map PBR permit 10
match IP address 100
set IP next-hop 131.131.34.138
IP local policy route-map PBR
i used the above commands
PBR not working, still i am not able to send packet from r1 to r4 to r5 to r2. (this is the way i need to use)
but it using this way (r1 to r3 to r2)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide