cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

327
Views
0
Helpful
24
Replies
Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

Gents,

 

Suggested changes made to no avail. Issue still persists. Full configs as requested :-

 

HUB

hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
!
!
ip tcp synwait-time 5
!
ip audit po max-events 100
no ip domain lookup
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel0
ip address 10.1.1.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 10
ip nhrp nhs 10.1.1.1
tunnel source Serial0/0
tunnel mode gre multipoint
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 15.0.0.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
interface Serial0/2
no ip address
shutdown
clock rate 2000000
!
interface Serial0/3
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet3/0
no ip address
shutdown
!
interface FastEthernet3/1
no ip address
shutdown
!
interface FastEthernet3/2
no ip address
shutdown
!
interface FastEthernet3/3
no ip address
shutdown
!
interface FastEthernet3/4
no ip address
shutdown
!
interface FastEthernet3/5
no ip address
shutdown
!
interface FastEthernet3/6
no ip address
shutdown
!
interface FastEthernet3/7
no ip address
shutdown
!
interface FastEthernet3/8
no ip address
shutdown
!
interface FastEthernet3/9
no ip address
shutdown
!
interface FastEthernet3/10
no ip address
shutdown
!
interface FastEthernet3/11
no ip address
shutdown
!
interface FastEthernet3/12
no ip address
shutdown
!
interface FastEthernet3/13
no ip address
shutdown
!
interface FastEthernet3/14
no ip address
shutdown
!
interface FastEthernet3/15
no ip address
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

 

SPOKE

hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
!
!
ip tcp synwait-time 5
!
ip audit po max-events 100
no ip domain lookup
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Tunnel0
ip address 10.1.1.2 255.255.255.0
ip nhrp map 10.1.1.1 15.0.0.1
ip nhrp map multicast 15.0.0.1
ip nhrp network-id 10
ip nhrp nhs 10.1.1.1
tunnel source Serial0/1
tunnel destination 15.0.0.1
!
interface Tunnel1
no ip address
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 25.0.0.2 255.255.255.0
clock rate 2000000
!
interface Serial0/2
no ip address
shutdown
clock rate 2000000
!
interface Serial0/3
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet3/0
no ip address
shutdown
!
interface FastEthernet3/1
no ip address
shutdown
!
interface FastEthernet3/2
no ip address
shutdown
!
interface FastEthernet3/3
no ip address
shutdown
!
interface FastEthernet3/4
no ip address
shutdown
!
interface FastEthernet3/5
no ip address
shutdown
!
interface FastEthernet3/6
no ip address
shutdown
!
interface FastEthernet3/7
no ip address
shutdown
!
interface FastEthernet3/8
no ip address
shutdown
!
interface FastEthernet3/9
no ip address
shutdown
!
interface FastEthernet3/10
no ip address
shutdown
!
interface FastEthernet3/11
no ip address
shutdown
!
interface FastEthernet3/12
no ip address
shutdown
!
interface FastEthernet3/13
no ip address
shutdown
!
interface FastEthernet3/14
no ip address
shutdown
!
interface FastEthernet3/15
no ip address
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/1
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

Rising star

Re: DMVPN Phase 1 Hub to Spoke connection

spoke# ping 10.1.1.1 source 10.1.1.2
Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

SPOKE
R2#ping 10.1.1.1 source 10.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.2
.....
Success rate is 0 percent (0/5)
R2#ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

HUB
R1#ping 10.1.1.2 source 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
.....
Success rate is 0 percent (0/5)
R1#ping 10.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)
Highlighted
Enthusiast

Re: DMVPN Phase 1 Hub to Spoke connection

The tunnel interface is tied to the physical interface including reachability to the destination tunnel. Conditions that can cause the Tunnel to be up/down include:

 

1. Physical interface is shutdown

2. No ip route to the destination

 

I guess this is a lab that you're doing. I would suggest the following

1. Shut/No shut the tunnel interface

2. Change the clock rate on the serial interface

3. Use the Fastethernet interface. If it works, then it's an issue with the Serial interface. 

4. Delete R1 (Hub) and configure a fresh router 

Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

Nice one for the suggestions. I'll give them a go. I'm beginning to think it is a weird gns3 issue. I've had a good few second opinions and the tunnel configuration, by all accounts, looks good.
Rising star

Re: DMVPN Phase 1 Hub to Spoke connection

show the network topology

 

just try to create ordinary p2p gre  tunnel and check if it works...

 

Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

Added the topology earlier in the thread.

Already did p2p and worked (specifying a single destination at both hub and spoke). I'm trying out Phase 1 but it looks as though it could be a gns3 issue. I'll give Phase 2 a go and see how that works out. Appreciate your time.
Rising star

Re: DMVPN Phase 1 Hub to Spoke connection

Beginner

Re: DMVPN Phase 1 Hub to Spoke connection

Just a quick update to finish off. Turns out it was a GNS3 issue. Deleted the hub router and re-applied config to a new hub using a different ios. Everything now working as intended. Bloody GNS3. Appreciate the help all around.
VIP Advisor

Re: DMVPN Phase 1 Hub to Spoke connection

oh we were in impression this was live environment, glad you clarified. and working.

BB
*** Rate All Helpful Responses ***
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards