05-26-2011 04:37 AM - edited 03-04-2019 12:32 PM
Hi. I need to set priority queue on tunnel interface, to make some traffic class served first, the other one next and remaining the last.
I understand what i should create shaping policy map to specify tunnel bandwidth, but what's next?
05-26-2011 05:46 AM
I would not really even begin trying this, chances are will newer work. In most cases the outbound interface is ethernet and never experiences congestion, so there is to do a nested pologu, DSPC bits copying and way too many things, creating instability and never ending maintenance.
Tunnell == Internet == No QoS
Don't expect that you can change the above.
05-26-2011 08:01 PM
Tunnell == Internet == No QoS
Who said about Internet?
It's a guaranteed 5 mbit/s link.
05-26-2011 08:55 AM
Hi,
You can Certainely do that. You need to specify (QoS pre-classify) on the tunnel interface, classify and mark as close to the source as possible and apply your QoS at the Outgoing Interface (The Source Of the Tunnel Interface). and you should be good to go.
Again, just make sure thier is marking honored ONLY for your tunnel destination before the tunnel establishment,
After the tunnel is established, you dont need the Service Provider involvemnet at all, you can do and implement all your QoS policy over the Tunnel.
Regards,
Mohamed
05-26-2011 08:04 PM
You can Certainely do that. You need to specify (QoS pre-classify) on the tunnel interface, classify and mark as close to the source as possible and apply your QoS at the Outgoing Interface (The Source Of the Tunnel Interface). and you should be good to go.Again, just make sure thier is marking honored ONLY for your tunnel destination before the tunnel establishment,
After the tunnel is established, you dont need the Service Provider involvemnet at all, you can do and implement all your QoS policy over the Tunnel.
Alright then. How to implement priority queue at outbound interface? Considering marking DiffServ at incoming interfaces.
Is there a policy-map style commands for that?
05-26-2011 09:40 PM
Hi;
It works either you apply on source interface or even on tunnel interface; below is the configuration I am using for this.
class-map match-any VC
match access-group name VC
class-map match-any ERP
match access-group name ERP
policy-map QOS
class VC
priority 768
class ERP
bandwidth 640
interface Tunnel2
service-policy output QOS
ip access-list extended VC
permit ip host 197.82.184.240 any
05-26-2011 09:49 PM
shehzadtesleem wrote:
Hi;
It works either you apply on source interface or even on tunnel interface; below is the configuration I am using for this.
class-map match-any VC
match access-group name VC
class-map match-any ERP
match access-group name ERPpolicy-map QOS
class VC
priority 768
class ERP
bandwidth 640interface Tunnel2
service-policy output QOS
ip access-list extended VC
permit ip host 197.82.184.240 any
could you explain alittle?
you set priority 768. as i understand it is some guaranteed bandwidth, but where does it know total bandidth? does it need to?
05-26-2011 11:23 PM
Hi;
You can apply shaping like this suppose you have 2 Mb link
policy-map QOS
class VC
priority 768
class ERP
bandwidth 640
policy-map QOS_PROFILE
class class-default
shape average 2048000
service-policy QOS
interface Tunnel2
service-policy output QOS_PROFILE
05-27-2011 01:55 AM
hi,
you can also the " bandwidth
Regards
Kishore
05-27-2011 02:08 AM
kishore.chennupati wrote:
hi,
you can also the " bandwidth
" statement on the tunnel interface. Regards
Kishore
i thought it used for EIGRP metrics only
05-27-2011 03:52 AM
Yes, bandwidth command is for metric calculation of EIGRP, OSPF etc
05-27-2011 05:15 AM
Okay, here is what i'm thinking of:
class-map match-any CITRIX
match access-group name CITRIX
class-map match-any VIDEO
match access-group name VIDEO
class-map match-any VOICE
match access-group name VIDEO
!
policy-map QoS
class VOICE
priority percent 10
class VIDEO
priority percent 70
class CITRIX
priority percent 10
!
policy-map INTERFACE
class class-default
shape average 4800000
service-policy QoS
!
interface Tunnel0
qos pre-classify
!
interface Vlan10
service-policy output INTERFACE
!
Will that leave only 10% of bandwidth to class-default traffic, no matter what load in another classes? Or will it decrease and leave available bandwidth to 10% when there is full load in non default classes?
What's the difference between "priority" and "bandwidth" policy commands?
Also, what about CPU load? it is 2811 router with several other WAN connections.
05-27-2011 06:17 AM
Dear
it will decrease and leave available bandwidth to 10% when there is full load in non default classes is correct statement.
2ndly you can apply priority to only one class.
kindly read LLQ and CBWFQ for more details to see the difference between priority and bandwidth.
05-27-2011 06:37 AM
hi shehzad,
2ndly you can apply priority to only one class.
kindly read LLQ and CBWFQ for more details to see the difference between priority and bandwidth.
The Low Latency Queueing feature brings strict priority queueing to Class-Based Weighted Fair Queueing (CBWFQ) when we define a class with priority command.
Priority statement can be applied to more than one class. Priority has a inbuilt policer which doesn't let it go beyond what you have configured for the class. So, you can have priority for Voice class and for also Video class seperately.
please find below an example that have put here for your reference.
r5#sh policy-map
Policy Map POL
Class VC1
Strict Priority
Bandwidth 10 (kbps) Burst 250 (Bytes)
Class VC2
Strict Priority
Bandwidth 20 (kbps) Burst 500 (Bytes)
HTH,
Regards,
Kishore
Please rate if helpful
05-28-2011 03:52 AM
Hi Kishore;
2ndly you can apply priority to only one class.
My apologize for the above statement, yes you can define more than one classed to apply the priority
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide