cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2401
Views
5
Helpful
13
Replies

Problem configuring Etherchannel

m.lammerse
Level 1
Level 1

Could someone tell me what I'm doing wrong here please?

One side :

Cat3550-1(config)#interface range fastEthernet 0/23 - 24

Cat3550-1(config-if-range)#switchport trunk encapsulation dot1q

Cat3550-1(config-if-range)#switchport mode trunk

Cat3550-1(config-if-range)#duplex full

Cat3550-1(config-if-range)#speed 100

Cat3550-1(config-if-range)#channel-group 1 mode on

Cat3550-1(config-if-range)#shut

Cat3550-1(config-if-range)#no shut

Other side:

Cat3550-2(config)#interface range fastEthernet 0/23 - 24

Cat3550-2(config-if-range)#switch trunk encap dot

Cat3550-2(config-if-range)#switchport mode trunk

Cat3550-2(config-if-range)#duplex full

Cat3550-2(config-if-range)#speed 100

Cat3550-2(config-if-range)#channel-group 1 mode on

Cat3550-2(config-if-range)#shut

Cat3550-2(config-if-range)#no shut

Error message:

01:25:34: %PM-4-ERR_DISABLE: channel-misconfig error detected on Fa0/23, putting Fa0/23 in err-disable state

01:25:34: %PM-4-ERR_DISABLE: channel-misconfig error detected on Fa0/24, putting Fa0/24 in err-disable state

Config :

Cat3550-2#sh run int fastEthernet 0/23

Building configuration...

Current configuration : 144 bytes

!

interface FastEthernet0/23

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

duplex full

channel-group 1 mode on

end

Cat3550-2#sh run int fastEthernet 0/24

Building configuration...

Current configuration : 144 bytes

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

duplex full

channel-group 1 mode on

end

Cat3550-1#sh run int fastEthernet 0/23

Building configuration...

Current configuration : 144 bytes

!

interface FastEthernet0/23

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

duplex full

channel-group 1 mode on

end

Cat3550-1#sh run int fastEthernet 0/24

Building configuration...

Current configuration : 144 bytes

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

duplex full

channel-group 1 mode on

end

Cat3550-1#sh run int port-cha

Cat3550-1#sh run int port-channel 1

Building configuration...

Current configuration : 116 bytes

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

duplex full

end

Cat3550-2#sh run int port-cha

Cat3550-2#sh run int port-channel 1

Building configuration...

Current configuration : 116 bytes

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

duplex full

end

13 Replies 13

Edison Ortiz
Hall of Fame
Hall of Fame

let's see SH VLAN from both switches.

Please refer to below link.

http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration_guide_chapter09186a008014f344.html#wp1033981

For Layer 2 EtherChannels:

Assign all interfaces in the EtherChannel to the same VLAN, or configure them as trunks. Interfaces with different native VLANs cannot form an EtherChannel.

If you configure an EtherChannel from trunk interfaces, verify that the trunking mode (ISL or 802.1Q) is the same on all the trunks. Inconsistent trunk modes on EtherChannel interfaces can have unexpected results.

An EtherChannel supports the same allowed range of VLANs on all the interfaces in a trunking Layer 2 EtherChannel. If the allowed range of VLANs is not the same, the interfaces do not form an EtherChannel even when PAgP is set to the auto or desirable mode.

Interfaces with different spanning-tree path costs can form an EtherChannel if they are otherwise compatibly configured. Setting different spanning-tree path costs does not, by itself, make interfaces incompatible for the formation of an EtherChannel.

For Layer 3 EtherChannels, assign the Layer 3 address to the port-channel logical interface, not to the physical interfaces in the channel.

Seems you are going to use Layer 3 mode, please remove below from interface Port-channel1 :

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

duplex full

then add :

no switchport

ip addr x.x.x.x y.y.y.y

Where the interface port-channel is a logical interface, no need to configure speed, duplex, etc.

If layer 2 mode, simply delete the interface port-channel1.

Please try to follow the example.

Hope this helps.

Hi Jack,

thanks for your suggestion, but it didn't quite solve my issue. This is a simple layer-2 bonded trunk connection. I mean, even with just:

interface fas0/23

channel-group 1 mode on

switchport mode trunk

!

interface fas0/24

switchport mode trunk

channel-group 1 mode on

!

end

I should come up, but it didn't. I am thinking it has something to do with the trunk not being fully operational as the etherchannel is formed. But I am not sure.

-Marcel

Hi Edison,

unfortunately, I don't have the equipment at my disposal right now. I'll try and post the output of the command you suggested shortly.

Thanks,

Marcel

mchoo2005
Level 1
Level 1

If all else fails, try using "channel-group 1 mode active" on both switches, and "channel-protocol lacp" for good measure. I have always used the "active" mode (i.e. forcing IEEE802.3ad mode) and never had any problems, even between Cisco and non-Cisco (Nortel).

Anand Narayana
Level 6
Level 6

your configuration 100% perfect.While doing ether channeling, make sure that atleast one of the port is not active, because even that might disable the port. also try to avoid "speed 100 & duplex full".

hope this helps.

rate this post.

Hi anandanarayana,

I tend to agree with you that the config is correct. I double and tripple checked it. Do you know why a port might get disabled if don't shut it, like you suggested?

Cheers,

Marcel

Hi,

This error typically occurs due to spanning tree problem. Perform the steps in both switches.

Can you try this:

SW1-3550#config t

Enter configuration commands, one per line. End with CNTL/Z.

SW1-3550(config)#int range f0/23 - 24

SW1-3550(config-if-range)#shut

SW1-3550(config-if-range)#channel-group 1 mode desirable

SW1-3550(config-if-range)#no shut

HTH,

Sundar

Hi Sundar,

yes, that particular configuration works. But, I did not see any spanningtree error messages. The ports get err-disabled. Could you explain a little more about why you think it would be a spanning-tree issue?

Thanks,

Marcel

Marcel,

Here's the link you were looking for.

Did you attempt my previous recommendation?

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a0080094647.shtml

Hope that helps. Good Luck!

Regards,

Sundar

Hi,

will the F0/23 and F0/24 form two separate trunks when not being bonded to an EtherChannel? Maybe you are chasing cabling or hardware issues and so on.

Regards, Martin

Like said in the former post, I would test the Etherchannel with different cables. The conf looks fine so it could be a physical problem (cables, connectors etc)

Each EtherChannel has a numbered port-channel interface. A configuration applied to the port-channel
interface affects all physical interfaces assigned to that interface.
Note QoS does not propagate to members. The defaults, QoS cos = 0
After you configure an EtherChannel, the configuration that you apply to the port-channel interface
affects the EtherChannel; the configuration that you apply to the physical interfaces affects only the
interface where you apply the configuration. To change the parameters of all ports in an EtherChannel,
apply configuration commands to the port-channel interface (such commands can be STP commands or
commands to configure a Layer 2 EtherChannel as a trunk).Each EtherChannel has a numbered port-channel interface. A configuration applied to the port-channel
interface affects all physical interfaces assigned to that interface.
Note QoS does not propagate to members. The defaults, QoS cos = 0
After you configure an EtherChannel, the configuration that you apply to the port-channel interface
affects the EtherChannel; the configuration that you apply to the physical interfaces affects only the
interface where you apply the configuration. To change the parameters of all ports in an EtherChannel,
apply configuration commands to the port-channel interface (such commands can be STP commands or
commands to configure a Layer 2 EtherChannel as a trunk).

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: