cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
688
Views
0
Helpful
5
Replies

Router cannot reach its own interface

Jonathan Nali
Level 1
Level 1

Hi Everyone,

 

I always get help from this forum so I am confident an solution will be found here.

I have this Cisco Router 891

I have put IP addresses on gig0 - 192.168.124.10 and FE8 - 10.10.3.3,

I can ping FE  8 but not Gig0. Do not know why. Maybe you can see something I am missing.

When I plug in an ethernet cable, it response to say, interface is up.

 

===========================================================================

!
ip source-route
!
!
ip dhcp relay information option
ip dhcp relay information trust-all
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 10.10.3.253
ip dhcp excluded-address 10.10.3.252
ip dhcp excluded-address 10.10.3.1 10.10.3.50
!
ip dhcp pool KITWE-POOL
network 10.10.3.0 255.255.255.0
default-router 10.10.3.3
dns-server 10.10.1.4

!
!
ip cef
no ip domain lookup

ip name-server 8.8.8.8
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
!
interface FastEthernet0
!
!
interface FastEthernet1
!
!
interface FastEthernet2
!
!
interface FastEthernet3
!
!
interface FastEthernet4
!
!
interface FastEthernet5
!
!
interface FastEthernet6
!
!
interface FastEthernet7
!
!
interface FastEthernet8
ip dhcp relay information option-insert
ip address 10.10.3.3 255.255.255.0
ip helper-address 10.10.3.3
ip directed-broadcast
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
!
interface GigabitEthernet0
description Internet
ip address 192.168.124.10 255.255.255.252
ip helper-address 192.168.124.10
ip directed-broadcast
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!


!
!
ip forward-protocol nd
ip forward-protocol udp talk
no ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 111 interface GigabitEthernet0 overload
ip nat outside source static 10.10.1.0 10.10.3.3
ip nat outside source static 192.168.124.2 192.168.124.10
ip route 0.0.0.0 0.0.0.0 192.168.124.1 2
ip route 192.168.124.0 255.255.255.252 192.168.124.9
ip route 192.168.124.0 255.255.255.252 GigabitEthernet0 3
!
access-list 111 deny ip 10.10.3.0 0.0.0.255 10.10.1.0 0.0.0.255
access-list 111 permit ip 10.10.3.0 0.0.0.255 any
no cdp run

=============================================================================

 

5 Replies 5

balaji.bandi
Hall of Fame
Hall of Fame

What is the source IP you trying to ping ?

 

can you share ipconfig /all information from the device ? (if windows)

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hello,

 

remove the lines marked in bold:

 

ip source-route
!
ip dhcp relay information option
ip dhcp relay information trust-all
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 10.10.3.253
ip dhcp excluded-address 10.10.3.252
ip dhcp excluded-address 10.10.3.1 10.10.3.50
!
ip dhcp pool KITWE-POOL
network 10.10.3.0 255.255.255.0
default-router 10.10.3.3
dns-server 10.10.1.4
domain-name repro.local
!
ip cef
no ip domain lookup
ip domain name yourdomain.com
ip name-server 8.8.8.8
no ipv6 cef
!
multilink bundle-name authenticated
license udi pid CISCO891-K9 sn FCZ1544C41L
!
username kitwert privilege 15 secret 5 $1$W.GL$N7EAtQPVUmtdxuRdLvwGa.
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
ip dhcp relay information option-insert
ip address 10.10.3.3 255.255.255.0
ip helper-address 10.10.3.3
ip directed-broadcast
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface GigabitEthernet0
description Internet
ip address 192.168.124.10 255.255.255.252
ip helper-address 192.168.124.10
ip directed-broadcast
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$
ip address 10.10.10.1 255.255.255.248
ip tcp adjust-mss 1452
!
interface Async1
no ip address
encapsulation slip
!
ip forward-protocol nd
ip forward-protocol udp talk
no ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 111 interface GigabitEthernet0 overload
--> no ip nat outside source static 10.10.1.0 10.10.3.3
--> no ip nat outside source static 192.168.124.2 192.168.124.10
ip route 0.0.0.0 0.0.0.0 192.168.124.1 2
--> no ip route 192.168.124.0 255.255.255.252 192.168.124.9
--> no ip route 192.168.124.0 255.255.255.252 GigabitEthernet0 3
!
--> no access-list 111 deny ip 10.10.3.0 0.0.0.255 10.10.1.0 0.0.0.255
access-list 111 permit ip 10.10.3.0 0.0.0.255 any
no cdp run

Hello

interface GigabitEthernet0
no ip helper-address 192.168.124.10 <-- not required
ip directed-broadcast <-- why do you require this?

interface FastEthernet8
ip address 10.10.3.3 255.255.255.0
ip helper-address 10.10.3.3 <---- not required
ip directed-broadcast <-- why do you require this?

no ip route 192.168.124.0 255.255.255.252 192.168.124.9 <-not required connected interface
no ip route 192.168.124.0 255.255.255.252 GigabitEthernet0 3  < - not required connected interface
no ip route 0.0.0.0 0.0.0.0 192.168.124.1 2 < recursive lookup for nexthop
ip source-route < -- let the rtr make the forwarding decision not the source

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 192.168.124.1 2 < disables recursive lookup for nexthop


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Can i get a show ip route output.

Please do not hesitate to click the STAR button if you are satisfied with my answer.

We have several responses which suggest  changes in the config. While I agree that these suggestions are appropriate ways to improve the config, I do not see that they relate to problems to ping G0. I agree that the output of show ip route may be helpful but think that output of these commands would be more helpful

show ip interface brief

show arp

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card