Routing with PPPoE
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-19-2019 10:07 PM
Hello
I have one issue about routing with PPPoE
i will show you diagram.i have configured PPPoE server on ISP router and client side on EDGE router.I will post the configs
The problem is i could connect from Edge to ISP and could get ip address but i cannot ping from PC to ISP
i wrote default route in Edge router and back static route on ISP router.But i cannot ping from PC to ISP
I also checked with NAT but the result was the same.May be some one can explain me what may be the problem ? I also used dynamic routing and the ISP router get the PC network
SERVER SIDE (ISP)
bba-group pppoe test
virtual-template 1
interface GigabitEthernet2/0
no ip address
negotiation auto
pppoe enable group test
!
interface Virtual-Template1
ip address 10.10.10.1 255.255.255.0
peer default ip address pool pool1
!
ip local pool pool1 10.10.10.2 10.10.10.10
ip forward-protocol nd
!
ip route 0.0.0.0 0.0.0.0 10.10.10.2
no ip http server
no ip http secure-server
Client side (EDGE)
ip dhcp excluded-address 192.168.10.10 192.168.10.50
!
ip dhcp pool pool1
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
duplex full
interface GigabitEthernet2/0
no ip address
negotiation auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 60 either
dialer hold-queue 10
dialer-group 1
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
- Labels:
-
Other Routing
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-20-2019 12:24 AM
Hi,
What is 10.10.10.2?
Try with NAT on the EDGE router as:
ip access-list standard 10
permit any
!
nat inside source list 10 interface Dialer1 over
!
interface FastEthernet0/0
ip nat inside
!
interface Dialer1
ip nat outside
!
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-20-2019 12:26 AM
Hello
Is the ISP router aware of the edge subnet and does it have nat statements for it
Also if this is a real setup make sure your pcs dont have any software firewall enable negating ping
Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.
Kind Regards
Paul
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-20-2019 07:17 AM
This is not real just lab
My ISP does not know about pc network but it has default route
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-20-2019 07:58 AM
Hello,
post the gns3 project file here (you probably have to zip it first)...
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-20-2019 12:29 AM
You will be not able to ping because your Local IP address range not aware in the routing table.
you need to do NAT on dialer interface :
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer idle-timeout 60 either
dialer hold-queue 10
dialer-group 1

- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-20-2019 01:05 AM
Hello,
I just recreated your exact setup, using your exact configs, in GNS3, and it works fine. What IP address is being assigned to your VPCS (show ip) ?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-20-2019 07:15 AM
MY VPCP PC got ip address from dhcp of Edge
ip is 192.168.10.2
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-20-2019 07:50 AM
I used the exact configurations you used. How far can you ping from the PC, can you ping the Edge router ?
Do a 'trace 10.10.10.1' from the VPCS and check how far it goes...
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-20-2019 07:37 AM
Can you lease put config?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-20-2019 08:13 AM
when i use NAT on dialer interface i even can not ping from ISP to edge
when i remove nat on dialer interface i can ping
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-20-2019 08:16 AM
EDGE ROUTER
interface GigabitEthernet2/0
no ip address
negotiation auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet3/0
ip address 192.168.10.1 255.255.255.0
ip nat inside
negotiation auto
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer idle-timeout 60 either
dialer hold-queue 10
dialer-group 1
!
ip nat inside source list 10 interface Dialer1 overload
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 10 permit any
dialer-list 1 protocol ip permit
ISP ROUTER
interface GigabitEthernet2/0
no ip address
no negotiation auto
pppoe enable group test
!
interface GigabitEthernet3/0
no ip address
shutdown
negotiation auto
!
interface Virtual-Template1
ip address 10.10.10.1 255.255.255.0
peer default ip address pool pool1
!
ip local pool pool1 10.10.10.2 10.10.10.10
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-20-2019 12:14 PM
Hello,
I am lost to be honest. The configuration you originally posted works fine. What are you trying to accomplish, is there a requirement to use NAT ?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-20-2019 11:48 PM
I am trying to ping from PC to ISP
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-21-2019 12:02 AM
Hello,
I am just thinking, it might have to do with the IOS versions and images you are running in GNS3. Your original configurations, without any sort of NAT, work fine, but I am using IOSv15.6(2)T-1.
When you use the configuration you have posted in your original post, where does a traceroute from the VPCS stop ?
