03-22-2010 12:59 PM
HI
Don't have my N7k yet so can't test but can N7K VPC be a L3 Interface to my downstream L3 C4k or C6k? Thx
for example:
int port1
no switchport
ip add 1.1.1.1 255.0.0.0
vpc peer-link
Solved! Go to Solution.
03-23-2010 07:49 PM
You should *not* use vPC for L3 routed connections on the 7K. Just use regular routed links for L3 interfaces. It accomplishes the same result of active/active bandwidth with load sharing and fast convergence.
Like this:
On the 4K or 6K:
interface GigabitEthernet4/1
description Link to N7K1
no switchport
ip address 10.100.10.5 255.255.255.254
ip ospf network point-to-point
interface GigabitEthernet5/1
description Link to N7K2
no switchport
ip address 10.100.10.9 255.255.255.254
ip ospf network point-to-point
On N7K1:
int E1/1
description Link to 6K int 4/1
no switchport
ip address 10.100.10.6 255.255.255.254
ip ospf network point-to-point
ip router ospf area 1
On N7K2:
int E1/1
description Link to 6K int 5/1
no switchport
ip address 10.100.10.10 255.255.255.254
ip ospf network point-to-point
ip router ospf area 1
Make sense?
03-24-2010 12:36 AM
The necessity for Spanning-Tree can be avoided with the correct implementation of vPC on your peer-devices. Rapid PVST is the default spanning-tree protocol, however this purely for your VLANs which would ordinarly been trunked across your Port-Channel or your peer-link between peer devices in this case, such as two N7Ks, and the uplinks from the N7Ks for your vPC to the edge or distribution switch in triangular topology, this scenario would not require STP. Please look at the diagram on page 5 of the below link, you will notice that switch 3 has two uplinks back to the N7Ks this is essentially your vPC, thus no STP is required.
Your L3 interfaces should be purely for establishing neighbour relationships with other L3 devices that participate in the exchange of routing updates.
Please look at the following guide regarding vPC on the Nexus.
http://www.cisco.com/en/US/prod/collateral/switches/ps9441/ps9670/C07-572835-00_NX-OS_vPC_DG.pdf
Hope you find this helpful.
Regards
03-22-2010 03:11 PM
Anything vPC attached should be L2 only.
If you are connecting to an L3 switch or router, you should use simple L3 point-to-point interfaces on the Nexus 7000 side.
Cheers,
Brad
03-23-2010 05:49 PM
To simply clarify the position regarding L3 interfaces, and to re-iterate what was mentioned in the previous post that you should be aware of. When you attach a Layer 3 device to a vPC domain, the peering of routing protocols using a VLAN also carried on the vPC peer-link is not supported. If routing protocol adjacencies are needed between vPC peer devices and a generic Layer 3 device, you must use physical routed interfaces for the interconnection.
You can configure VLAN Interfaces for Layer 3 connectivity on the vPC peer devices to link to Layer 3 of the network for such applications as HSRP and PIM. However, Cisco recommend that you configure a separate Layer 3 link for routing from the vPC peer devices, rather than using a VLAN network interface for this purpose.
Regards
Allan.
Hope you find this is helpful.
03-23-2010 06:58 PM
Confuse now..on the c4k or c6k side, I would do
interface Port-channel11
ip address 10.100.10.10 255.255.255.254
ip ospf network point-to-point
interface GigabitEthernet4/1 and 5/1
no switchport
no ip address
channel-group 11 mode active
On the N7k side:
interface Port-channel11
ip address 10.100.10.11 255.255.255.254
no switchport
vpc peer-link
int E1/1 as well as E2/1
no switchport
no ip address
channel-group 11 mode active
03-23-2010 07:49 PM
You should *not* use vPC for L3 routed connections on the 7K. Just use regular routed links for L3 interfaces. It accomplishes the same result of active/active bandwidth with load sharing and fast convergence.
Like this:
On the 4K or 6K:
interface GigabitEthernet4/1
description Link to N7K1
no switchport
ip address 10.100.10.5 255.255.255.254
ip ospf network point-to-point
interface GigabitEthernet5/1
description Link to N7K2
no switchport
ip address 10.100.10.9 255.255.255.254
ip ospf network point-to-point
On N7K1:
int E1/1
description Link to 6K int 4/1
no switchport
ip address 10.100.10.6 255.255.255.254
ip ospf network point-to-point
ip router ospf area 1
On N7K2:
int E1/1
description Link to 6K int 5/1
no switchport
ip address 10.100.10.10 255.255.255.254
ip ospf network point-to-point
ip router ospf area 1
Make sense?
11-03-2015 02:59 AM
i am trying to implement the n7k as a core and 4500 as agg and 2960 as access.
is it possible to run a L3 mode between the n7k and 4500 and from 4500 to 2960 as L2 mode with VLAN?
the above scanrio is possible with 2 n7k with VPC enabled and in the 4500 VSS enabled?
or which will be the best design to make core and agg as L3mode and Agg to access L2 mode.
thanks.
03-23-2010 09:39 PM
ok, I will use your recommendation....but got a related question on your reply:
I thought the default STP which is Rapid PVST+ is faster convergence than OSPF unless I tweak all bunch of timers (ie hellos, LSP, LSP Throttle and SPF ect..)..I like to avoid tweaking ospf timers but will I still get the fast convergence with default OSPF timers?
TIA
03-24-2010 12:36 AM
The necessity for Spanning-Tree can be avoided with the correct implementation of vPC on your peer-devices. Rapid PVST is the default spanning-tree protocol, however this purely for your VLANs which would ordinarly been trunked across your Port-Channel or your peer-link between peer devices in this case, such as two N7Ks, and the uplinks from the N7Ks for your vPC to the edge or distribution switch in triangular topology, this scenario would not require STP. Please look at the diagram on page 5 of the below link, you will notice that switch 3 has two uplinks back to the N7Ks this is essentially your vPC, thus no STP is required.
Your L3 interfaces should be purely for establishing neighbour relationships with other L3 devices that participate in the exchange of routing updates.
Please look at the following guide regarding vPC on the Nexus.
http://www.cisco.com/en/US/prod/collateral/switches/ps9441/ps9670/C07-572835-00_NX-OS_vPC_DG.pdf
Hope you find this helpful.
Regards
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide