cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1526
Views
8
Helpful
6
Replies
Highlighted
Beginner

3750, range command, session hang

Hi All,

I've noticed that when using the range command to configure multiple interfaces on a 3750 the SSH session oftens hangs.

It's seems the more interfaces in the range command the more often it hangs. I have a feeling it also spikes up the CPU.

Has anyone else come across this?

Doesn't seem to be related to a specific version of code.

Anyone know a workaround?

I tried shutting the interfaces before hand but that made no difference.

In some instances I could not even change 2 interfaces without my SSH session disconnecting. Its very frustrating.

This is the typical interface config.

Doesn't seem hang on any particular command.

switchport mode access

switchport port-security maximum 2

switchport port-security

switchport port-security aging time 1

switchport port-security violation restrict

switchport port-security aging type inactivity

no logging event link-status

srr-queue bandwidth share 10 20 60 20

srr-queue bandwidth shape 30 0 0 0

priority-queue out

storm-control broadcast level 5.00

storm-control multicast level 10.00

storm-control unicast level 95.00

storm-control action trap

spanning-tree portfast

spanning-tree bpduguard enable

service-policy input qos-policy

ip dhcp snooping limit rate 15

Any help, ideas much appreciated

Cheers

6 REPLIES 6
Highlighted
Contributor

I agree, as it is said by you, CPU might be going crazy

check whether unnecessary old configs are still availble and remove if you are sure.

Might be helpful

Please rate the helpful tags.

Regards
Thanveer
"Everybody is genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is a stupid."

Highlighted
Collaborator

Hi,

Have you tried a different terminal application? I have had numerous issue using putty and ssh on Windows 7 with similar symptoms to those you describe. I use Tera Term and haven't experienced the same issue I did with putty and pasting the buffer to the terminal. Just my experience..

Regards
Allan.

Sent from Cisco Technical Support iPad App

Highlighted
Hall of Fame Community Legend

I've noticed that when using the range command to configure multiple interfaces on a 3750 the SSH session oftens hangs.

This is a typical behaviour of the 3750 (all IOS versions). This behaviour becomes more evident if you have a six or more switches to a stack. 

This is the main reason why I do not recommend anyone stacking more than six 3750 together. 

Highlighted

I agree that this is normal behavior for the 3750.  I have always tryed to not to stack more than five (make for a messy closet).   But I have found that if "tacacs" is enabled then it is more pronounced.  From the console the delay is not as bad. 

So doing a cut and paste with a large about of configuration might take a while.  I often would try one or two and then when they complete doing a couple more. 

Highlighted

Thanks to all who responded.

Seems that this is usual behavoir. I havent had a chance to try using TeraTerm but will do so when a chance arrises.

We also use TACACS accounting so perhaps that is also contributing to the issue.

Highlighted
Hall of Fame Community Legend

Look, if you have no other options but to stick to the current stack structure, there's another way to "cheat".

1.  Open a Notepad;

2.  Type in your commands, for example:

conf t

interface r G1/0/1 - 48, G2/0/1 - 48 , F3/0/1 48

no macro description

end

3.  Save the TXT file and run the following commands on the switch:  copy tftp:///.txt run

This should implement your command without going into interface configuration mode.  Just make sure that you save the config when you are done.

Content for Community-Ad