cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

1025
Views
15
Helpful
12
Replies
a.m Beginner
Beginner

A problem with NATIVE_VLAN_MISMATCH

Hello,

In the following topology, I was asked to implement the inter-vlan routing on the layer 3 switch MLS.

Screenshot from 2018-04-18 07-05-19.png

The activity progress counter shows 100% but I see a vlan mismatch on both of S1 and MLS. I don't understand the reason. 

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet0/1 (1), with S1 GigabitEthernet0/1 (999).
I checked the configurations but I didn't find any error. Could you please confirm if there is something wrong in the configuration ?
On MLS :
Configurations :
https://pastebin.com/9QHy72Bg

MLS#show interfaces g0/1 switchport
Name: Gig0/1
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: trunk
Administrative Trunking Encapsulation: negotiated
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 999 (VLAN0999)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: All
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

On S1
configurations :
https://pastebin.com/yPSU0NUn

S1#show interfaces g0/1 switchport
Name: Gig0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 999 (VLAN0999)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: All
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

 

Kind regards.

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advocate

Re: A problem with NATIVE_VLAN_MISMATCH

Hi, 

You are missing two commands on MLS switch.

 

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q   

switchport mode trunk  

 

Regards,

Deepak Kumar

 

 

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

View solution in original post

12 REPLIES 12
Collaborator

Re: A problem with NATIVE_VLAN_MISMATCH

On the MLS side for the interface put the command: switchport mode trunk

 

Mike

a.m Beginner
Beginner

Re: A problem with NATIVE_VLAN_MISMATCH

So, I can't change the native vlan without being in trunk mode ?
VIP Advocate

Re: A problem with NATIVE_VLAN_MISMATCH

Hi, 

Then you have to remove the command

"Switchport tunk native vlan <>

 

 

Regards,

Deepak Kumar

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
a.m Beginner
Beginner

Re: A problem with NATIVE_VLAN_MISMATCH

VTP can't communicate the native vlan ?
VIP Advocate

Re: A problem with NATIVE_VLAN_MISMATCH

Hi, 

You are missing a command "Switchport mode trunk"

 

Regards, 

Deepak Kumar

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Collaborator

Re: A problem with NATIVE_VLAN_MISMATCH

Sorry I should have read this more closely.

 

Did you see the error during the configuration?

 

Clear the logs and see if the error continues.

 

After reading everything closer it all looks ok. A trunk will form if one side is trunk and the other to dynamic auto.

 

 

a.m Beginner
Beginner

Re: A problem with NATIVE_VLAN_MISMATCH

The error persists, is it a bug in the simulator ?
VIP Advocate

Re: A problem with NATIVE_VLAN_MISMATCH

Hi,

Please attach your lab file.

 

Regards,

Deepak Kumar

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
a.m Beginner
Beginner

Re: A problem with NATIVE_VLAN_MISMATCH

Hello,

Thank you for your interest.

https://mega.nz/#!MfRTlA6T!Fo1mkMFw5E9DSX-3BcmUCUrESqt8uF0IBDNIUAwbPxo

Regards.

VIP Advocate

Re: A problem with NATIVE_VLAN_MISMATCH

Hi, 

You are missing two commands on MLS switch.

 

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q   

switchport mode trunk  

 

Regards,

Deepak Kumar

 

 

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

View solution in original post

a.m Beginner
Beginner

Re: A problem with NATIVE_VLAN_MISMATCH

The problem can also resolved also when you do, as you suggested before,
Thank you all for your precious help.
Kind regards!

Highlighted
a.m Beginner
Beginner

Re: A problem with NATIVE_VLAN_MISMATCH

Sorry, no switchport trunk native vlan 999 doesn't work.

I edited my previous reply.

only, the Deepak kumar's solution work :

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q   

switchport mode trunk  

 

Regards

CreatePlease to create content
Content for Community-Ad