cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1523
Views
5
Helpful
13
Replies
Highlighted
Participant

Catalyst C3850 Gibraltar-16.12.1 ED

Just making this post so no one else tries to run this software version on their 3850.

Do not attempt to run cat3k_caa-universalk9.16.12.01.SPA.bin on the 3850.

Mine is a C3850-12X48U-E.

I verified the SHA512 multiple times and even tried booting from a flash drive.

Currently SHA512 is: 5800720c79f217e150e50397006f199ceeb21e69721fd8a941b84c2675ec62666aa6a4b5aca58ed1079e470f6a3ceaa429e496279d409e47921aae8a90af48f2

 

 

Interface GE 0 link down***ERROR: PHY link is down

Getting rest of image
Reading full image into memory...Check base package header ...: done = 16384
Getting rest of image
Reading full image into memory....done
Reading full base package into memory...: done = 34200944
Bundle Image
--------------------------------------
Kernel Address    : 0x5342f3c0
Kernel Size       : 0x43824e/4424270
Initramfs Address : 0x5386760e
Initramfs Size    : 0x1c0cf62/29413218
Compression Format: mzip

Bootable image at @ ram:0x5342f3c0
Bootable image segment 0 address range [0x81100000, 0x81da5280] is in range [0x80180000, 0x90000000].
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@boot_system: 377
Loading Linux kernel with entry point 0x81894d40 ...
Bootloader: Done loading app on core_mask: 0x3f

### Launching Linux Kernel (flags = 0x5)

Linux version 4.9.177 (xelinux@sjc-xelinux1) (gcc version 5.3.0 (GCC) ) #1 SMP Fri Jun 7 18:13:03 PDT 2019
CVMSEG size: 2 cache lines (256 bytes)
Cavium Inc. SDK-5.1.0
bootconsole [early0] enabled
CPU0 revision is: 000d900a (Cavium Octeon II)
Checking for the multiply/shift bug... no.
Checking for the daddiu bug... no.
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)

 

 

13 REPLIES 13
Highlighted
VIP Expert

have you read the release notes.

 

More intrested to learn from what version you try to upgrade :

 

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3850/software/release/16-12/release_notes/ol-16-12-3850.html#id_67613

 

 



BB


*** Rate All Helpful Responses ***

Highlighted

Yes, I always read the release notes for known issues and even noticed the installation command changed slightly, telling you to put "new" at the end of "req platform software package install sw all file...".

 

I was attempting an upgrade from Fuji-16.9.3a MD (cat3k_caa-universalk9.16.09.03a.SPA.bin).

I don't think that really matters much (unless older versions used an older ROMMON) because I even tried booting from a flash drive in ROMMON.

 

Also, if you google the actual error:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)  

 I believe this means the Kernel wasn't configured correctly.

Highlighted

Good to know you are in right direction, if this is not in production and you have not seen any outage.

 

try Gib 16.11.X and upgrade to 12.X

 



BB


*** Rate All Helpful Responses ***

Highlighted

It was in production and caused some downtime but for me it's not a huge problem.

Just warning other people.

 

The only Gibraltar release I can see for the C3850 is this one: cat3k_caa-universalk9.16.12.01.SPA.bin

Highlighted

since its new release as value added for others and TAC benift raise TAC case so they make a note allow them to do test and realse fix for you.

 

NOTE ; iam going to do upgrade  same verison 11.X or 12.X on Cat 9500 and let you know outcome.



BB


*** Rate All Helpful Responses ***

Highlighted

I don't have a support contract so all I can do is post here.

Highlighted
Beginner

unfortunately I didn't carefully read about this issue. & now one of mine 3850 24 port switch keep rebooting after showing error
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)
I was trying to upgrade it from vpn remote connection, so I am not physically there, my bad
Highlighted
Participant

Since my new thread keeps getting flagged as spam, I'll reply to this post.

Gibraltar-16.12.4 MD (cat3k_caa-universalk9.16.12.04.SPA.bin) has the exact same issue.

So either I'm extremely unlucky or Gibraltar just doesn't work on the C3850 platform.

Be warned.

Highlighted
Hall of Fame Community Legend

Post the entire boot-up process so we can have a look.

NOTE:  I have a few 3850 running 16.12.4 and no issue like this in production.

Highlighted

It's the exact same error as above.

I posted a new thread with the console output but it never got published because it was marked as spam.

The output was pretty much identical to the above.

Highlighted
Hall of Fame Community Legend

Can you go into ROMMON?
If you can, delete the IOS (BIN file &/or the packages.conf file). If this is done, reboot the switch (it'll go into ROMMON as intended) but I want to see the console output when this is done.
I want to see where the "stupid" is happening -- Is this happening before the IOS file(s) gets loaded or not.
Highlighted

When I put the BIN file on a USB stick and hold the mode button to bypass startup then type boot usbflash0:/file.bin it still fails with the same error.

Highlighted
Hall of Fame Community Legend

No. That's not what I requested. I want to see the output of the switch as it goes into ROMMON.
Content for Community-Ad