cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3237
Views
11
Helpful
12
Replies

DHCP Cisco router leases IP configuration but doesn't ping hosts

Nightwolf_82
Level 1
Level 1

Hello guys.

I have 2811 Cisco router which I configured as a DHCP server. The configuration is very basic.

ip dhcp excluded-address 172.16.10.1 172.16.10.10
ip dhcp excluded-address 192.168.20.1 192.168.20.10
!
ip dhcp pool VOICE
network 172.16.10.0 255.255.255.0
default-router 172.16.10.1
option 150 ip 172.16.10.1
!
ip dhcp pool DATA
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.10
description **VOICE VLAN INTERFACE**
encapsulation dot1Q 10
ip address 172.16.10.1 255.255.255.0
!
interface FastEthernet0/1.20
description **DATA VLAN INTERFACE**
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0

!

The IP addresses are leased successfully.

SYD-RTR-CME#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
172.16.10.11 0100.1f9e.24bf.08 Dec 18 2015 03:00 PM Automatic
192.168.20.11 01bc.aec5.51f6.39 Dec 18 2015 03:04 PM Automatic

Below is TCP/IP configuration of the host.

C:\Users\win7>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : iBook
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : JMicron PCI Express Gigabit Ethernet Adap
ter
Physical Address. . . . . . . . . : BC-AE-C5-51-F6-39
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::7d41:d47:11f2:c4fa%20(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.20.11(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Thursday, December 17, 2015 7:19:14 PM
Lease Expires . . . . . . . . . . : Friday, December 18, 2015 7:23:09 PM
Default Gateway . . . . . . . . . : 192.168.20.1
DHCP Server . . . . . . . . . . . : 192.168.20.1

The ping from PC to router is fine.

C:\Users\win7>ping 192.168.20.1

Pinging 192.168.20.1 with 32 bytes of data:
Reply from 192.168.20.1: bytes=32 time=1ms TTL=255
Reply from 192.168.20.1: bytes=32 time<1ms TTL=255
Reply from 192.168.20.1: bytes=32 time<1ms TTL=255
Reply from 192.168.20.1: bytes=32 time<1ms TTL=255

Ping statistics for 192.168.20.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms

The router successfully pings an IP phone, however, ping to PC doesn't work.

SYD-RTR-CME#ping 172.16.10.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
SYD-RTR-CME#ping 192.168.20.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.11, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

There is no antivirus software installed on PC. I tried to connect another router directly to SYD-RTR-CME on both f0/0 and f0/1 and ping was OK. I also tried to connect the workstation directly to another router and again ping was OK.

What could be the reason of that?

12 Replies 12

Mark Malone
VIP Alumni
VIP Alumni

what way is it physically setup , is the pc hanging off the phone port  and both connected to switchport

if so what way have you set the port by trunk or by switchport voice vlan  or is the pc and phones on different ports ?

The PC is connected to IP phone's 10/100 PC port and the IP phone's port 10/100 SW is connected to switch. The config of switch is below.

SYD-SW-3750#sh run int f1/0/1
Building configuration...

Current configuration : 136 bytes
!
interface FastEthernet1/0/1
switchport access vlan 20
switchport mode access
switchport voice vlan 10
spanning-tree portfast
end

SYD-SW-3750#sh run int f1/0/24
Building configuration...

Current configuration : 139 bytes
!
interface FastEthernet1/0/24
description **INTERFACE TO SYD-RTR-CME**
switchport trunk encapsulation dot1q
switchport mode trunk
end

 

Are other pc/phones working fine on the same switch same setup?

Is the arp complete with the correct mac address for that interface on the L3 device that the switch trunks too

I tried to connect another PC to the same switch but without any luck.

Yes, the ARP table is OK.

whats the default gateway of the 3750 , if you can ping 1 way but not the other somethings off acl etc  , I understand you said its not a FW issue but I would turn it all off when testing to be sure 

Hi Mark

The default gateway on 3750 switch was 192.168.20.1

The problem is solved but I didn't understand why it happened. The only thing I did is that I added the command switchport trunk allowed vlan 10,20 on the switch. What's more interesting is that when I typed no switchport trunk allowed vlan 10,20 the ping still went to and from router.

Please be kind to expain what was that and why it happened.

Thank you in advance.

If you do not specifically state which VLANs are allowed on a trunk then it will implicitly allow all VLANs.

Are you sure this is not just a case of needing to specify the source address in the ping:

ping 192.168.20.11 source 192.168.20.1

I tried to specify the source address but without any luck.

glen.grant
VIP Alumni
VIP Alumni

  If it's running windows did you shutoff the Windows firewall ? 

The Firewall in on but I'm pretty sure it's not the reason of the issue as the ping is OK if I connect PC to another router.

design1balu1
Level 1
Level 1

What could be the reason of that?

The problem is solved but I didn't understand why it happened. The only thing I did is that I added the command switchport trunk allowed vlan 10,20 on the switch. What's more interesting is that when I typed no switchport trunk allowed vlan 10,20 the ping still went to and from router.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card