cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
481
Views
0
Helpful
7
Replies
bryan.iler
Beginner

Extended VLAN's

Hello All,

 

I have never worked with with extended vlans, but I have a customer who sent their vlan IDs they won't configured and they start at 2000. I have set the switch to VTP Transparent mode and created the vlans, but I need these to be routed. When I create an actual vlan interface, the status shows up, but the protocol shows down. Is it possible to create vlan interfaces for extended vlans?

Switchin

Thanks,

Bryan

 

1 ACCEPTED SOLUTION

Accepted Solutions
Martin L
VIP Advocate

 

Try switchport autostate exclude under SVI interface -  tells the switch to no longer consider the state of that port in its determination as to whether the SVI should be up or down. 

cisco 9300 should support that command and exclude vlan 2000 SVI for so called auto vlan check (PT does not).

 

Regards, ML
**Please Rate All Helpful Responses **

View solution in original post

7 REPLIES 7
balaji.bandi
VIP Guru

Can give us more information what switch and what IOS Code, yes that is possible,

 

SVI Interface vlan 2000 only be up/up - when any access port to be part of the VLAN and device connected to that port to become up.

 

or this should be allowed in Port-channel ? (this is my assumption)

 

if you looking more advice, then please post the information below :

 

show VLAN

show ip interface brief

show interface vlan 2000

show span vlan 2000

 

 

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thanks for the response. I don't have access to the switch at present, but I have done some test scenarios on 3650 in packet tracer and it isn't working. The customer switch is cisco 9300. Here is the config I am using:

vtp mode transparent
!
spanning-tree mode pvst
!
vlan 10
name testvlan10
!
vlan 2000
name testvlan2000
!
interface GigabitEthernet1/0/1
switchport mode trunk
!
interface Vlan10
mac-address 0009.7caa.2501
ip address 10.10.10.1 255.255.255.0
!
interface Vlan2000
mac-address 0009.7caa.2502
ip address 10.124.25.1 255.255.255.0


Interface IP-Address OK? Method Status Protocol
GigabitEthernet1/0/1 unassigned YES unset up up

Vlan10 10.10.10.1 YES manual up up
Vlan2000 10.124.25.1 YES manual up down

I have a access switch connected to the core with the vlans and it is trunked. Vlan 10 comes up, but not vlan 2000

At this information, we are not sure what is wrong. i am not a Packet tracer user, as i know PT does not support Extend vlan as per the document, this might have changed in due course of the latest version.

 

 

for extended we use spanning-tree config -spanning-tree extend system-id

 

when you get the chance i would like to see the below output as asked before, also other side switch config.

 

 

show VLAN
show ip interface brief
show interface vlan 2000
show span vlan 2000
show interface trunk
show vtp status

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hi,

 

Try to create vlan 2000 on the access switch as well.

You might need to change VTP to transparent as well.

Assign it to trunk port if it is not.

 

Regards,

Ventsi

pman
Enthusiast

Hi,

 

try the show int trunk command and make sure vlan 2000 is there.

interface igabitEthernet1/0/1

   switchport mode trunk

   switchport trunk allowed vlan add 2000

Another thing you can try is to set another port as access (try to connect it to another device for testing)for vlan 2000 and see if it changes status up:

int gi1/0/x
switchport mode access
switchport access vlan 2000

Martin L
VIP Advocate

 

Try switchport autostate exclude under SVI interface -  tells the switch to no longer consider the state of that port in its determination as to whether the SVI should be up or down. 

cisco 9300 should support that command and exclude vlan 2000 SVI for so called auto vlan check (PT does not).

 

Regards, ML
**Please Rate All Helpful Responses **

Thanks ML,

 

That was the issue. PT doesn't support extended vlans. 

 

Best,

 

Bryan