cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3137
Views
4
Helpful
2
Replies
Highlighted
Beginner

Layer 3 Etherchannel Config

Hi,

   I been practicing with the configuration of layer 3 etherchannel configuration and i am facing a problem here. I have two 3560 switches and i want a layr 3 ether channel configuration setup between the first 2 ports of bothe the switches. I assign IPs to the Port-channel 1 of both the switches "10.1.1.1 /24 and 10.1.1.2 /24" but i am unable to get a successful ping. what am i doing wrong. below are the configs for bothe of my switches.

3560_1

Building configuration...

Current configuration : 1274 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname 3560_1

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/1

no switchport

channel-protocol pagp

no ip address

duplex auto

speed auto

!

interface FastEthernet0/2

no switchport

channel-protocol pagp

no ip address

duplex auto

speed auto

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Port-channel 1

no switchport

ip address 10.1.1.1 255.255.255.0

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

!

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

!

end

=====================================

3560_2

Building configuration...

Current configuration : 1338 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname 3560_2

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/1

no switchport

channel-protocol pagp

channel-group 1 mode desirable

no ip address

duplex auto

speed auto

!

interface FastEthernet0/2

no switchport

channel-protocol pagp

channel-group 1 mode desirable

no ip address

duplex auto

speed auto

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Port-channel 1

no switchport

ip address 10.1.1.2 255.255.255.0

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

!

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Layer 3 Etherchannel Config

You need to have channel-group command on both sides (desirable must be used on one or both). channel-protocol command is not neccessary.

View solution in original post

2 REPLIES 2
Highlighted
Beginner

Layer 3 Etherchannel Config

You need to have channel-group command on both sides (desirable must be used on one or both). channel-protocol command is not neccessary.

View solution in original post

Highlighted
Beginner

Layer 3 Etherchannel Config

like Sergey said, you need it on both sides....your half way there...

put the command "channel-group 1 mode desirable" or "channel-group 1 mode on" on both ends you will be good...

Content for Community-Ad