05-17-2010 09:40 AM - edited 03-06-2019 11:08 AM
I'm trying to setup a port channel from a 2960G to a 3750G and I'm getting (Not connect) on the 3750 when I do a sho int Po1 command. It shows connected on the 2960. When I do a sho eth sum on each device things look good both ends show that they are bundled. One difference I see when comparing the sho int po1 on the devices is that the 3750 shows a "Media-type configured as a connector" see sho int command below. Could this be the cause of the no connection on the port channel? I know the cable is good because the uplink works fine when its not port channelled. Its only when I port channel the interface that connection is lost. Both ends are running in access mode servicing one vlan. Any ideas? I've done many port channels and never come accros this one. Thanks!
Port-channel1 is down, line protocol is down (notconnect)
Hardware is EtherChannel, address is 000e.d753.f983 (bia 000e.d753.f983)
Description: etherchannel to CORP-SW3-2960G
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Full-duplex, 1000Mb/s, link type is auto, media type is unknown
Media-type configured as connector
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:44:06, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
05-18-2010 10:04 AM
I see a lot of responses to your question. I saw in your last show interface that you didn't have to members in your output. An example of one of my channels (I cut out the non important part to save space.
Port-channel2 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 001b.d5a2.2d87 (bia 001b.d5a2.2d87)
Description: to 3-TC1A-6509-1
MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, <-------------Note bandwidth
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is unknown
input flow-control is off, output flow-control is off
Members in this channel: Gi3/24 Gi5/2 <---------------Note members in the channel
I have lots of port channels configured (3750's, 4948's, and 6500's). If I was at the console of your devices I would enter as follows:
int range g0/1 , g2/3/37
no channel-group 1 mode on
exit
no int po1
default interface range g0/1 , g2/3/37
We now have the ports cleared. It only takes a few commands to clear and start from scratch. Notepad helps. Time to setup the channel:
int po1
description UPLINK TO WCK CORE
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
shut
"Don't unshut the ports until your channels are setup"
interface GigabitEthernet0/1
description UPLINK TO WCK CORE
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
shut
interface GigabitEthernet2/3/37
description UPLINK TO WCK CORE
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
shut
int po1
no shut
You can cut and past the commands into the device. Once the channel is up, you no longer make interface changes on the individual ports, only on the channel port (int po1). You see above that I didn't "no shut" the individual ports. Only the "int po1" With spanning tree, trunk links can play havoc on the network. I always prune my trunk links to allow only vlans needed across. Let me know of any questions that you might have. Make sure the setup is similar on the other side of the connection.
05-18-2010 10:51 AM
Thanks for the reply. I mirrored your config and I'm still getting down, down, (not connect) on the upstream switch...what do you think about the media-type configured as a connector statement below? It's the only difference I see when comparing my working etherchannels to this one. Any way to get rid of that statement?
*Forgot to mention that I started from scratch and kept the po channel down until the interfaces were setup.
Port-channel1 is down, line protocol is down (notconnect)
Hardware is EtherChannel, address is 000e.d753.f983 (bia 000e.d753.f983)
Description: UPLINK TO WCK CORE
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 7/255, rxload 5/255
Encapsulation ARPA, loopback not set
Full-duplex, 1000Mb/s, link type is auto, media type is unknown
Media-type configured as connector
05-18-2010 11:43 AM
Media type as connector usually refers to a shared port (can be 10/100/1000 or SFP). That means the port needs a "media type command". Is one of the ports being used a shared port? Can you send a "show int status" on the 2960G Model. Also when you turn up the port channel are there any log entriies? Also what is the specific switch model number. A show version will give it.
From your configs I get this:
Your 3750 on one side of the connection
g1/0/1 = channel group 1
g1/0/3 = channel group 1
Your 2960G on the other side of the connection
g0/1 = channel group 1
g2/3/37 = channel group 1 <---------- I am not familiar with this port designation
I see your configuration for g2/3/37 in the posts, but don't see it in the 2960G config posted above.
Can I get a show run int g2/3/37
Douglas
05-18-2010 04:38 PM
No shared port on the 3750G. I did notice the 2960G has dual purpose ports, but those are ports 45-48.
Every port on the 3750G shows up as "configured as a connector" The media-type command is unrecognized on the interfaces or while in global config mode.
Here's the sho int stat on the 2960G:
CORP-SW3-2960G#sho int stat
Interface Vlan1 is disabled
Vlan4
Switching path Pkts In Chars In Pkts Out Chars Out
Processor 1905 158687 131 9743
Route cache 0 0 0 0
Total 1905 158687 131 9743
GigabitEthernet0/1
Switching path Pkts In Chars In Pkts Out Chars Out
Processor 0 0 0 0
Route cache 0 0 0 0
Total 0 0 0 0
GigabitEthernet0/2
Switching path Pkts In Chars In Pkts Out Chars Out
Processor 0 0 51221 5583967
Route cache 0 0 0 0
Total 0 0 51221 5583967
The sho int status on the 3750G looks much different:
core-48#sho int status
Port Name Status Vlan Duplex Speed Type
Gi1/0/1 10.1 Riverbed connected 1 full 1000 10/100/1000Ba
seTX
Gi1/0/2 .1 connected 1 a-full a-1000 10/100/1000Ba
seTX
Gi1/0/3 connected trunk a-full a-1000 10/100/1000Ba
Here's the current port channel members and the config is the same for all the below members.
interface GigabitEthernet1/0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
On the 2960G Side- ports Gig0/1 and gig0/2 are members of channel-group 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Gi0/1(P) Gi0/2(P)
On the 3750G side- ports Gig1/0/3 and gig3/0/11 are members of channel-group 1
Group Port-channel Protocol Ports
------+-------------+-----------+------------------------------------------------
1 Po1(SU) PAgP Gi1/0/3(P) Gi3/0/11(P)
I've also tried port channel modes active, on, auto and cant get the line protocol up on the 3750G....very odd. They bundle fine but no connection on po1.
05-18-2010 06:12 PM
I don't have any 2960 switches at work. I do have one that a bought used on ebay. I haven't even booted it up yet. I do have 250 Cisco 3750's in service at work. So lets check the configs for each port. This shouldn't be too difficult. I have your configs. I will play with them in the morning when I get to work. How far are the devices from each other? Can you get link on each of the ports? Which port physically connects to the other? I will respond as often as possible.
3750
show run int g1/0/1
show run int g1/0/3
show run int po1
2960
show run int g0/1
show run int g0/2
show run int po1
05-19-2010 06:38 AM
I don't know why this did not click with me earlier. The PAgP is not supported for cross-stack EtherChannels. I notice that you have one link on the first switch in the stack and one on the third switch. Try putting them both on the same switch in the stack.
This is from the Cisco website.....
*********************************************************************************
For cross-stack EtherChannel configurations, ensure that all ports targeted for the EtherChannel are either configured for LACP or are manually configured to be in the channel group using the channel-group channel-group-number mode on interface configuration command. The PAgP protocol is not supported on cross- stack EtherChannels.
*********************************************************************************
Mike
05-19-2010 12:54 PM
The port channel is up and connected. The change I made was creating po6 and re-assigning the appropriate switch ports to it. . Not sure why the 3750G didn't like port channel 1.
05-20-2010 05:32 AM
Glad to see that you got it working.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide