cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1178
Views
0
Helpful
7
Replies

Splitting available bandwidth

mumbles202
Level 5
Level 5

I'm trying to split a 20 mb pipe that comes in from my ISP so that 1 server gets a dedicated 5 mb and the remaining ips behind the router get the remaining 15 mb.  I put this in place thinking it would do the trick but it didn't:

access-list 110 permit ip host AA.BB.CC.180 any
access-list 120 permit ip host AA.BB.CC.178 any


class-map match-all lifesize
match access-group 110
class-map match-all remaining_ips
match access-group 120

policy-map internetpriority
class lifesize
   police cir 5000000
     exceed-action drop
class remaining_ips
   police cir 15000000
     exceed-action drop


policy-map physical
class class-default
    police 20000000 conform-action transmit  exceed-action drop
  service-policy internetpriority


interface FastEthernet0/0
description Connection to Internal Switch
ip address AA.BB.CC.177 255.255.255.248
service-policy output physical

I tried using bandwidth instead as well but it also didn't seem to yield the desired result.  Wondering if I missed something or if I applied it incorrectly?

2 Accepted Solutions

Accepted Solutions

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello David,

usually for nested policies the parent policy is a shaper and the child policy implements queuing.

The parent policy creates a logical pipe at specified bit rate and the child policy provides resource partitioning among classes with the great advantage of being an elastic mechanism if one class does not use all of its resources they are left for use to other classes

So I would suggest

policy-map physical

class class-default

shape 200000000

service-policy QUEUES

policy-map QUEUES

class lifesize

bandwidth 5000

class class-default

fair-queue

Nesting policers is not common.

Hope to help

Giuseppe

View solution in original post

Hello David,

feel free to post the error messages.

I have made a typing error I should have written shape average 20000000

see QOS Command reference shape average provides better control

Have you modified the bandwidth settings on the interface?

http://www.cisco.com/en/US/docs/ios-xml/ios/qos/command/send_qdm_message_through_show_atm_bundle_svc_statistics.html#GUID-989CB240-829E-4075-B2AA-3A0C5E3A2CAB

Hope to help

Giuseppe

View solution in original post

7 Replies 7

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello David,

usually for nested policies the parent policy is a shaper and the child policy implements queuing.

The parent policy creates a logical pipe at specified bit rate and the child policy provides resource partitioning among classes with the great advantage of being an elastic mechanism if one class does not use all of its resources they are left for use to other classes

So I would suggest

policy-map physical

class class-default

shape 200000000

service-policy QUEUES

policy-map QUEUES

class lifesize

bandwidth 5000

class class-default

fair-queue

Nesting policers is not common.

Hope to help

Giuseppe

Ok, thanks for the quick response.  I'll give that at a try and post back the results.

I just tried adding the config example above and it errors out when trying to add the shape statement under policy-map physical.  If I do a shape ? I have the following items to choose from:

  adaptive        Enable Traffic Shaping adaptation to BECN

  average         configure token bucket: CIR (bps) [Bc (bits) [Be (bits)]], send out Bc only per interval

  fecn-adapt      Enable Traffic Shaping reflection of FECN as BECN

  fr-voice-adapt  Enable rate adjustment depending on voice presence

  max-buffers     Set Maximum Buffer Limit

  peak            configure token bucket: CIR (bps) [Bc (bits) [Be (bits)]], send out Bc+Be per interval

  adaptive        Enable Traffic Shaping adaptation to BECN

  average         configure token bucket: CIR (bps) [Bc (bits) [Be (bits)]], send out Bc only per interval

  fecn-adapt      Enable Traffic Shaping reflection of FECN as BECN

  fr-voice-adapt  Enable rate adjustment depending on voice presence

  max-buffers     Set Maximum Buffer Limit

  peak            configure token bucket: CIR (bps) [Bc (bits) [Be (bits)]], send out Bc+Be per interval

I tried doing "shape peak xxxxxxx"  and a shape average but those errored out as well.

Hello David,

feel free to post the error messages.

I have made a typing error I should have written shape average 20000000

see QOS Command reference shape average provides better control

Have you modified the bandwidth settings on the interface?

http://www.cisco.com/en/US/docs/ios-xml/ios/qos/command/send_qdm_message_through_show_atm_bundle_svc_statistics.html#GUID-989CB240-829E-4075-B2AA-3A0C5E3A2CAB

Hope to help

Giuseppe

Thanks Giuseppe.  I had tried the shape average but it failed, but I realized the problem.  It was the last 0 in the 2000xxx so I just dropped one off and it went through.  I'll try to add the service-policy to the interface now and see if they can test it tomorrow.

Thanks.

i just got confirmation that this worked as expected for outbound traffic.  If i wanted to apply to inbound traffic as well would I just need to do "service-policy input physical" for that interface as well?

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

Inbound is more problematic.  You'll only be able to police and policing is really only effective with rate-adaptive traffic, and even then, it's not precise.

As policy like:

policy police_server_in

class lifesize

police average 5000000

Review Cisco Networking products for a $25 gift card