Showing results for 
Search instead for 
Did you mean: 

SX20- TC7 to CE9 Upgrade


I recently received a work order to upgrade our endpoints from TC7.3.6 to CE9.2.3. I pushed the update to a test system via TMS and afterword received the following warnings:


Certificate Expiry- A certificate has expired X days ago. Please Update.

Default Call Protocol- The system is not registered on any protocols. Please configure SIP or H323.


I verified that both call protocols are enabled, gatekeeper/uri settings are correct with dynamic port allocation. Basically, none of the settings changed, yet I'm now getting the two warnings above. Cannot send or receive calls. 


I'm wondering if this expired cert is disabling the system. I'm also not sure what I'd need to do to get it updated. Our systems do tie in with TMS, currently running 15.3. Any guidance is appreciated.

18 Replies 18

Paul Richardson

Hi Russell,


Looking at TMS release notes, it appears that you may need TMS 15.6.1 to support CE9.2.x s/w.  I have a client with a similar issue with an old TMS that doesn't support CE8 s/w.  TMS saw the endpoint as some strange old MXP.  Downgraded to TC7.3.9 and added to TMS without issue.  Trying to talk them into upgrading.


You state that the endpoint shows as not registered.  What should it be registered to, CUCM or VCS?  If CUCM, I assume that all the relevant cop files are in place.


Cheers, Paul R.

Hi Paul,


Thanks for the reply. I recently upgraded TMS to 15.6.1, which resolved the cert warning but the default call protocol error still persists.


The endpoint is registered to a VCS and when I look at event logs, the endpoint shows as a search event with "Not registered-Destination not found." This is using H323. I've triple-checked to ensure the endpoint is correctly configured to our gatekeeper.

Wayne DeNardi
VIP Advisor VIP Advisor
VIP Advisor

You should be using at least TMS 15.5 if using CE9.x software on your endpoints.  This is likely to be the cause of most of your issues.  It's recommeded that you use the latest TMS 15.6.1 (which includes a few bug fixes relating to CE9.x code).  Some of your issue are likely caused by the lack of a provisioning template for the CE devices which isn't available in the older TMS version.


Note that the supported versions of Windows and SQL server have also changed from TMS15.3 to TMS15.6, which may require that you build a new server(s).  

Please remember to mark helpful responses and to set your question as answered if appropriate.

UPDATE: I upgraded to TMS 15.6.1. The certificate error seems to have resolved but the call protocol error persists. I again went through to make sure the settings were correct. 

Wayne, you mentioned provisioning--I'm aware of TMSPE but I'm not sure we're running it. Is this (or the lack thereof) what you are referring to?


Thank you for your help.


EDIT: Correction, the cert error still persists. It disappeared when I tried downgrading to CE8, but as soon as I installed CE9.2.3, the error returned.


Hi Russell,


Can you check if the device has a CUCM CAPF certificate? 


I think the warning does not do a good job to tell what certificate you are missing. I have CAPF and I dont have that warning. Maybe just a shot in the dark, but hope you find this helpful.

Thank you for the reply. The cert error has resolved since upgrading to TMS 15.6.1. The call protocol error persists, however. 


Since I'm not seeing any errors for that device on TMS, I'm wondering if there's a problem with it registering to the gatekeeper/registrar, but I'm not seeing anything in logs that would indicate this.


EDIT: Correction, the cert error still persists. It disappeared when I tried downgrading to CE8, but as soon as I installed CE9.2.3, the error returned.

What is the endpoint registered to, ie: CUCM, VCS, Expressway?
If CUCM, than Default Call Protocol should be SIP.
If VCS, than Default Call Protocol could be either H323 or SIP depending on which protocol it's registered to the VCS with.
If it's not registered to anything, than Default Call Protocol should be H323.

Endpoint is registered to VCS. We typically leave the default call protocol on auto, but I've attempted manually switching to H323 and SIP (both protocols are pointed to the appropriate gatekeeper/registrar) with no success.


Can you post a screenshot of the Home page, from the SX20 that is having problems?

Thank you,
Justin Ferello
Technical Support Specialist, ScanSource KBZ


The two issues it mentions are the cert error and call protocol error.

It appears SIP & H323 are both inactive. Go up to "Setup" slide down to "System configuration" and click. Then click on "Network Services" on the left side. Then make sure that H323 mode and SIP mode are set to "on".
Thank you,
Justin Ferello
Technical Support Specialist, ScanSource KBZ

Thanks Justin. I just noticed this. I'm still getting the cert error and cannot send/receive calls, but it's at least registering to the VCS again.

Looking at your screenshot I think it's likely you have a configuration error. If you go into system config/network services/general settings, are both H.323 mode and SIP mode set to on? Then move on to the sections for each of those and check there - both are showing inactive, you are likely missing something. 

Thanks PJ. I just noticed this a few minutes after submitting that screen. Services are running again but I still can't send/receive calls. Combing through settings now to see if I'm missing anything else. Still getting the cert expiry error.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers