cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4935
Views
25
Helpful
15
Replies

CallManager upgrade from 7.1(3b) to UCM 8.5 on UCS

joeharb
Level 5
Level 5

We are upgrading a customers CallManagers and have upgraded the existing servers to 7.1(3b).  We have installed 7.1(3b) on the UCS server and restored from a DRS backup successfully.  Our goal is to leave the phones/users registered to the physical hardware until we have the UCS version @ 8.5. When we attempt to upgrade the UCS version to 8.5 we get an error:  Upgrades are prohibited during Licensing Grace Period.  Do I have to go through licensing@cisco.com and have the license from the physical server rehosted, if so will this disrupt the license on the servers in production?  Has anyone had this issue, if what was the resolution?

Thanks,

Joe

15 Replies 15

Adam Thompson
Level 4
Level 4

Yes, you will have to rehost the appropriate licensing to the new CUCM installation. When you get the license rehosted, it will not disrupt the current production server. Basically, you will need to copy down the old licenses, supply them to the Cisco Licensing team, and they will send you what you need for the upgrade.

HTH

Adam

I have several licence files on the existing server, do I have to send all of them or is there something specific?

Cisco will ask for all of the applied licenses. They will combine them and send you back one file tied to the new MAC, containing all of the necessary DLUs and nodes.

HTH

Adam

Rob Huffman
Hall of Fame
Hall of Fame

Hi Joe,

I just wanted to reference this bug as well to add to the great tips from Adam (+5"A")

CSCtb86875 - Upgrades are prohibited during License Grace Period

Description

Symptom:

After Disaster Recovery System (DRS) backup is done on the old server, we DRS restore all the data into the newly replaced server. The license file for old server is valid for 30 days.

During license grace period, you can not proceed due to the upgrade error message "Upgradeds are prohibited during License Grace Period".

Conditions:

It only occurs after DRS backup and restore data to newly replaced servers.

One example of an erroneous document:

http://www.cisco.com/en/US/partner/docs/voice_ip_comm/cucm/install/7_1_2/cluster/clstr712.html#wp87717

The problem is steps 7-9.  The order should be:

7. install the same version

8. restore the DRS backup

9. upload the new license file

Workaround:

If license is uploaded before DRS restore then use the following steps to correct the state of licensing on the system:

1. Remove the rehosted (new) license files using cli commond "file delete xxx.lic"

2. Restart license manager.

3. Re-upload the rehosted (new) license files.

Details

1st Found-in:                          (1)

7.1(3.10000.3)

Status:

Open

Last Modified:

Oct 18,2011

Product:

Cisco Unified Communications Manager (CallManager)

Platform:

Dependent

Severity:

3 - moderate

Customer Reported:                          (105)

Cheers!

Rob

The bug seems to fit exactly what I am experiencing.  I am not sure which direction I should go, should I delete licences or should I copy all 15 or so license files and get them to rehost?  If I do delete is there a specific licence I need to delete?

Joe,

No matter what, you will need to get the license files rehosted. The bug that Rob is referencing occurs when you have uploaded the newly rehosted licensing, then restored from DRS. In your instance, you have not uploaded a rehosted license file yet, so you shouldn't have to delete any license files.

Once you upload the new license file, you should be able to proceed with your upgrade.

HTH

Adam

Rob Huffman
Hall of Fame
Hall of Fame

Hi Joe,

I think both things come into play here. You will still need

the new licenses as Adam suggested as well as doing the workaround

shown in the Bug details.

Cheers!

Rob

Reading the bug details again, you may have to do as Rob suggested and upload the new license as well as delete the old ones.

-Adam

Rob Huffman
Hall of Fame
Hall of Fame

Hi Joe,

Really, I think a TAC case is your best bet here as I've seen some references

that indicate that root aceess may be required or at least greatly mitigate

this issue. I would try that as your first step. They can help work with licensing@cisco.com

as well

Cheers!

Rob

I have sent an email to licensing@cisco.com with all license files attached requesting the rehost, will update on the results.

Thanks for the responses hope to be able to rate them highly .

Joehard , how did it ends for you.

I'm running into the same problem , and I'm curious to find out how you got it resolved.

In my case, I got the license rehomed but CUCM doesn't want to load any of them.

Thanks

Had to get tac involved to get a new license. This was a lot harder than expected but once we got the right people involved it worked without issue

Sent from Cisco Technical Support iPhone App

Do you remember how TAC solved this problem? I got the same issue, and this was my process. I'm upgrading from 7.1.5.10000-12 on MCS to 8.6 on UCS.

1. DRS backup production 7.1.5.10000-12 on MCS

2. Install 7.1.5.10000-12 on a VM. Yes, I get that it's not supported, but it should still work. I've done numerous upgrade from 4.x to 7.x on a VM to 8.x, and it always worked.

3. DRS restore

4. Now trying to upgrade to 8.6 and getting this error "Upgrades are prohibited during Licensing Grace Period"

It's gotta to be some simple trick with license files that could fix this. I tried installing rehosted NODE/PHONE license to the license mac, that didn't help. I tried removing all licenses, that also didn't help.

Do you remember what was the trick?

You need to delete the licexpiry.txt file

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186
a0080a6c01a.shtml#grace

I had to open a TAC case for that since you don't have access to that file.

If you don't have TAC support then maybe this can help.

I haven't tried it so I have no idea if it works

http://blog.recurity-labs.com/articles/jail-breaking_cisco_unified_communication_manager/index.html