cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
2678
Views
15
Helpful
8
Replies
Paul Freiberg
Beginner

HTTP 404 after enabling SSO

Hi all,

 

in our test cluster (12.5 CUCM/IMP) we enabled SSO.

During the enable process the admin account login test was successful.

Now I see additional links on the main CUCM web page:

Recovery URL to bypass Single Sign On (SSO)

But behind each of that links now I get:

 

HTTP Status 404 ? /ccmadmin/localauthlogin

type: Status Report

Message: /ccmadmin/localauthlogin

Description: http.404

or

HTTP Status 404 ? /ucmuser/localauthlogin

type: Status Report

Message: /ucmuser/localauthlogin

Description: http.404

...

Even that bypass links don't work.

Has anyone experienced the same?

 

Best Regards

Paul

1 ACCEPTED SOLUTION

Accepted Solutions

Yeah, there is a bug where a database field doesn’t get flipped from 0 (SSO off) to 2 (SSO on) and it causes the WAR file to fail after enabling SSO. You see it as a 404. I believe the defect is CSCvg50338:
https://quickview.cloudapps.cisco.com/quickview/bug/CSCvg50338

View solution in original post

8 REPLIES 8

Yeah, there is a bug where a database field doesn’t get flipped from 0 (SSO off) to 2 (SSO on) and it causes the WAR file to fail after enabling SSO. You see it as a 404. I believe the defect is CSCvg50338:
https://quickview.cloudapps.cisco.com/quickview/bug/CSCvg50338

View solution in original post

Hi @Jonathan Schulenberg ,

 

"great" the workaround helped me. Thanks a lot for that info!

Hi All,

 

May I check what is the workaround? enabled SSO, encountering the issue now...

 

Thanks!

After I forward the instruction from https://quickview.cloudapps.cisco.com/quickview/bug/CSCvg50338.

**Applied: run sql update processnode SET tkssomode = 2 where name = 'CUCM HostL'

I can reach the ccmadmin, but it is required "SSO" sign in, and I can't enable "SSO" from GUI.

 

Any idea to re-activate SSO? thanks!

 

 

You should not do that DB update before you have SSO properly setup in your system. Revert the change to the DB and start over again with setup of SSO, then check if you’re hit by the defect. If you are do the workaround again.

Please rate all useful posts

I had the same issue with a version of CUCM that was in the list of known fixed releases. Applied the cli sql command to enable SSO and it's working. Thanks for this post!

Thank you - That worked for me on CUCM ver 12.5

Many Thanks ! I'm hit this bug with cucm vers 12.5.1.13900-152 and the workaround works well.
it's incredible that the sso in cucm is not fixed also with this very recent release 

Content for Community-Ad

Spotlight Awards 2021