cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1933
Views
3
Helpful
9
Replies

Internal calls (dial by extensions) don't work in Webex Calling

Dmytro Benda
Spotlight
Spotlight

Hello people, 

Recently we've got our own tenant in Webex Calling (at the moment it is with evaluation licenses for testing). We created several users in Webex control hub and assigned extensions to them like 2110, 2120, 2130, etc. When the users login to Webex App with their accounts, all goes well - they are in, the App shows the number and all looks cool. 

However, these users can't even make internal calls to each other when they dial by extension from App to App. Let say the user with extension 2110 dials 2120 and the call fails. The user hears the message from Webex Annunciator like: "We're sorry, but your call can not be competed at this time..." 

But if we try to dial by the URI like user@domain, then the calls are completely ok - the destination App rings, the recipient can answer the call. 

We checked all possible settings at user level and at our organization level (like Do not Disturb, CFW, internal call settings and others), however no luck. In the reports we do not see failed calls - they are not shown. I tried to download the logs from Webex Control Hub, but the system shows me no logs for these calls as well. 

May be someone dealt with similar issue in the past? Any ideas what to check? And please tell me, if there is any way how to see the failed calls and how to download traces\logs for calls? In CUCM it is not a problem to troubleshoot a failed call at all, but cloud is another story. We created, of course, a case at Cisco TAC, however, they haven't responded to us for over a week.

Thanks in advance for any assistance. 

2 Accepted Solutions

Dmytro Benda
Spotlight
Spotlight

Hi all, 

The issue with internal calls by extensions has been solved. Our problem was at Calling -> Location settings. Unfortunately we didn't pay attention to this warning there (lack of experience with cloud) :

DmytroBenda_0-1679057977423.png

So we didn't assigned a main number to our location and this was the reason of such system behavior. We modified it as follows (added one of our PSTN numbers):

DmytroBenda_1-1679058156392.png

Immediately after that the internal calls started working and now the users can dial by extensions too. @Jonathan Schulenberg and @kgroves42 many thanks for your participation. 

 

View solution in original post

lisa_lennon
Beginner
Beginner
Make sure you have set a main number on your location. If no main number, you can't make any calls.

View solution in original post

9 Replies 9

lisa_lennon
Beginner
Beginner
Make sure you have set a main number on your location. If no main number, you can't make any calls.

hi @lisa_lennon 

Yeah, you are right. We found it as well ourselves just before your message. Thank you, anyway. We are just starting working with the cloud, so it is a good experience. 

Dmytro Benda
Spotlight
Spotlight

Hi all, 

The issue with internal calls by extensions has been solved. Our problem was at Calling -> Location settings. Unfortunately we didn't pay attention to this warning there (lack of experience with cloud) :

DmytroBenda_0-1679057977423.png

So we didn't assigned a main number to our location and this was the reason of such system behavior. We modified it as follows (added one of our PSTN numbers):

DmytroBenda_1-1679058156392.png

Immediately after that the internal calls started working and now the users can dial by extensions too. @Jonathan Schulenberg and @kgroves42 many thanks for your participation. 

 

Jonathan Schulenberg
Hall of Fame
Hall of Fame

Is Calling > Service Settings configured for four-digit extensions without a site prefix? If not, set that and reboot the physical phones / quit and relaunch the Webex app. Unlike CUCM the endpoint is given dial strings to recognize locally; it doesn’t blindly send each digit as the user dials it and expects the PBX to figure out the significance. Far more efficient TBH.

Hi @Jonathan Schulenberg 

Thank you for your answer. We tried both default settings and 4-digit extension setting too, the Apps were restarted, but it didn't help. The settings were as follows (please see screenshots): 

DmytroBenda_1-1679047444622.png

DmytroBenda_0-1679047417631.png

What is interesting - as Cisco Collab Instructor I have an account at another Webex Calling tenant. In that second tenant there are also 4 digits long Extensions, and default Service Settings like Internal Extension Length = None. However, the calls by extensions in the second tenant work pretty fine. 

There are a couple of things I would check. 

It is odd how you can dial a Webex URI but not an extension. That almost seems like a licensing issue as those are two different licenses. 

kgroves42_2-1679049668044.png

 

kgroves42_0-1679049424481.png

But since you have an extension assigned to a user it sounds like the license is good. 

the other place to check  is under the User go to Calling --> Outgoing Call Permissions. and make sure that user can dial internal calls. 

kgroves42_1-1679049570569.png

 

hi @kgroves42 

Thank you for your suggestions. The licenses seems to be ok, please see the screenshot at user settings level:

DmytroBenda_0-1679050405564.png

As for Outgoing Call Permissions - we tried both default settings and Custom settings where all is enabled. Unfortunately we can't still make it work. Our custom settings are almost same as yours (we allowed International calls as well): 

DmytroBenda_1-1679050533092.png

OK can you dial the Voice Mail Portal Number for your location? 

Is everyone in the same location? 

Also do you have a PSTN Connection setup for your location? 

We found the solution. I will write a message soon with screenshots. Thanks for your participation. I appreciate it

Getting Started

Welcome to the Webex Community. This is your home to ask questions, share knowledge, and attend live webinars.