Showing results for 
Search instead for 
Did you mean: 

Room Navigator and Touch 10 - Button for Microsoft Teams Mystery

Level 1
Level 1

We have several Room Kits in our organization which we have been using with good results. Some of them are managed with Touch 10 tablets, others with Room Navigator tablets.

We recently added licensing to allow the joining of Microsoft Teams meetings on the devices. We've had a really mysterious result that we cannot figure out that I am hoping someone here can.

In Control Hub, we have enabled Teams and Zoom as meeting providers under Devices > Settings. Our expectation was that this would place buttons on the tablet screen same as Webex.

In the case of Zoom, this happened right away. Each device's tablet shows a Zoom button on the home screen which can be tapped to enter Zoom meeting info, after which the meeting can be joined.

This isn't the way it worked with Teams. For several days, nothing showed up on the tablet screen to allow any interaction with Teams at all. The only way to join a Teams meeting from one of the devices was to invite the room where the device lives to the meeting as a resource. This allowed a Teams meeting to be joined via OBTP.

Until suddenly, one tablet - and only one tablet - suddenly began displaying a button for Teams on the home screen. We made no changed to any configurations at all, either at the global or the device level. One day there was no Teams button, and the next day, there just was.

What could possibly have caused this? The only thing I could come up with was the fact that we had previously joined a Teams meeting with OBTP in the room where the Teams button suddenly appeared. But the meeting was several days prior, and experiments with joining meetings with other devices in other rooms did not give the same result.

We're totally baffled. Anyone ever seen anything like this, or have guidance on what we might be missing?



1 Reply 1

Jonathan Schulenberg
Hall of Fame
Hall of Fame

That button has been stuck in beta for months. The reasons are probably covered by NDA, so I won’t go into them here, but it’ll ship sometime before the heat death of the universe.

The only endpoints that should see it right now are those assigned to the beta software channel in Control Hub. If you’re seeing it on a preview or stable channel device it’s arguably a bug and a valid TAC case.