Showing results for 
Search instead for 
Did you mean: 

Aironet 1100 giving out weird IP addresses

Level 1
Level 1

I've read that the Aironet 1100 isn't supposed to be a DHCP server. However, I have two laptops with wireless capability and when I turn them on they connect wirelessly and get an IP address in the 169.254.147.x series with no default gateway.

Our network has a DHCP server configured to give out addresses in the 166.x.x.x range. When I connect the laptops to the network by wire, they get the correct addresses. And I know they aren't connecting to some rogue wireless access point somewhere because the web-based config for the Aironet shows them with the 169 addresses.

What's going on? How is the 1100 assigning these weird addresses, and how do I turn that off to make the laptops get their addresses from the legitimate DHCP server?


Ken Long

San Luis Obispo, CA

7 Replies 7

Level 1
Level 1


The 169.254.147.x addresses are the IP addresses that a Windows machine will allocate "itself" if it is unable to contact a DHCP server at all. This is true for both wired and wireless clients.

Try an "ipconfig /renew" on one of the wireless clients. You will see that it has been unable to contact the DHCP server.

Can't comment on why DHCP doesn't work.. however past experience tends to suggest that you might have broadcast key rotation turned on. That normally screws DHCP up nicely. Are the wireless clients associating with the AP..?

I've got the above running in my home office (DHCP server is 1700 series router) with no problems....

Regards, Barry

Thanks very much for the quick reply. The wireless clients are associating with the AP, as they are displayed in the list in the web-based setup. If I then go and put in a static IP address on the client, it works fine. I did the ipconfig /renew and you're right- no contact with the DHCP server.

Broadcast key rotation is turned off... in fact I haven't even tried to do WEP yet because I'm just getting this off the ground.

Do you have any other ideas? Are there any other settings I should check? Any services that should be running to pass DHCP requests through?

Thanks again!


Ken the AP 1100 is a bridge in network terms as such it does not have a bearing on layer3 and above packet such as DHCP passing through it.

I would guess you have a network problem between the DHCP server and AP try a sniffer on the ethernet side of the AP and you should see the DHCP probes

you can also try setting it to receive a dhcp address and see if it can get an IP address from your DHCP server

BTW you can configure the 1100 to act as a DHCP server but has some limiations here are the details

You were right... there was indeed a problem with the DHCP server. We have it configured with a small pool of addresses and it had simply run out! They were set to 4-day leases which wasn't good... I reset it to 1-day and cleared out the old leases and all is ok now. Thank you for your help!


I have an issue that is not quite the same, but does relate due to the fact that I am assigning a specific IP address to a designated MAC address via DHCP server. I have AP1200 running IOS, utilizing LEAP,MIC, and TKIP. I currently have a trunk connection between a 5509 and the AP allowing 2 vlans on the trunk. One vlan is for mgmt purposes and the other is the user segment to which are wireless clients. The strange thing is the WLAN client will obtain a DHCP address if it is truely dynamic, however, if I assign a specific MAC address to a specific IP address via the DHCP server, the WLAN client cannont obtain the IP address. The reason why I do it this way is another story, but I don't understand if both requests are going to the same DHCP server why the WLAN client cannot obtain both ways if one way works. Any ideas

So if there's no change to the IP settings on the client (all set to dynamic) and you have no assignment on the DHCP server, it works, but if you assign that MAC address on the DCHP server to a specific IP address, the client can't get the IP address?

One thing I found out was that my DHCP server was leasing IP addresses for four days by default. I don't know if it'll help, but maybe you should try clearing out all the old leases and making sure it's only leasing as long as you need it to?

It doesn't solve the problem, but if we actually solved every problem we'd never get anything done... how about just assigning that client a static IP address?

From the client and wireless network the 2 methods you have described are identical

The client will follow the normal method of a broacast DHCP probe then the DHCP server should reply etc etc

I would suspect you have a problem with the config of the DHCP server when trying to hand out the fixed address. It maybe as simple as a typo in the MAC address ??

A sniffer will prove that it is getting to the DHCP server and see what replies if any you are getting from the DHCP server

Review Cisco Networking products for a $25 gift card