cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1496
Views
45
Helpful
22
Replies
AM8112
Beginner

Scanners Do Not See SSIDs after 5520 WLC Update to Version 8.10.151.0

Hello, 

 

We have a group of scanners - Intermec CK3X - that did not reconnect to the WLAN after we upgraded our WLC to version 8.10.151.0. We were at 8.5.151.0. I did not make any config changes with the update, but now I have been tinkering with different settings to see if we can make it work, but so far nothing. They are 802.11abg. These are the only devices not connecting to our wireless. 

 

The only positive change we saw was when I unchecked the "Client Exclusion" checkbox under the WLAN in Advanced Settings. The client saw the AP for a bit, however, identified it as the wrong L2 security (even though it was configured the same as the settings defined in the WLC), then just dropped it again. These devices do not see any of the wireless controller's SSIDs, however, does see any other rouge SSIDs. 

 

Looking at the data sheet of the device, I saw that it supported data rates of 1, 2, 3 Mbps. So I added that in our Data rates for the 802.11b/g Global Parameters. 

Data Sheet: 

https://www.martindaleassoc.com/files/128205181.pdf

 

I did not see any positive change for that either.

 

We have spoken with their tech support and tried numerous things (factory rest, different security profile, etc), but that didnt help either. It has to be something with the update, since they did work prior, but I am not sure what. Maybe a setting is needed and I am just missing it. 

 

I appreciate any feedback. 

 

Thank You 

1 ACCEPTED SOLUTION

Accepted Solutions
AM8112
Beginner

Thank you everyone for your suggestions, I worked with TAC and the issue has been resolved. The issue was that these scanners are compatible up to CCX version 4, with this new update, it updated CCX to version 5. We disabled it by unchecking "Aironet IE" under WLAN settings in the Advanced tab. After doing that, the scanners were then able to see the WLAN and associate! 

View solution in original post

22 REPLIES 22
MHM Cisco World
Collaborator

...

Hi, 

 

Radio config as the rf-profiles, correct? Yes, I have compared the configs of pre-update and today's and all of the "config rf-profile" are the same. I am still reviewing/comparing the rest of the config though.  

 

Also, yes, they are broadcasting their SSIDs. All other wireless clients can see the networks except for these scanners. 

 

Thanks 

Scott Fella
Hall of Fame Guru

You should run a diff between the previous good config and the new configuration after you upgraded. See if there is a setting that has changed like WPA3 being enabled or another setting that was added or changed.
Typically I would say revert back and then test in the lab, this way you limit the downtime and poor user experience.
-Scott
*** Please rate helpful posts ***

Hi, 

 

Yes, I am comparing the pre-upgrade config and today's config right now. I would have already reverted, however, they aren't needed today so I have some time to work on them. Honeywell/Intermec is also reviewing what Cisco changes have been made with this latest update to see if there is some sort of incompatibility issue with their device.   

 

Thanks 

AM8112
Beginner

UPDATE: After seeing no config differences, attempting many troubleshooting steps, I ended up reverting to the previous image and now all of the scanners are once again connected / see all of the SSIDs. I will just have to lab it out and continue to work on this with Honeywell/Intermec. Thanks 

Leo Laohoo
VIP Community Legend

Get Cisco TAC involved as well.

What kind of WLAN is it - Open/WPA-PSK/802.1x?

 

Check the Security - Layer 2 tab of the WLAN - there are some new options there which may be enabled by default - like WPA3 and SHA2 - check those.

 

Check https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvm44842 and https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvu24770

 

Hi, 

 

It is WPA2 - PSK

 

I did check those, I even thought that maybe the mixed mode of WPA2 + WPA3 may have been the issue, so I tried WPA + WPA2 and that didnt fix it either. 

 

I checked out those links:

CSCvm44842 - We dont have 802.11v BSS Transition enabled. 

CSCvu24770 - Thats an interesting one. These scanners are not Android, they are running Windows 6.5.3. 

 

Thanks! 

....

Hi, 

 

I have taken the scanner near an AP and I have enabled all Data Rates when I was troubleshooting, but nothing. 

 

Thanks 

I will 

> they are running Windows 6.5.3.

Hmmm is that like a very, very old version of Windows embedded or something?

Anyway sounds similar to another problem.  Older Intel drivers ignore 802.11ax (WiFi 6) beacons - they "can't see" the SSIDs.

See https://www.intel.co.uk/content/www/uk/en/support/articles/000054799/wireless.html

So it may be this if you have WiFi 6 capable APs or something like this.

The point is - what MHM Cisco World says is not necessarily correct.  Software bugs *can* cause this type of fault due to incompatibility. 

Of course do check data rates but get TAC to assist with troubleshooting otherwise.

Hi, 

 

Yep, old Windows Embedded. And this sounds very similar, however, its any network, not just WiFi 6 WLANs. I even disabled .11ax on the WLAN in question / the one I was trying to authenticate these scanners to and still saw nothing. Or maybe just because it was enabled on the other WLANs, caused this issue

 

Thanks 

It's weird that there was no config diff from the two versions you have.  Typically there is.  

-Scott
*** Please rate helpful posts ***
Create
Recognize Your Peers
Content for Community-Ad