cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1073
Views
5
Helpful
7
Replies
Pad22
Beginner

Trouble seeing Google Home devices between APs - Cisco 2504

History:

My previous network setup was two Asus APs, one acting as the gateway/router and the other acting as an AP.  I have 5 Google Home devices and they were previously connected to the AP closest to each location.  I upgraded this network with a Cisco 2504 and three AIR-AP1852I-A-K9 Access Points over POE.  The connectivity is great and all Google Home devices can access the internet themselves.  The 2504 WLC is running 8.5.140.0.

 

Problem:

I can't see all of the google home devices at once from my phone (when trying to cast for example).  The Google Home app on my phone only lists a couple of the devices, and it *seems* to be based on the AP that I'm connected to.  If I'm connected to an AP that has no other Google Home devices connected to it, then I can't see any Google Home devices in the Google Home app (nor can I cast to them).  The final problem that I ran into today was that I was unable to print from a laptop on the new WiFi network to a printer on the old WiFi network.  When I jumped onto a wired desktop, I was able to print to the old WiFi connected printer.

 

What I've done so far:

I thought that this was a AP Isolation issue and looked into Multicast and mDNS.  From what I have read about chromecast, these seem to be the settings that I need to modify.  However, I have yet to find any information about specifically Google Home devices and what settings need to be changed so that they all appear to be accessible from anywhere on the network.

 

I have tried to keep the setup simple: I have one WLAN

WLAN - Advanced:

* P2P Blocking Action = Disabled

 

Controller - General:

* Broadcast Forwarding = Enabled
* AP Multicast Mode = Multicast (239.1.2.3)

Controller - Multicast:

* Enable Global Multicast Mode = Checked

* Enable IGMP Snooping = Unchecked

* Enable MLD Snooping = Checked

 

Controller - mDNS:

* mDNS Global Snooping = Checked

 

I need some help and ideas as to what I need to change next to get these google devices working.  Thanks in advance!!

1 ACCEPTED SOLUTION

Accepted Solutions

With everything in the same VLAN, you wouldn't need mdns as this is just to bridge multicast traffic to users in separate VLANs.  On your WLAN disable mdns snooping. On the Controller>Multicast tab make sure multicast is enabled. I would enable IGMP snooping as well but you don't have to. Test this and see if it resolves your problem.

 

If you have a contract on any of your devices I would suggest opening a TAC case. If you do, let me know the sr #.

View solution in original post

7 REPLIES 7
patoberli
VIP Advisor

This might help in your scenario:
https://www.cisco.com/c/en/us/support/docs/wireless-mobility/wireless-mobility/119017-config-chromecast-mdns-wlc-00.html
Also don't forget to reboot the google home devices after you make configuration changes.

Ok, this helped, THANKS.  Not resolved yet, but I see a light at the end of this tunnel :)

 

There was one setting that I missed.  I did not setup a separate VLAN for the chromecast / google home devices.  So, at the bottom of my only interface (Controller --> Interfaces) I had not set the mDNS there.  Once I selected the "default-mdns-profile") there, I started to see all of the google home devices in the Google Home app.

 

I also had Fast Transition (WLAN --> Security --> Layer 2) set to Adaptive.  The article mentioned to disable this, but I haven't seen evidence that it does anything.  Is this a critical setting?

 

However, they do not consistently show up in Amazon Music or Spotify.  I can see some devices, say 2 devices, and then when I refresh the list, one more pops up.  If I refresh again, I'll lose one of those devices.

 

What would be causing this inconsistency?  I've turned on Multicast Forwarding to see if that helps see all of the devices more consistently.  I'm going to go around and restart all of the google home devices.

 

What else am I doing wrong?  Should I have more than one interface?  If I go into Controller --> mDNS --> General and click on the Googlecast service, I can see all of the google home/mini devices.  The TTL is 4500 seconds, but the Time Left never goes below 4450.

 

Lots of questions - Thanks for your help so far, we're making progress!!

Jay Vivas
Cisco Employee

Are your APs and WLC in the same subnet?

Yes.

 

APs:

Screen Shot 2020-02-19 at 6.11.54 PM.png

WLC:

Screen Shot 2020-02-19 at 6.12.48 PM.png

 

Clients (including google home devices):

Screen Shot 2020-02-19 at 6.13.42 PM.png

With everything in the same VLAN, you wouldn't need mdns as this is just to bridge multicast traffic to users in separate VLANs.  On your WLAN disable mdns snooping. On the Controller>Multicast tab make sure multicast is enabled. I would enable IGMP snooping as well but you don't have to. Test this and see if it resolves your problem.

 

If you have a contract on any of your devices I would suggest opening a TAC case. If you do, let me know the sr #.

View solution in original post

Hi Jay,

 

Success!  I turned off mDNS on the WLAN and turned off mDNS Global Snooping in the Controller.  I made sure everything was checked in Controller -> Multicast.  Once I did that, everything just started working.  I didn't have to reboot any google devices or have to wait for any length of time.  Right now everything is working. 

 

Here are my settings if anyone else ever has problems getting Google Home devices working on a basic network:

 

I have one interface.

I have one WLAN.

WLAN -> General:

Multicast VLAN Feature: Enabled

Multicast Interface: Set to the only Interface

WLAN -> Advanced:

Aironet IE: Disabled

P2P Blocking Action: Disabled

mDNS Snopping: Disabled

Controller -> General:

Broadcast Forwarding: Enabled

AP Multicast Mode: Multicast 239.1.2.3

Controller -> Multicast:

Enable Global Multicast Mode: Checked

Enable IGMP Snooping: Checked

Enable MLD Snooping: Checked

Controller -> mDNS -> General:

mDNS Global Snooping: Unchecked

 

Lastly, I currently have WLAN -> Security -> Layer 2 -> Fast Transition Disabled.  I may turn that back to adaptive and test to see if I lose any functionality.  FYI.

 

Those are the settings that I recall having to adjust based on reading articles and the help on this forum.

 

Thanks everyone for your time and help - hopefully this helps someone in the future :)

 

Please mark the answer as an accepted solution so others will know they can find the answer here.

Content for Community-Ad