cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
25362
Views
57
Helpful
44
Replies

Trying to get AIR-AP1562I-E-K9 to Join WLC

jbo@Thisted.dk
Beginner
Beginner

Hey

Hope you can help regarding this Isue

WLC AIR-CT5520-K9 

Running 8.3.121.0 

 

I have added to MAC address on the label in side of the AP to the Controller.

Advanced - Security - Mac Filtering - Any Wlan

 

But I keep getting this error from the AP

[*08/29/2017 08:59:00.4886] CAPWAP State: Discovery
[*08/29/2017 08:59:00.4897] IP DNS query for CISCO-CAPWAP-CONTROLLER.skoler.thisted.dk
[*08/29/2017 08:59:00.4926] DNS resolved CISCO-CAPWAP-CONTROLLER.skoler.thisted.dk
[*08/29/2017 08:59:00.4927] DNS discover IP addr: 10.5.1.15
[*08/29/2017 08:59:00.4944] Discovery Request sent to 10.5.1.15, discovery type DNS(3)
[*08/29/2017 08:59:00.4955] Discovery Request sent to 255.255.255.255, discovery type UNKNOWN(0)
[*08/29/2017 08:59:00.4956] Discovery Response from 10.5.1.15
[*08/29/2017 08:59:01.0000] Discovery response from MWAR 'WLC01'running version 8.3.121.0 is rejected.
[*08/29/2017 08:59:01.0001] Failed to decode discovery response.
[*08/29/2017 08:59:01.0001] CAPWAP SM handler: Failed to process message type 2 state 2.
[*08/29/2017 08:59:01.0001] Failed to handle capwap control message from controller - status 4
[*08/29/2017 08:59:01.0001] Failed to process unencrypted capwap packet 0x2334000 from 10.5.1.15
[*08/29/2017 08:59:01.0001] Failed to send capwap message 0 to the state machine. Packet already freed.
[*08/29/2017 08:59:01.0001] IPv4 wtpProcessPacketFromSocket returned 4

 

After a while failing the above ending in this

[*08/29/2017 09:04:01.9860] CAPWAP State: Discovery
[*08/29/2017 09:04:01.9871] IP DNS query for CISCO-CAPWAP-CONTROLLER.XXXX.XXXX.dk
[*08/29/2017 09:04:03.3293] DOT11_DRV[0]: set_channel Channel set to 4
[*08/29/2017 09:04:03.5923] DOT11_DRV[1]: set_channel Channel set to 112
[*08/29/2017 09:04:05.5272] DOT11_DRV[0]: set_channel Channel set to 5
[*08/29/2017 09:04:05.7945] DOT11_DRV[1]: set_channel Channel set to 116
[*08/29/2017 09:04:07.7255] DOT11_DRV[0]: set_channel Channel set to 6
[*08/29/2017 09:04:07.9797] DOT11_DRV[1]: set_channel Channel set to 132
[*08/29/2017 09:04:09.9126] DOT11_DRV[0]: set_channel Channel set to 7
[*08/29/2017 09:04:10.1709] DOT11_DRV[1]: set_channel Channel set to 136
[*08/29/2017 09:04:12.1082] DOT11_DRV[0]: set_channel Channel set to 8
[*08/29/2017 09:04:12.3631] DOT11_DRV[1]: set_channel Channel set to 140
[*08/29/2017 09:04:14.3061] DOT11_DRV[0]: set_channel Channel set to 9
[*08/29/2017 09:04:14.5484] DOT11_DRV[1]: set_channel Channel set to 100
[*08/29/2017 09:04:16.5042] DOT11_DRV[0]: set_channel Channel set to 10
[*08/29/2017 09:04:16.7341] DOT11_DRV[1]: set_channel Channel set to 104
[*08/29/2017 09:04:16.9988] DNS resolved CISCO-CAPWAP-CONTROLLER.XXXXX.XXXXX.dk
[*08/29/2017 09:04:16.9989] DNS discover IP addr: 10.5.1.15
[*08/29/2017 09:04:17.0002] Discovery Request sent to 10.5.1.15, discovery type DNS(3)
[*08/29/2017 09:04:17.0014] Discovery Request sent to 255.255.255.255, discovery type UNKNOWN(0)
[*08/29/2017 09:04:18.7023] DOT11_DRV[0]: set_channel Channel set to 11
[*08/29/2017 09:04:18.9195] DOT11_DRV[1]: set_channel Channel set to 108
[*08/29/2017 09:04:20.9001] DOT11_DRV[0]: set_channel Channel set to 12
[*08/29/2017 09:04:21.1236] DOT11_DRV[1]: set_channel Channel set to 112
[*08/29/2017 09:04:23.0856] DOT11_DRV[0]: set_channel Channel set to 13
[*08/29/2017 09:04:23.3248] DOT11_DRV[1]: set_channel Channel set to 116
[*08/29/2017 09:04:25.2683] DOT11_DRV[0]: set_channel Channel set to 1
[*08/29/2017 09:04:25.5099] DOT11_DRV[1]: set_channel Channel set to 132

 

 

Anyone Knows what I am doing wrong!

 

Regards 

Johnni

44 Replies 44


@rcaofficecx wrote:

My AP didn't join WLC too, untill I did two things:

1. Added AP's MAC address to the filter at Security tab

2. Installed AP BUNDLE in addition to my image


What version of code are you using?

Hi,

 

we have had the same issue with regards of these APs, you have to check the initial firmware version on your AP, if it's newer than tha WLC fw version, the WLC rejects the CAPWAP Join. You've got two options, downgrade the AP's firmware or upgrade the WLC at least to the same version. For outdoor APs, you have to add the AP's mac address to WLC's mac filter under security tab also.

Matkassner
Beginner
Beginner

I have had the same issue with the 1562I on a 5508 running 8.3.133

First i tried to upgrade to 8.5, to see if that would work but it didn't.

Then I realized that the AP was in bridge mode, after i changed it to local mode it connected to controller with no errors.

 

Command:

"capwap ap mode local"

 

That was IT - Thanks! 

 

Regards

Johnni Borggaard

But once the 1562 is in local mode, it won't bridge.  I changed my mode to local, and now I can't change back to bridge (there's no ap-type bridge command on the AP), and there's no bridge mode option under the AP config after the AP joins the controller.  On Cisco, I can only download Mobility Express.  So how do I get my APs back to bridge mode?  

 

I have 5508s running 8.3.133. 

 

Regards,

Eric Nickols

1562 Mesh support is not added in 8.3 release. 

you have to upgrade to 8.5 release. 

 

Please see below link: 

 

https://www.cisco.com/c/en/us/td/docs/wireless/access_point/1560/installation/guide/1560hig/1560_ch1.html#pgfId-1183915

 

The Cisco Aironet 1560 Series Outdoor Access Point (hereafter called the access point or AP) is a wireless outdoor access point which is designed for use in a variety of network configurations. The access point supports wireless client access, bridging, and mesh wireless connectivity.


Note Mesh and bridge modes are not supported in Cisco Wireless Release 8.3 software.


 

************** Please rate Useful posts***************

For what it's worth, I wasn't using mine in mesh mode. I was just working to get it in local mode.  I did have to add the MAC address to allow it on my controllers, as I've had to do with all of the external APs.  Even after that, I couldn't get it working unless I was on 8.5.  Now everything is working great.

This is exactly where I am stuck now as well. Luckily we found out early that we had to change the mode from bridge to local so we can download the image that will support this AP. Currently our WLC 5508 is running a 8.3.141.0 image which was recommended by Cisco TAC to support "mesh" design. Unfortunately since the upgrade I am unable to change the mode from local to bridge so I can join the AP's as MAP. 

 

Last comment recommended going to 8.5 to be able to change the mode. I need to know if I need to upgrade my WLC to 8.5 or 8.4 code to make the mesh work with these AP's 1562e. 

 

FYI I have 2 other 1552 ap's working as a mesh configuration. Thanks for any replies. 

 

AJ 

Hi AJ,

 

Yes, unfortunately you'll have to upgrade to 8.5.  If you do, also make sure that you load the bundle to the WLC.  For my test switch, a 3750X, we had to force the wattage due to another issue (fixed with "power inline static max 30000" to give the 1562e 30 watts).  With 3850s and 9300s I had no power issues.

 

Eric "Stretch" Nickols

Thanks for the quick reply BCHSysAdmins. We will be upgrading the WLC bundle to 8.5 and having the AP's download the image.

This will be a mesh design so no POE, only AC power.

Even with mesh, it will run PoE. Just make sure that you have a good UPS on the switch. If you get a power hit, then you'd have to wait for the switch to load and then for the bridge to come back up (20-30 mins). I trust my switch power over a wall outlet due to dedicated circuits.


Good luck,

Eric "Stretch" Nickols

dzwissler1
Beginner
Beginner

I had this problem as well... I used a simple command and it immediately fixed the issue.

 

AP# capwap ap mode local