09-07-2023 03:23 AM
hello all
I am new to ios xr and after some study i started building a small lab
the lab is to bring eBgp neighborship between one regular ios and ios xr. they are connected directly
cisco ios xr interface ip is 192.168.15.1/24
cisco ios interface ip is 192.168.15.2/24
they both can ping each others.
My configs is below.
================================================
ios XR
================================================
interface GigabitEthernet0/0/0/1
ipv4 address 192.168.15.1 255.255.255.0
no shut
!
route-policy PASS
pass
end-policy
!
router bgp 1
address-family ipv4 unicast
!
neighbor 192.168.15.2
remote-as 5
address-family ipv4 unicast
route-policy PASS in
route-policy PASS out
!
================================================
Regular IOS
================================================
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
!
interface FastEthernet2/0
ip address 192.168.15.2 255.255.255.0
no shut
!
router bgp 5
bgp log-neighbor-changes
redistribute connected
neighbor 192.168.15.1 remote-as 1
!
================================================
with this config i am unable to bring the neighborship up.
please check.
Solved! Go to Solution.
09-07-2023 06:39 AM - edited 09-07-2023 06:47 AM
Hi @TaimurKhan ,
Normally, XR should set the BGP router ID automatically if there is at least one ipv4 address configured locally. It looks like it might not be able to do so in your case for some reason. Try forcing the router ID with the following command:
router bgp 1
bgp router-id 192.168.15.1
By the way, it is a best practice to set the BGP router ID explicitly, rather than let BGP pick one automatically.
Regards,
09-07-2023 04:20 AM
The question confusing here ? heading says EIGRP and Content is BGP
Are you Looking BPG config - can you able to ping each other Routers ?
Advise - use source interface and on IOS activate command.
check below guide can help you :
09-07-2023 04:34 AM
thanks for the reply
heading of the topic is Ebgp not eigrp
i have gone through that full article document and followed it but it is not coming up. although i am able to make eigrp neighborship up.
09-07-2023 06:39 AM - edited 09-07-2023 06:47 AM
Hi @TaimurKhan ,
Normally, XR should set the BGP router ID automatically if there is at least one ipv4 address configured locally. It looks like it might not be able to do so in your case for some reason. Try forcing the router ID with the following command:
router bgp 1
bgp router-id 192.168.15.1
By the way, it is a best practice to set the BGP router ID explicitly, rather than let BGP pick one automatically.
Regards,
09-07-2023 07:02 AM
thanks alot
I have spent hours on fixing this issue. now it is up. thanks once again.
09-07-2023 08:04 AM
You are very welcome @TaimurKhan . There is a few ways you could have gone for troubleshooting this issue.
1. show bgp ipv4 unicast neighbor x.x.x.x detail (as mentioned by @tkarnani )
2. debug bgp (after configuring "logging console debug"). This a good option for lab testing, but need to use it with caution if it is for a production network.
Regards,
09-07-2023 06:45 AM
on XR
show bgp ipv4 unicast neighbor x.x.x.x detail << this output usually gives some clue as to why its down
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide